Welcome to discussions

Quick Suggestions

  • PolarCoded
    1 posts

    My fight with one of the Daughters of Lerion Cordelia seems to be glitched. I was able to attempt the fight twice before the prompt on the body disappeared. I’ve tried loading saves from an hour before the first attempt but no luck. Any suggestions would be very appreciated.

  • Ubi-Woofer
    Ubisoft Support Staff 1050 posts
    Best Answer

    Hello everyone,

    We announced last night that TU 1.1.1 will launch today on January 14th, and I am pleased to say that in this patch is the fix for the Daughters of Lerion encounter with Cordelia whereby the corpse cannot be interacted with to start the fight.

    Once the update has been applied and you have fully updated your game, you should find that you are able to interact with the corpse upon returning to her lair in Berkelow Bog in East Anglia. Please give this a try once the patch is released, and let me know here in this thread if you encounter any further issues!

    I would like to thank you all for bringing this issue to our attention, and for providing all of the requested information throughout our investigation of the issue. This thread will remain open if you have any further questions or concerns, and either myself or another agent will respond as soon as possible. Thank you! 🙂

    Official Response
  • IbrahemHosni_95
    2 posts

    @polarcoded I have the same problem as well. It wont respawn when I arrive at the location

  • Zer00nEZer0
    1 posts

    I have nearly the same issue except with the third daughter Cornelia. The first two I have already killed.
    Have tried it three times with different powerlevel but couldn't get her. Now at powerlevel 203 I thought to give it another try but can not 'activate' that corpse anymore. Is there something new to this issue?

  • ValtyrNine
    87 posts

    This also happened to me. The body became uninteractable and I was no longer able to start the fight. The only way I found to fix it was to reload an earlier save that the one that was bugged.

  • ThisWhit3Guy
    1 posts

    Anyone hear back about a fix for this? The sister here is the only one I have left and I'd like to complete this.

  • R4Z0RW0LF
    8 posts

    Cannot interact with NPCs on (Xbox one X). Most notably the Berkcrow Bog sister there just isnt an interact button. I have tried reloading to a previous save and restarting my game but nothing. I also noticed that during seiges some npcs are invincible and can still kill you.

  • jeffertson1987
    11 posts

    I have the same problem with cordelia playing on xbox already got the other 2 please fix this

  • metalmetalrob
    1 posts

    I've seen a few similar posts about this battle, as well as the other two sisters having similar issues with the fights not starting.
    The icon is showing on the map and compass, but there's no prompt to trigger the battle.
    So, I'm reporting that I'm also having an issue in hopes that it get addressed sooner as more bug reports are submitted.
    Kinda annoying being that I've already defeated the other two sisters, lost this battle once, and now I can't restart it in order to progress and finish the mini quest line.
    Hope to see this fixed soon as I've been grinding my face off to get strong enough to defeat them and am now stuck on the last one with no option to complete it.

  • Andresteia26
    1 posts

    Same... I have thos bug to... 😥

  • Vateas
    4 posts

    It is impossible to interact with body on Berkelow Bog. There is no option to interact with it. I tried loading previous save and restarting game, but it did not help.

  • Vateas
    4 posts

    I think that there should be this green glowing ball, to inform me that there is option to interact with body, but as you can see there is no this green ballundefined

  • jeffertson1987
    11 posts

    I have the same problem in east anglia the boss fight in theodort forest corelia its the last one i need to beat please fix this want to compleet thor his armor

  • Mighty_M1tch
    3 posts


    thats the exact same one I’m stuck on too. Completed the other 2 fights but this one has really got me stuck! I can complete the fight on an earlier save, however I can’t do it on a later save.

  • Ubi-Ginge
    Ubisoft Support Staff 257 posts

    Hello everyone, are you still experiencing this issue with starting the fight with Cordelia?

    What platform do you play on? Would you be able to share video footage with us

    Official Response
  • Kadwen_
    8 posts

    @ubi-swaggins I have the same problem on PC. I found the daughter in Spalda Fens. died a few time. decided to go level up. came back and now i can not start the fight as the interact prompt is gone.

    I do not want to have to restart my save to get this done.

  • Wamjimjam
    3 posts

    Same bug with Cordelia on PS5.
    Power level 228 so I don't want to restart the game over this.
    I did try uninstalling the game and reinstalling it, but that did not work.

  • Vizjerei77
    3 posts

    Hi, i have a problem with bugged mystery mission in East England in Berkelow bog on pc.Problem is that i found the corpse, killed Cordelia and i have her "dagger" in inventory, but quest don't want to end. There is still active battlefield and only thing i can do, is to enter this battlefield and leave it xd

  • GrizzleSammich
    1 posts

    I was able to interact and start the battle the first time. After I died, the game reloaded, and I was no longer given the option to interact and start the battle again. I have gone and done other things and come back to it, but still not able to interact. Anyone else have this issue? This is the last daughter I need to beat =(

  • Bir1in
    8 posts

    @GrizzleSammich Have the same issue on Xbox one. Ended up beating the game and the interact icon is still missing.

  • wistak1
    1 posts

    same problem but with Regan

Suggested Topics

Community Details