Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Xeraloth
    1 posts

    I also have the same issue. It occurred when I kept throwing my body at her, reloading and going at her again. Then she killed me one last time and I can't attempt a rematch anymore.

  • Ima4nDAl0reI92
    12 posts

    Ubisoft emailed me this morning about the case I have with them about this issue and they told me that others have reported the same issue and that it’s been sent to the development team. So now it’s just a matter of waiting on them to patch it

  • BIG_UNIT2015
    2 posts

    No still haven’t found a fix hopefully they fix it soon

  • TheKingsNoose
    4 posts

    @ubi-litten

    Was a few days ago (not the best example)
    undefined

  • TheKingsNoose
    4 posts

    @tbtheg234
    It's a known bug, no fix as of yet.

  • PolarCoded
    1 posts

    My fight with one of the Daughters of Lerion Cordelia seems to be glitched. I was able to attempt the fight twice before the prompt on the body disappeared. I’ve tried loading saves from an hour before the first attempt but no luck. Any suggestions would be very appreciated.

  • IbrahemHosni_95
    2 posts

    @polarcoded I have the same problem as well. It wont respawn when I arrive at the location

  • Zer00nEZer0
    1 posts

    I have nearly the same issue except with the third daughter Cornelia. The first two I have already killed.
    Have tried it three times with different powerlevel but couldn't get her. Now at powerlevel 203 I thought to give it another try but can not 'activate' that corpse anymore. Is there something new to this issue?

  • ValtyrNine
    87 posts

    This also happened to me. The body became uninteractable and I was no longer able to start the fight. The only way I found to fix it was to reload an earlier save that the one that was bugged.

  • jeffertson1987
    11 posts

    I have the same problem with cordelia playing on xbox already got the other 2 please fix this

  • metalmetalrob
    1 posts

    I've seen a few similar posts about this battle, as well as the other two sisters having similar issues with the fights not starting.
    The icon is showing on the map and compass, but there's no prompt to trigger the battle.
    So, I'm reporting that I'm also having an issue in hopes that it get addressed sooner as more bug reports are submitted.
    Kinda annoying being that I've already defeated the other two sisters, lost this battle once, and now I can't restart it in order to progress and finish the mini quest line.
    Hope to see this fixed soon as I've been grinding my face off to get strong enough to defeat them and am now stuck on the last one with no option to complete it.

  • Andresteia26
    1 posts

    Same... I have thos bug to... 😥

  • jeffertson1987
    11 posts

    I have the same problem in east anglia the boss fight in theodort forest corelia its the last one i need to beat please fix this want to compleet thor his armor

  • Mighty_M1tch
    3 posts

    @thekingsnoose

    thats the exact same one I’m stuck on too. Completed the other 2 fights but this one has really got me stuck! I can complete the fight on an earlier save, however I can’t do it on a later save.

  • Ubi-Ginge
    Ubisoft Support Staff 127 posts

    Hello everyone, are you still experiencing this issue with starting the fight with Cordelia?

    What platform do you play on? Would you be able to share video footage with us

    Official Response
  • Wamjimjam
    3 posts

    Same bug with Cordelia on PS5.
    Power level 228 so I don't want to restart the game over this.
    I did try uninstalling the game and reinstalling it, but that did not work.

  • GrizzleSammich
    1 posts

    I was able to interact and start the battle the first time. After I died, the game reloaded, and I was no longer given the option to interact and start the battle again. I have gone and done other things and come back to it, but still not able to interact. Anyone else have this issue? This is the last daughter I need to beat =(

  • Bir1in
    8 posts

    @GrizzleSammich Have the same issue on Xbox one. Ended up beating the game and the interact icon is still missing.

  • wistak1
    1 posts

    same problem but with Regan

  • Grikz45
    1 posts
    This post is deleted!

Suggested Topics

Community Details

25
Online
130.3k
Users
22.6k
Topics
117.0k
Posts