ubisoft discussions

Quick Suggestions

  • francezu95
    2 posts

    I have the same problem. Tried Cordelia a few times but was destroyed.
    Now, I cannot interact anymore with the corpse.
    Tried restarting the game but to no avail.

  • Delbertqb1
    1 posts

    @kanjman13 same, I tried to fight the electric daughter after 3 tries of losing at power level 90. I am now power level 250 and still cannot interact with her.

  • bdb384
    1 posts

    Also having an issue getting Cordelia to appear, the prompt isn't showing up on the hanging corpse. I've gotten her to show up before, then after beating the other two daughters it suddenly won't let me.

  • Killjoyno69
    3 posts

    Issue still persist. I've liked the other 2 and I've fought her before but now I can't. Please fix 😞

  • mfam2
    2 posts

    I have tried getting the thor armor set, after I completed the first two Daughters of Lerion the game didn't let me interact with Cordelia to start the boss fight. I have tried restarting, uninstalling, and loading an old save. Nothing is working someone help!

  • TheRaveen
    1 posts

    There's a bug in East Anglia, after 3 deaths I can't interact the mission where you have to kill a boss (sister) to get Thor's armor

  • francezu95
    2 posts

    This issue is occurring for me as well, but with Cordelia. Same thing, tried a few times, to no success; now I can't interact with the hanging corpse.
    Did all other mysteries and wealth that were possible (only the armor at Lerion's palace remains, because I don't have the third dagger) in East Anglia, and I believe I did some main story missions as well (related to Oswald). Managed to defeat Regan in the meanwhile, although I've started that fight several times as well, but no issue occurred there.

    First, I've discovered Goneril and defeated her. Then I've discovered Cordelia and tried the fight but I was massively underpowered and at some point I saw that I cannot interact with the corpse anymore. Decided to leave it for later (as I was destroyed in the fights, did not bother at that time to re-load or try again to interact with the corpse). Some time later on I've discovered Regan and tried that a few times until I managed to defeat her. Now, when going back to Cordelia, the corpse is still not interactable.

    Restarting the game or re-loading another save does not work.

    @Ubisoft, any deadline or date when this is going to be fixed?

  • Opus728
    1 posts

    Same issue on PC
    I cannot interact with the corpse to spawn Cordelia in Berkelow Bog for Thor's Armor. I have killed the two other sisters but I cannot interact with the corpse to fight the final sister.

  • XdeathcoreX
    2 posts

    I have the same issue in PS5.

    I challenged Cordelia a couple of times and lost. After that I decided to upgrade my armor next to the corpse and saved. After that I wasn't able to interact with the corpse anymore.

  • xSTGxBlaCkOuTx
    1 posts

    Having the same issue. (Xbox One)

  • MoKellex
    1 posts

    Same problem in Grantebridgescir. I tried around power level and got destroyed twice and I can't try again and to this point I have a power level around 370. So I want restart the nearly the whole game

  • guest-loH8h5ch
    1 posts

    After trying and failing twice to defeat the witch, I am unable to interact with the corpse to start the fight. Please help

  • REDxDAWN1999
    1 posts

    @guest-loh8h5ch its a big one for a lot of people atm including myself. best just post a video of not being able to see the prompt and keep playin the game. It hit me mid way through the story and im now at the end game and it still has no prompt. will need an update to fix it.

  • SubarcticBobcat
    1 posts

    Xbox one player here

    I am also experiencing this issue, but with Cordelia

  • Vizjerei77
    3 posts

    Now i'm after whole game and i can't force this mystery to end.That's strange, because i even completed mystery where we gain Thor's Helment ,and this mystery in bog still not end.That's the last mystery in this region and i can't complete it because of that bug.

    Also, there is multiple problems with subtitles in Polish langauge ,in many places,quests it looks like someone used google translate ,for example in our inventory we have something like "chest"(upper part of human body) but they translated it by "chest"(box,crate,etc) . There are other multiple problems with this translating ,but the worst part of it is flyting . I understand english but it's nice to have subtitles in your langiage ...and in many ways that translation is awful to this part,that we must change language of interface to complete almost every flyting

  • Ubi-Swaggins
    Community Manager 438 posts

    Hey folks,

    I am sorry to hear that you are having problems with this specific world event.

    Can you provide any videos of the issue from your game?

    Official Response
  • shaiwan43
    54 posts

    I have this issue. Unable to trigger / interact with corpse. I'm at the last daughter and I can't get Thor's armor or finish quest. It's so frustrating.

  • shaiwan43
    54 posts


    Swag, tell the team to reproduce the bug:

    Trigger daughter of lerion fight sequence (any daughter, but for me it mostly was 3rd electricity level 360) (click the corpse), then crash the game or force quit the game mid battle, then re-load and try to trigger it again. Do this several times. If it doesnt work, then trigger the fight sequence, die to the witch, reload previous save. Leave the area (fast travel), come back (fast travel), try to trigger it again. Guarantee it will break the triggering mechanism eventually if you repeat enough times.

  • poleclair
    1 posts

    The "thunder witch" quest doesnt start anymore after a few failed attempt to kill her (the "Press Y" on the corps doesnt show up anymore for me to start the quest.

  • jrovig
    2 posts
    This post is deleted!

Suggested Topics