Welcome to discussions

Quick Suggestions

  • Locked SOLVED [RESOLVED] Unable to progress with "The Demon Odour at the Tithe" as the NPC does not spawn | POST HERE

    1 Likes/144 Replies/5308 Views
    12 posts

    @dooxast reloaded to a save 30min earlier. he came back and i moved everything... now he does not want to leave lol gonna try exit animus i guess and go back in to see if he wants to move.

    thats how i cleared the issue anyhow with the wall not moving.

  • Dooxast
    12 posts

    @atkuna corpse trick - when waiting for a patch is not our choice... I'll try it later... how about returning everything to the beginning, fast travel away, exit the animus and then return?

  • Atkuna
    12 posts

    @dooxast just spent some time doing this. sadly did not work for me, so i guess ill have to wait for a fix from ubi 🤣

  • Dooxast
    12 posts

    in another thread someone said that guy left warehouse after couple of completed quests, and after return to Lunden, he completed it by speek with that guy outside (doesn't work to me)

  • Dooxast
    12 posts

    Well, I have no idea how it happened, but it seems that the corpse trick will not help here...


  • Atkuna
    12 posts

    @dooxast sadly didnt work for me either, so gotta wait for a patch 🙂

  • Atkuna
    12 posts

    that one spawns like that if you dont have the smaller one to block it or didnt reset them before leaving. and i just pushed it back when it happend to me on that one. could just push it back into place from the broad side.

  • guest-G0k90lHo
    4 posts

    This bug has happened to me as well, the description is as follows: The Mystery is called ,The Demon Odour at the Tithe, the man whom is stuck in the shack first does not appear to be there-by some random occurrence- though he is found to be present after cut scenes, or perhaps reloading the game. Once he mysteriously appears we are left to move shelfs and jars out of the way so he can be free, however, one shelf seems to be bugged to where it cannot be moved.
    If the first shelf is moved and the game is reloaded, the shelf will be in the same spot that you moved it to yet this time it will be floating on the jars, this makes it immovable, when one breaks the jars the shelf drops but it has been displaced by the jars and now it lies slightly on the wooden beam barrier on the floor which also makes it immovable. Well, why was the shelf moved in the first place and the game reloaded? This is because the man was not there at first, upon searching the premises for the blue mystery marker that is on the map, one moves the shelfs as it is obvious they have something to do with this world event, hence the first shelf is moved. Only by chance does do we find out that there is a man there after reloading the game.

    The first image shows the first shelf in the sahck spawned on top of jars.

    This second image below shows the jars have been broken and the shelf is displaced leaving it immobile which effectively stops the world event from being completed and thus breaking the "Completionist all the Way" achievement.

  • Atkuna
    12 posts

    @guest-g0k90lho and if you throw a corpse at it it slides back. but yea even when i clear the way my self the guy wont exit sooo.. im waiting for a patch before i bother trying anymore.

  • ThorGodThunder1
    6 posts

    The npc stuck in the warehouse will not leave after the path has been cleared, cant talk to him or anything.

  • UnDyingUK
    10 posts

    So I saw this mystery item marked on the map, I went to the location and found a warehouse with moveable barriers and jars, so I moved the jars and the barriers, and got to the centre, then realised i could of just climbed over the centre either way couldnt work out what I was supposed to do.


    I went online and searched, only to discover that the event that is supposed to happen here didnt, so as the title suggests...

  • elhefe1290
    1 posts

    Same problem for me. Just pushing this thread. Nothing is working with that mystery. Dude inside the storagehouse randomly appears and disappears.

  • MissKylieD
    1 posts

    Hello, everyone! This is my first time here and I have checked the megathreads and known issues but couldn't find anything on this specific issue that Ubisoft has addressed, so I figured I would make a post and try to be as detailed as possible in the hopes that it could better help the fixing process.

    I am currently struggling with an issue with The Demon Odor at the Tithe. The second moveable object floats on top of the jars of garum, and even after throwing a body at the object to shift it back into place where it is able to be moved, a new problem occurs where the stuck man then becomes unresponsive as a result of the jars inevitably breaking (and both Eivor and the stuck man toss their cookies), which means that whether or not you move everything out of the way, it doesn't matter since the stuck man won't move or respond to anything, he just starts muttering to himself. I believe this issue starts out with the ability to enter the building before the completion of the Lunden Arc, as the stuck man doesn't appear until the Lunden Arc is finished.

    At the time of this message, I have tried restarting the game/console, traveling in and out of the zone/region, going to and from England and Norway, finishing the Lunden arc to potentially reset the area, among other possible fixes, but I have yet to prevail and finish this mystery.

    I hope it's possible to fix this with a patch (possibly by allowing a reset of the mystery area to move everything back to its original positions, as I really don't want to have to start a fresh game), and I wish everyone the best of luck! 😊

  • Check_S6x
    4 posts

    @misskylied I have the same problem with the second moveable shelf being stuck on top of jars. When I break the jars, the shelf falls on the ground but its off its railing and cannot be moved. Since I can't move this shelf, the task cannot be completed because the man will only move when all the shelves are all in their correct position. Multiple re-starts of the game did not fix this.

  • PonayCha
    2 posts

    i have reset the game multiple times with out the npc spawning i can't seem to get it to spawn and i know i have not completed it as the icon still shows on my map i don't remember talking to this npc when playing the main story

  • triquetratrip
    19 posts

    Unable to complete. Previous players say I need to talk to a man to Start the mystery but he isn’t there.

  • xogjs123
    1 posts

    I'm having a difficult time to finishing this mystery quest due to the bugs issue. I see a man stuck in the house and I need to help him removing jars and make a way out for a man. But once I completed, there is no button that I can interact with him or something to finish the quest. I've been seeing youtube video, etc.. but it doesn't help at all. I was wondering if anyone has the same issue like I am.

  • fesust
    4 posts

    Bug found: Lunden - Anyone, I'm stuck mystery
    Description: The Norse Man is not inside the warehouse, so the event to free him never starts.
    Patch: 1.0.4
    Platform: PC

  • Tre916
    2 posts

    I don't even see the man, I run to the icon and can see a note upstairs, but there's no man to kick it off.

  • chemical053
    4 posts


    Same problem here on the ps5.
    Would be great if this gets a fix!

Suggested Topics

Community Details