ubisoft discussions

Quick Suggestions

  • Locked SOLVED [RESOLVED] Unable to progress with "The Demon Odour at the Tithe" as the NPC does not spawn | POST HERE

    1 Likes/144 Replies/6128 Views
    2 posts

    Got the same problem, NPC was not there.
    Exited the animus en re-entered it, the NPC spawned, but still couldn't move the crates.
    Trowed a dead body against it and I was able to move it.
    But the NPC doesn't walk out and I can't talk to him.

    Fix this please!
    There are thousands of people with this problem on Reddit/YouTube.

  • guslefreak
    2 posts

    Same here,
    stucked shelves, above some jars, the guy does not interact.....

    And i've tried the tricks you're telling in the forum, but no luck.

    Only this mission left for PLATINUM!!!!!

  • drab2009
    1 posts

    This mystery will not start for me. The only thing I need to complete. Please add it to the ongoing issues list.

    thank you

  • JoshDesign
    1 posts

    @lysvander can confirm this work. Thank you!

  • swiftmoor
    2 posts

    For me the single block is in front of the gap in the middle (completely out of position). No amount of throwing a dead body moves it and it doesn't move if I try. It seems to be hung up on something, but I can't see what it would be. The bigger block it's next to is also out of position, but isn't blocking the path.

  • guslefreak
    2 posts

    Finally I found a way to finish the quest; after reading reddit forums, looking for other places.....

    Look at this video, throwing corpses to the shelves can move them.
    The idea is to return them to their "start" position:

    Good luck!

  • lycanthropy7
    1 posts

    I am referring to the world event near the port, in the left, where you need to move some jars and movable objects to release a man in the warehouse. I did all that but the man is not there anymore and so I cannot complete the quest. Is there a way I could reset this quest?
    Thank you

  • Kamikaze_Cooke
    2 posts

    I have 1 mystery left in Lunden...(the one where you must move the smelly containers and create a path for the guy to get out)
    But my 1st time going there he was dead, and now hes dissapeared!

  • tomasalbert
    1 posts

    The bug still persists even after update 1.11 as the man does not move and does not allow me to finish the quest. Please fix

  • Prangstar
    3 posts

    So i had both bugs. The one where the shrlves would spawn on top of the jars and the NPC not appearing. The workaround is first you put the shelves back in their original location. If a shelve is stuck, throw a body at it to move it. Then i left the animus and returned the guy spawned this time on the outside of the building and mission was complete.

  • Sylwester9303
    7 posts

    Latest patch didn't solve this mission.

    For me, the 1x1 shelf is completely stuck by the wall on the left from the entrance. I can throw the body on it and "slide" it forward and backward, but I can't move it by Eivor's hands, so for me it's completely impossible to "reset" its position.

    XXI century, hundreds of developers, testers, modern engines and for what...? It's annoying.

  • PeeKay85
    6 posts

    After the new patch, still not fixed!!!😠

  • BrockbankZulu2
    1 posts

    Lunden mystery demon odor of the tithe. Moved all the jars and shelves but dude just stands there tossing up a bag. Cant interact or anything. Tries restart and nothing

  • inzario
    1 posts

    Hello Ubisoft.

    I got the newest patch and this mission is still NOT working, its the only one mission i need to get Platium, i watched all youtube videos, all glitches and stuff. nothing works... Please fix this 🙂

  • Pierogidog
    1 posts

    I can move all the barrels and shelfwalls but the npc just rants in Saxon and will not talk with me either before or after I move the barrels. I am on PC. This is the second world event bug I have had. Other than that, game has run great so far

  • gingermurdo
    1 posts

    I’m having this issue as well. PS5. I get to the building but he’s not there.

  • LedoveeeKladivo
    64 posts

    Hi guys,

    I had same problem and don´t know why, but this helped: complete Lunden story arc and after that, retourn back and give it try, quest should work. Hope this helps . . . if not, sorry 😉

  • PG-Iceman
    16 posts

    I have tried everything and now found a workarround to the issue. Here is a little map that shows the final position of the boxes.

    It is essential that they remain in their original rails and end up in their final positions.

    The box marked with a red X is a room where boxes can end up, if they do you are screwed and have to use quick saves and reloads to try to move them back into their original rails. You can do so via luck and throwing bodies at the boxes when they hover on vases. It may be challenging if they are on a wrong rail.

    In general use the quicksave and load function to get the boxes set anew.

    • Use bodies, arrows to move the boxes in their right rail.
    • Make sure the rails are not stuck by objects (vases or small crates)
    • Push the boxes into the positions mentioned in the image

    If the guy has not spawned for you do one of this:

    • Quicksave and reload
    • Leave animus and come back

    Tell me if this worked for you!


    1 posts

    Same as everyone else... still bugged... it has been the last event I need for 100%, waiting for about a month and a half now. C’mon Ubisoft.

  • Luknot
    1 posts

    Same here. Can't obtain Platinum trophy! Fix this!

Suggested Topics