Welcome to discussions

Quick Suggestions

  • Elicit85
    17 posts

    @dylface09 I'm going to go ahead an call [censored] on this. Once you aim your bow you lose all ability to hold the button down to collect the key. And if you pull too soon you hit the ground too soon. You either got incredibly lucky or are full of [censored]

  • Ubi-Borealis
    Ubisoft Support Staff 2877 posts
    Best Answer

    Hello all!

    Following the announcement of TU 1.2.0, I would like to reach out to you all with an update. The development team plans to fix this issue with the floating key in tomorrow's update!

    This update is due to be deployed 16 March, 2021 at 1PM CET/8AM EDT. You can read the patch notes and learn more here.
     
    If the issue still persists for you following the deployment of TU 1.2.0, please can you provide us with a video that shows the following:

    • You have TU 1.2.0 installed. You can check this in the title menu in the bottom right-hand corner.
    • That you are still unable to collect this key in Jotunheim


    Thanks all! 😊

    Official Response
  • Elicit85
    17 posts

    Sure would be nice if these useless [censored] suckers would fix this God damn bug though wouldn't be? Maybe if I grab a few hundred bots and spam the forum it will finally get noticed.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi folks, and apologies for the difficulties caused by this issue with the floating key. Our teams have received similar reports concerning this issue, but they're having a difficult time with reproducing this on their end. In order to further their investigation, please provide your save files to us by attaching them to a support ticket and posting your reference numbers here.

    Please also refrain from bumping posts, since this is considered spam and is against the Forum Rules.

    Official Response
  • tanneralis
    3 posts

    @hardkore819 same problem on PS4 Pro...I have all the others too...very frustrating...

  • Vicktacular
    4 posts

    I have this issue as well. Xbox One S. The first time I came through here I was able to grab it, but killed myself by shooting the other hanging supplies in the area before I opened the chest. When it reloaded it got stuck just like the others above me and the key was never in my inventory once I reloaded.

    I have tried everything I can think of, try to get it through alternative means, leave the region and load back in, shut down the game and roload, hard reset the Xbox, moved the game files from my external to internal hdd, nothing worked.

    Fingers crossed for this to be fixed in the next patch (have checked after every update do far and no luck). I have 112 hours in the game and have done everything else, this is the last thing I need to 100% the game.

  • Vicktacular
    4 posts

    @livianata_ wow that's is impressive. This is the last thing I need in the entire game to 100% and finish all achievements. I'll try this a bit later. Thanks for the video!

  • GingerViking687
    1 posts

    I can confirm this is a real glitch!!!! im 97% on trophies and need this last wealth for the blood stone to give to the alter for 100% completionist and get my platinum! Happend on my first playthrough jotunheim been back on numerous occassions, uninstalled and re-installed and even installed AGAIN on my ps5 with lastest updates but still the key floats on the pallet!!!!! BEYOND ANNOYING!!!!! PLEASE ubisoft fix this glitch!!!! 😞

  • Druitty
    1 posts

    Im on xbox one. Having the same issue. The key is just floating in the air. I restarted my game. Restarted my xbox. Im nearly at the end of the game completing till last area. Decided to do this mission now. Nothing working

  • Awqsqw1ww
    1 posts

    So I’m having a problem on valhalla for the PS4 pro where one of the blood tear stones in jotenheim off to the left side there is a chest with two keys you need to shoot them down the big square cargo one won’t fall when you shoot it down it will just stays stuck up in the air any help would be appreciated

  • Im_So_Elite
    5 posts

    @awqsqw1ww this has been reported many times and Ubisoft are investigating. Hopefully fixed at next patch.

  • TheeElf
    179 posts

    @im_so_elite I encountered this about a week ago. Obviously wanting to progress the only workaround I found was to reload an earlier save before entering Jotunheim and go for the 2 key wealth first. I lost about 3 hours of progress but they key dropped on that load. Glad I did it because it still hasn't been patched yet. It just depends on how you manage your save game files whether that's even an option but it worked for me.

  • erkllert2020
    2 posts

    Can confirm this is also an issue on the PS4, since the last update still not fixed. This game has been infuriating with its glitches.

  • TheeElf
    179 posts

    I had the same problem. Wanting to progress the only workaround I found was to reload an earlier save before entering Jotunheim and go for the 2 key wealth first. I lost about 3 hours of progress but they key dropped on that load. Glad I did it because it still hasn't been patched yet. It just depends on how you manage your save game files whether that's even an option but it worked for me.

    However, someone else had a post and they did manage to grab the key while it was floating but the timing has to be flawless. Here's the post and video:

    https://discussions.ubisoft.com/topic/86859/unable-to-collect-key-in-southwest-jotunheim-to-access-wealth-post-here/59
    VIDEO:

  • RFRedFox
    1 posts

    @livianata_

    It is not easy to succeed this solution, but really works on PC. Thank you. 😁

  • ORSF_MTZIGG
    6 posts

    @livianata_ Good job. I tried that myself unsucsessfully quit after 30 min, at least i know it dose work . I am just too slow 😉

  • SuperguyA1
    2 posts

    I submitted save games from just before and just after the key not falling The reference number is 13693542

  • Ferretfur
    33 posts

    More than just one key causing problems:

    The terrible case of keys to chests and door just disappearing appears not to be addressed yet, or even acknowledged in the problems list.

    This one serious bug has stopped me from plying the game until it can be fixed.

    This is the current list of keys that disappear when i pick them up, no matter what i try:

    Please tell me this problem is very much being investigated!

    Updated! Now up to 32 Keys that are bugged and not able to pick up!

    So current list for me:
    Asgard Key
    Utbeck Key
    Sutton Hoo Key
    Colcestre Barracks Key
    Serpent's Landing Key
    Wulfgeard (Farm) Key
    Ulkerthorpe Fort Key
    Eatun Barn Key
    Sabrina's Spring Key
    Belas Knap Keys (all 3)
    Lunden Gate House Chest Key
    Lunden Bodilsbury Garrison Key
    Lunden - Bandit Camp Key Near Londinium Bureau
    Lunden Crepelgate Fort Key
    Jorvik - Eboracum Bureau Chest Key
    Jorvik - Key in Crypt under Yorvick Theatre
    Jorvik - Forseti's Rest Chest Key
    Thieves Warren Chest Key (key in cage)
    Curse Site Key near Donecaestre
    Cnuic Fhada Ruins Chest Key
    Isurium Aldbury Chest Key
    Odin Mine Hideout Chest Key
    Lock Clunbre Hideout Chest Key
    Skegi's Beard Chest Key
    Saint Hadrian's Priory Chest Keys (Both Keys)
    Beamsasfield Chest Keys (Both Keys)

    Deserted Chalet (Norway)
    Viking Lovers World Event Key (Norway)

  • Seelenkontrast
    2 posts

    @livianata_ I’m really too dumb for this. Doing exactly the same things. Nothing shows up to pick up this damn key. It’s a shame that I have to try this hours and hours without getting the key. @ubisoft: do something about this. I’m really [censored].

  • tmetheienohen
    3 posts


    This is my video, it took me a few tries but seemed to work for me!

    This has worked for me, thanks! It was the last quest for me, after that I did the altar and got the 100% achievement! You should keep in mind that once you jump down from the crane, aim to focus, then release the aim button for the “collect key” prompt to appear, then collect it!

  • Wolfpack7833
    2 posts

    Key does not fall when crate shot down. Have noted it is reported glitsch in November.

Suggested Topics

Community Details

93
Online
141.8k
Users
25.0k
Topics
129.8k
Posts