Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • m3duatp
    2 posts
    • I have the same issue on PC. I also opened technical case 13466765.

  • Ballzack707
    7 posts

    I'd like a solution to this too. I can't seem to get it either. Key won't fall

  • YaboiManaea
    4 posts

    Same problem, PC

  • Dylface09
    2 posts

    Whenever I shoot the crate down to get the second key it just floats in the air. Is anyone else having this issue? it’s the last Ymir blood stone I need.

  • Dylface09
    2 posts

    I figured it out finally took me a bunch of tries but hang off of the edge of the device that was holding the crate. Aim your bow to fall in slow motion at the right time and then hold y to snag the key... what a relief.

  • Onefastlife
    19 posts

    @dylface09 i cant hang off the falling crate? Or do you mean the crane?

  • ubi-smash
    Ubisoft Support Staff 360 posts

    Hey everyone, to help review this further, our team has asked that you please created a support ticket with us and provided your save files so they are able to further investigate the cause of this issue. Please check out our guide here to provide this information and please note that PS5 can follow the same steps under PlayStation 4 to share this with us. Thank you again for your patience as we take a deeper look into this with you all.

    Official Response
  • Ballzack707
    7 posts

    @dylface09 I'm having this problem too. I've left and came back. Restarted the game and my console. This of course is the one at the abandoned mines. Just trying to blow this up because this is a deal breaker for me. I've logged 60 hrs and I'm planning on 💯 completion.

  • Ballzack707
    7 posts

    Same. And a few people on PlayStation too

  • tmetheienohen
    3 posts

    Same here, PS4

  • N301821
    1 posts

    Hi guys. There is a key on a pallet of wood thats hanging from a crane. The key is for a chest in the nearby mine. I shoot the pallet of wood and it comes crashing down but the key just hangs there floating out of reach. It won't drop when the wood drops. I've tried for several hours different ways to reach it. I've left jotunheim and returned but still nothing. I've scoured and possibly exhausted all sites pertaining to walkthroughs and bugs and the closest thing I've found is people not finding the key in the cauldron. Any help would be appreciated.

  • The11thcloud
    1 posts

    Can also Confirm this is also an issue with PC, have run through the entire story arc, thought it might be like the roman statue quest in lundun where if you complete the arc it gets reset, but the key still hangs in the air.

  • Otz17
    1 posts

    @redguyiscool same for me

  • ozJohnD
    11 posts

    Has this been acknowledged?

    Is there a fix for this?

  • marcinciok
    5 posts

    I have this same issue( PS4)

  • Jamijah
    1 posts

    Same problem on xbox.. tried and tried the slow mo method, but im not wasting anymore time on that

    6 posts

    me on PC assassin's creed valhalla Jotunheim Abandoned Mine key
    I noticed not a thing been done as of yet of course ; I am slowly turning into one of those UbI haters.Last 7 years UBI trash is starting to wear me down

  • TheElMalato
    1 posts

    Got a bug in AC where a key I need to open a chest is just floating on the air, as seen in the picture......

    This is in Jotuneim when trying to get a shard. undefined

  • Jorgie_
    4 posts

    @ubi-smash I am unable to share my PS5 save.

  • Tantalus_JB
    6 posts

    @ubikoreanbbq Also having this issue on PS4. The only thing keeping me from a Platinum trophy.

    It's still not on the list on known issues under investigation, does that mean we can assume we won't be getting a fix anytime soon?

Suggested Topics

Community Details