Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • SmudgyStatistic
    5 posts

    I travelled to Asgard early in the story, around level 40. I managed to complete the first quest but after starting the second I realised whilst protecting the painter that there was no way I could complete this part. So I travelled back to England and continued my quests there, only to find this now happens every time I travel to Asgard now.

  • Ubi-Borealis
    Ubisoft Support Staff 1451 posts
    Best Answer

    Hello all!

    I apologise for the delayed update. I would like to reach out to you all with an update, and with some more information about ongoing investigations taking place for issues encountered in Asgard.

    Please note that this thread is specifically for an issue wherein players would spawn into Asgard outside of the Builder's shield. Players would be killed before being able to reach the shield, causing desynchronization. This issue was marked as resolved in TU 1.1.1.

    We are aware of an issue wherein enemies are not killed by the Builder's shield, which prevents players from proceeding further with the quest. Players may also spawn within the shield and be able to leave it. You can find the megathread for this here.

    If you are encountering issues with battling Fenrir in "Binding Fate," please note that this is also a different issue that's currently under investigation. For future updates, please keep an eye out within our News & Announcements forum.

    If you are encountering an issue wherein you are spawn-killed immediately upon entering Asgard, and it is not related to one of the topics discussed above, please don't hesitate to create a new thread about this. A member of the support team will reach out to you as soon as they're able to.

    Thanks all! 😊

    Official Response
  • Lucifer...0_0
    1 posts

    I started the Asgard Arc when it first appeared. Got to the shield section and I kept dying due to being under level. So I left and now that I’m higher level I went back but it spawns me in taking massive damage till I die. I would reload but that was a good 20 hours ago in gameplay. I tried fast travelling and exiting and restarting the Asgard dream but it doesn’t work

  • R4DAR86
    1 posts

    SAME! PLEASE FIX

  • EpmKabob
    3 posts

    Having this same issue.

  • tygaddis
    2 posts

    @koobik96 Same here

  • GRIM-WildXBuck
    1 posts

    I'm having the same issue

  • daddyj2010
    1 posts

    Also having this issue.

  • srwwhite
    1 posts

    @jdpb5672020 I have the same problem, please help.

  • BananaSkullyTtv
    2 posts

    There is a glitch in Asgard. When I first did the mission I left as soon as I could cause I was not the correct power level. Now that I am the correct power level, I spawn in using the Asgard potion and now I take random tick damage and am unable to continue that mission at all... The last thing I did was the builder mission where he creates that shield, I was unable to complete it as I was not able to complete it cause I was not the correct power level. Now that i am that power level I spawn back in to see that no matter what I try I'm stuck in an enormous loop of dying and spawn.. It seems to me the only way to fix this is to lose 8 hours worth of gameplay and go to my last save with the builder.
    I am able to load to a previous save and carry on outside of Asgard, but I'd like to do that mission.
    To put it plainly i spawn in and start taking tick damage. For what reason I do not know.

  • Ubi-Baron
    Ubisoft Support Staff 730 posts

    @JdpB5672020 @srwwhite Thank you for contacting us.

    We are aware of this issue occurring, and it has been passed on to the development team to be looked into.

    Official Response
  • BananaSkullyTtv
    2 posts

    The mission that is glitched is called Defensive Measures.

  • lakirsch
    1 posts

    This is still an issue for the "defensive measures" quest - cannot travel to Asgard - get spawn killed each time.

  • Fede_trenti
    1 posts

    II I started the “defensive measures” mission which consists in raising the defensive shield on Asgard with the “builder” but when I had to resist the attack of the enemies the PlayStation turned off. Now he doesn’t let me continue the mission anymore, as soon as the screen loads I am transported away from the shield and hit by “light shots” until I die. I have tried everything but I don’t know what to do. Can you help me.

  • daedricgwen
    2 posts

    I’m having issues with the “In Dreams...” quest I started the “defensive measures” quest within the dream world but realized I was not leveled up enough. I kept repeatedly dying so I left leveled up and now every time I try going back into the dreamworld I instantly die.

  • brokenpizza
    2 posts

    i'm also having this issue. any idea when there will be updates made to fix this?

  • MollyLives
    1 posts

    same goes for me on the PS4. always get killed by the green spark when i try to reenter valhalla during the quest of the builder who makes the shield

  • Emeralder376
    Original poster 11 posts

    I've just met the same issue. Maybe you can try to reset this quest each time the player enters Asgard. Some other players also reported that the "defensive measures" quest won't proceed normally (enemies keep coming for half an hour/ the quest won't proceed when enemies are cleared). @ubi-spud

  • TealDuchess7549
    3 posts

    @ubi-spud I have had the same problem when I fast travel it then freezes and I can’t move

  • KazuhiraMartinz
    2 posts

    There's a game breaking bug in when doing the Asgard missions. I got to the second chapter where you're with the builder testing out the rune shield. I needed to leave to level up a bit, so I did. When you return it doesn't put you back into the circle; you're near Heimdall's Tower. On the other side of the Asgard map with the effects of the Rune shield still active, so you start taking the damage over time effect that happens when you exit the shield. This has completely ground the Asgard quest to a halt. There are numerous other issues but this is the one that's stopped progress all together. I can send a video of what's happening if you need it.

  • Jaycaldw3ll
    3 posts

    is there any update on a fix for this i really want to progress in the story currently stuck with no missions?

Suggested topics

Community details

12
Online
125.0k
Users
21.6k
Topics
111.2k
Posts