ubisoft discussions

Quick Suggestions

  • KainamHD
    2 posts

    @ubi-spud @CD_ProjektRed It's been 2 months since this bug was reported and we still don't have an update when it will be fixed. This is MORE broken than Cyberpunk 2077. At least with that game I can continue to play it, and people can get a refund on it. And they have a class action lawsuit going on it as well. I tried getting refunded through MS on Valhalla, but by the time I experienced this bug I was already a few days past the refund window.

  • juice7892015
    1 posts

    i was doing the build the shield wall and I couldn’t get any more enemy’s I woke up from Asgard then went back and now it spawns me on the other side of the map and I immediately start dying I can’t do anymore Asgard missions

  • phileeeeeeep930
    5 posts


    Has anyone from Ubisoft addressed this issue? Thanks for getting us back into the bubble but that's only half the problem. As have others on this thread, I've spent way too many hours in my life QA'ing your product for you, watching how the Jotnar spawn, tracking them throughout the area, trying to trigger them to enter the bubble 4 at a time. All of that work has gotten me nowhere, except trapped in Asgard..in this bubble. You need to trigger the Jotnar attack when players enter the bubble otherwise this is all pointless.

    Valhalla was my first venture into the AC game line and while I've definitely been impressed this whole situation is a bit absurd and really souring my opinion for the AC line going forward.

  • thornh
    18 posts

    There's no mention of this issue being addressed in title update 1.1.1 releasing tomorrow. I truly cannot believe we're going to go into month 3 without a resolution to this bug.

  • lara.hi
    2 posts

    It has been almost three months now and this hasn‘t been fixed. This is really ridiculous. How does Ubisoft expect us to pay for DLCs when the base game isn‘t even playable for so many people? At this point I don‘t think there will be an Update for Defensive Measures

  • thebartz
    5 posts

    Just checked if new update fix the issue - the answer is NO. I hoped to finish Asgard quest as this is only part which I've not done but unfortunately it won't progress.
    I'm going to sell my copy of the game as I'm not going to play one more time. Shame on you Ubisoft.

  • olischnollie
    1 posts

    @chuckyogurt I have the same problem. The new update has not changed anything

  • J1ackass
    2 posts

    Sort it out Ubisoft, ffs. We are not testers, we are players. If you want us to keep buying and playing your games, make sure they f**king work before release. None of us can complete the game because of this issue. My stupid [censored] has already bought the season pass, so I'm out £80 on a game that is still not fixed months after release. Might as well play Cyberpunk, I think it has less bugs.

  • will.i.am.321
    1 posts

    So I encountered this problem a while back but as it was more a side story I ignored it. But now I've completed a game I thought I'd look into it. In asgard you have the mission with the builder to create the force field and in it you have to fight hoards of enemies. However when I first did this I was a low level and wasn't strong enough so I woke myself up in the map and went on like normal. However when I went to return and complete this mission I was spawned at the entrance of asgard and outside the builders force field and was repeatedly struck by lightning and be killed many many times. No matter what I've tried I can't undo this without starting the entire game again. Are ubisoft aware of this problem or am I the only one that has this?

  • bplynch428
    1 posts

    I was fighting Fenrir and when he got down to half health he just disappeared. The health bar was still at the top, but Fenrir was just gone. After a few minutes of nothing happening I clicked on the Wake Up eye icon to return to England. Since then my player dies right away when I enter Asgard. I am playing on Xbox One and my gamertag is iBrLani. I am not able to advance in the story and this has been going on for a month now. Please fix ASAP.

  • Ubi-Wan
    Community Representative 636 posts

    Hello there! Thanks for reaching out with this. Our team is aware of this issue at this time, and are currently investigating a solution. If you'd like to assist with this, please create a new ticket with our dedicated support team, and attach a copy of your save game files for us to review!

    Official Response
  • Pipii11
    1 posts

    I suffer this bug in the mission "Blinding Fate", Fenrir got bugged and when I return to Asgard I die by desyncronization

  • Tskxsniper1
    2 posts

    This same bug happens to me when I return to Asgard but it was during the blinding fate mission. Fenrir, glitched under the map and I was unable to finish the quest so I returned to Norway and now every time I return to Asgard, I am spawn killed

  • Tskxsniper1
    2 posts

    @pipii11 same thing happens to me!!

  • guest-qWUg9gOF
    2 posts

    @tskxsniper1 @Pipii11

    Im afraid this will take some time to fix. I have had this problem for over 3 months now and even with the latets update things didnt get fixed.

    I am a little sceptic about the situation ever getting fixed. This destroyed my game with 75 played hours, did everything else in the game and now I haven't played it in over 3 months.

  • PiotrB2012
    1 posts

    1.1.2 - It is still broken. how long we have to wait to fix simple bug? It 4th patch since the bug is know. Fix it or money back plz.

  • Ubi-Borealis
    Ubisoft Support Staff 6075 posts

    Hello all!

    I apologise for the delayed update. I would like to reach out to you all with an update, and with some more information about ongoing investigations taking place for issues encountered in Asgard.

    Please note that this thread is specifically for an issue wherein players would spawn into Asgard outside of the Builder's shield. Players would be killed before being able to reach the shield, causing desynchronization. This issue was marked as resolved in TU 1.1.1.

    We are aware of an issue wherein enemies are not killed by the Builder's shield, which prevents players from proceeding further with the quest. Players may also spawn within the shield and be able to leave it. You can find the megathread for this here.

    If you are encountering issues with battling Fenrir in "Binding Fate," please note that this is also a different issue that's currently under investigation. For future updates, please keep an eye out within our News & Announcements forum.

    If you are encountering an issue wherein you are spawn-killed immediately upon entering Asgard, and it is not related to one of the topics discussed above, please don't hesitate to create a new thread about this. A member of the support team will reach out to you as soon as they're able to.

    Thanks all! 😊

    Official Response
  • AnimusAnomaly
    4 posts

    When will this quest be fixed (looks like it has been going on for 3 months)?

    I started the quest, then fought the enemies, shield was breaking, then got fixed again, then could not speak to the builder (try to push or kick him, no go) and enemies were able to enter the green shield no problem. I got out of the shield to go around the block and re-enter, now the builder is MIA and all the enemies in Asgard converge to the shield and are able to get in the green shield and I can spend an hour killing endless enemies, killed enemies keeping re-spawning again and again, can't finish the quest and advance the storyline... everything else is complete on the map.

    Please fix ASAP, don't care if the patch just trigger the end of the quest or reset it and I have to do it from scratch.
    Thank you

  • Speedsupporter
    1 posts


    Hi, I even have the issue (red shield last forever) with the latest patch 1.12 on PS5. It is really annoying, invested around 150 hours and just that part is left.
    please please help.

Suggested Topics