Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • thebartz
    5 posts

    When we expect fix for this issue?

  • KainamHD
    2 posts

    @ubi-spud @CD_ProjektRed It's been 2 months since this bug was reported and we still don't have an update when it will be fixed. This is MORE broken than Cyberpunk 2077. At least with that game I can continue to play it, and people can get a refund on it. And they have a class action lawsuit going on it as well. I tried getting refunded through MS on Valhalla, but by the time I experienced this bug I was already a few days past the refund window.

  • phileeeeeeep930
    1 posts

    @UbiKoality

    Has anyone from Ubisoft addressed this issue? Thanks for getting us back into the bubble but that's only half the problem. As have others on this thread, I've spent way too many hours in my life QA'ing your product for you, watching how the Jotnar spawn, tracking them throughout the area, trying to trigger them to enter the bubble 4 at a time. All of that work has gotten me nowhere, except trapped in Asgard..in this bubble. You need to trigger the Jotnar attack when players enter the bubble otherwise this is all pointless.

    Valhalla was my first venture into the AC game line and while I've definitely been impressed this whole situation is a bit absurd and really souring my opinion for the AC line going forward.

  • thornh
    12 posts

    There's no mention of this issue being addressed in title update 1.1.1 releasing tomorrow. I truly cannot believe we're going to go into month 3 without a resolution to this bug.

  • lara.hi
    2 posts

    It has been almost three months now and this hasn‘t been fixed. This is really ridiculous. How does Ubisoft expect us to pay for DLCs when the base game isn‘t even playable for so many people? At this point I don‘t think there will be an Update for Defensive Measures

  • thebartz
    5 posts

    Just checked if new update fix the issue - the answer is NO. I hoped to finish Asgard quest as this is only part which I've not done but unfortunately it won't progress.
    I'm going to sell my copy of the game as I'm not going to play one more time. Shame on you Ubisoft.

  • J1ackass
    2 posts

    Sort it out Ubisoft, ffs. We are not testers, we are players. If you want us to keep buying and playing your games, make sure they f**king work before release. None of us can complete the game because of this issue. My stupid [censored] has already bought the season pass, so I'm out £80 on a game that is still not fixed months after release. Might as well play Cyberpunk, I think it has less bugs.

  • will.i.am.321
    1 posts

    So I encountered this problem a while back but as it was more a side story I ignored it. But now I've completed a game I thought I'd look into it. In asgard you have the mission with the builder to create the force field and in it you have to fight hoards of enemies. However when I first did this I was a low level and wasn't strong enough so I woke myself up in the map and went on like normal. However when I went to return and complete this mission I was spawned at the entrance of asgard and outside the builders force field and was repeatedly struck by lightning and be killed many many times. No matter what I've tried I can't undo this without starting the entire game again. Are ubisoft aware of this problem or am I the only one that has this?

  • Pipii11
    1 posts

    I suffer this bug in the mission "Blinding Fate", Fenrir got bugged and when I return to Asgard I die by desyncronization

Community details

52
Online
102.7k
Users
17.1k
Topics
81.0k
Posts