Welcome to discussions

Quick Suggestions

  • thesour
    1 posts

    @ubikobold how come this quest is not featured in the thread Assassin's Creed Valhalla - Known Issues [Updated Dec 8] ?? I can't really understand. I finished all the rest of the game, made literally everything, all zones are fully finished except Licolnscire, Hamptunscire and Hordafylke stories. How long do we have to wait until we can finish this lazily tested game? I think you need new testers at Ubisoft, otherwise I can't comprehend how your QA didn't find any of these bugs beforehand, it's literally unacceptable to release a game like this in 2020...next-gen hahahahah

  • Gudder77
    3 posts

    I’m unable to complete the quest when at the castle in the basement. The woman just keeps scrubbing and there is no cut scene/integration. I use odinsight to find clues and see 3 things get lit up, but I am unable to interact with them. This is a major bug preventing players from progressing in the story.

  • Aerial_Arts
    29 posts

    I'm completely stuck on the quest "in the absence of an Ealdorman".
    i previously found the room where you locate the ealdorman before i started the quest and found the brooch before the quest,
    now i have the brooch in my inventory and the quest won't update since i haven't picked it up..... so im stuck and can't make any further progress in the questline.

  • Aerial_Arts
    29 posts

    Same issue
    i previously found the room where you locate the ealdorman while just exploringbefore i started the quest.
    Found and was able to pick up the brooch before the quest,
    now i have the brooch in my inventory and the quest won't update since "i haven't picked it up....."
    so im stuck and can't make any further progress in the game.


  • Aerial_Arts
    29 posts

    @dalinnar92 Same issue for me as well.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hey everyone! At the moment, this issue is still being worked on. For those of you that are new to the thread, we are requesting save files from PC and PS4 users, so we can add those to our on-going report.

    @kk1776 Thanks for sharing your case number! Would you also be able to upload your save files to this ticket please?

    @bigbenharg21 This is a slightly different issue, but our teams are also aware of this bug and would appreciate your save files if possible please!

    @Medeor2010 Thank you so much for attaching those files to your support ticket! I've added those to the report. 😊

    @imcrazyblah0 I'm sorry to say that we're still investigating this issue, so no timeframe is available to share yet. As soon as we have a solution, we'll let everyone know!

    @Gudder77 This also appears to be a slightly different bug, but save files are still being requested for this issue. Please let me know if you're able to attach those to a support ticket.

    @Aerial_Arts I merged your other post about this issue here to avoid any confusion. We will post updates here once we have new information to share.

    Official Response
  • Arthur.Morgan
    7 posts
    This post is deleted!
  • Arthur.Morgan
    7 posts

    @UbiExcellent @UbiKobold
    Save is submitted on Dec 5th under the case # 13508648
    Video:


  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @arthur-morgan Excellent, many thanks Arthur-Morgan! I've forwarded the file and video clip over to our dedicated teams to be evaluated further. 😊

    Official Response
  • zimpirate1
    9 posts

    Any update on this?

  • adamof1234
    1 posts

    Same here on PS4, didnt have the broach until the mission, picked it up, its not registering, still telling me I need to invesigate the castle,


    Mon guys please, loved this game, but this is after ruining it completely. Its been WEEKS

  • nin8220
    9 posts

    New update still no bugfix!!

  • kosrati
    3 posts

    I was all happy hearing patch 1.1 coming out just to get disappointed and knowing the quest "in the absence of an ealdormen" still not working. I have around 80 hours in game and can't finish the game just because I picked up the brooch before the quest. I finished everything else that's possible and we deserve a fix for this quest really fast

  • mrdazo
    2 posts

    @kosrati This is really upsetting me too since i really want to finish the game already lol

  • KAMLiOo10
    11 posts

    i don't know what is the wrong with ubisoft !!!
    the issue was discovered more than month ago and they still saying "thanks to everyone please send your save file" !!!
    the new update is more than 4 Gb and not fixing an easy issues like this !!
    the game wasn't tested well and it's totally your wrong so me and other players can't progress farther in your main storyline anymore therefore most of us stopped playing your game ..
    so tell us what are you waiting for ?!!

  • Rudolph176
    1 posts

    I cant do the "in the absents of an ealdorman" mission

    i cant give the pendant to the person

  • StaplePort2478
    23 posts

    Post update, i did the update, restarted console, am now re installing entire game. I like to do one area at a time but now im stuck in 3 regions half completed and i hate it. I hadn't played at all for a few weeks waiting for this update, and don't really have any desire to get back into the game now. Excitement dashed.

  • TunderNindzsa
    5 posts

    You investigate what? This is a one month old issue and you did nothing, shame on you!

  • Rihlee4
    2 posts

    Wow, guess ill just watch the ending if its gonna take months for this to get fixed. I just want one triple A game that isn't unfinished buggy mess.

  • GeneticV8
    2 posts

    Fix the brooch bug, this is unacceptable garbage.

Suggested Topics

Community Details

49
Online
143.1k
Users
25.3k
Topics
131.4k
Posts