Welcome to discussions

Quick Suggestions

  • budzmcgee
    1 posts

    Same issue with somewhat different circumstances (from what I scanned).

    1. On Xbox series x.
    2. I collected Brooch as part of mission (not before)
    3. Instead of returning it immediately I decided to go to the Yule fest to get tokens I needed to get last items.
    4. Spoke to Reda and took 2 contracts. One (predators one) was right by camp so decided to take care of that. I still had the Ealdorman quest selected though.
    5. Completed Reda quest.

    Icon for Ealdorman quest was now missing on game menu as was "tracked" quest screen feedback (though quest was selected in menu). Unable to speak to npc by just going to location as well. Unable to progress now.

    Reading over thread the common theme seems to be that if the Ealdorman quest is interrupted in any way the game won't trigger the world event to speak to the NPC. For me it was doing another quest. Some it was a crash. For others having the item prior doesn't trigger the event for picking it up and same result. Maybe the sludge hammer solution here is to make it so anyone who hasn't beat the quest (after broach collected) and has broach in their inventory) has conditions for quest reset (triggers the expected event for picking up the broach) on game load or quest selection?

  • Toy_Gammer
    1 posts

    I am also stuck on "In the Absence of an Ealdorman', I explored the area and picked up to broach before I did the story quest. Then, when I arrived at the cellar where the Ealdorman had already died, I was unable to proceed for that point. No crash, when I returned to present the broach at the castle I was unable to interact with any NPC. Help!

  • Numbr4B0bby0rr
    2 posts

    @xgudnitex still not fixed on my end. I know they released that one update but this bug wasn’t included. Really frustrates me that they release the yule festivals update but people who paid for the game and can’t complete it because of this glitch are stuck twiddling their thumbs.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    Hi folks. I am sorry to say that at this time, we still do not have any updates to share with you all regarding a fix. I understand that this is not the update you all were hoping for, but I wanted to make sure you all knew our teams are still investigating this issue in hopes of finding a future fix. I'm extremely sorry for the continued wait, but I appreciate everyone's patience and understanding with our teams in the meantime.

    Official Response
  • LoudAssassin410
    10 posts

    @ubiexcellent so thats it?after a few weeks waiting for an update we get "sorry still looking into it?" I mean for [censored]'s sake offer refunds or at the very least helix credits for this because this issue has been around for months,people CANNOT continue the storyline and complete the game because of this bug,at this rate what is the point of even playing this game? The current game you have is broken and your events are bugged to [censored], Im trying my best to understand the situation with the pandemic and the holidays but to wait for months for a company to fix a bug so i can complete the story is outrageous,best believe that I will be writing to any game reviewing website about this.🖕 🖕 🖕 🖕

  • deth199718
    2 posts

    How long is it going to take to fix a massive f*** up that you have known about for over 2 months? I have collected and completed all side missions and items in the game this bug is all thats stopping me from finishing the game

  • imcrazyblah0
    17 posts

    @ubiexcellent enough is enough. start issuing refunds now.

  • SBHeathcote
    13 posts
    This post is deleted!
  • SBHeathcote
    13 posts

    @ubiexcellent I know its not your job to personally go fixing the code, but for reals.

    Its now been 42 days since report for a quest progression script bug that soft-locks the game.

    BTW, Its super-inspiring to see the game get discounted down on epic to ~$49.79, & knock off another $10 for their winter sale process and know that I I paid a solid 30% premium to play something that doesn't work sooner than everyone else? That's still borked? Watching friends that have bought the game on sale post endgame content screencaps is a very weird feeling, man. I mean, this experience has left me not getting the season pass on principal and never picking up an Ubi game at full retail price again, because why would I? I'm not even mad about it anymore, its customer service that's literally so bad I wanna get popcorn and see how it goes.

    and here you are, stuck on this board while we yell at you. ...and the best your upstream can do for progress on this ticket is still investigating?

    Yikes.

  • KAMLiOo10
    11 posts

    @imcrazyblah0
    i want to do a refund also cause i lost all my patience on this company

    so i am ps4 player .. how i can do this ?!!

  • Indarctos
    1 posts

    42 days without a fix. At this point it's just sad.

  • kosrati
    3 posts

    @ubiexcellent that's all you have To say? It's almost 2 months I can't finish your game which I payed 70$ for and all I get a copy paste apology we got weeks ago too. You guys Should be embarrassed for what you do To your customers, I played all assassins creed games so far from day 1 they got released and it's impossible for you guys To find a fix for the bug? Either stop producing games if you cant Bring it or get to learn how CDPR does it and fixes most of their bugs with one patch

  • EQ-Geckoface
    9 posts
    This post is deleted!
  • Drozz242
    1 posts

    Been waiting for about 3 weeks as well. Better do something soon.

  • Tony41254ac
    2 posts

    where is hunwald and quest after anonymus bug
    and when will u fix it boss.



  • zimpirate1
    9 posts

    What urks me is they took the time to do the Yule Time stuff which is also bugged as hell but couldn't find the time to fix a 2 month old quest breaking game bug.

  • raqserrano
    1 posts

    I just want a refund at this point. Last time I will buy an Ubisoft game.

  • domleondavis
    1 posts

    @ubikobold I completed the Lincolnshire arc and then experienced a crash. My save progress was reset to a few hours before. I went to progress and was not able to return the broach. As others have stated, I’m in the objective area and the NPC is just standing there.

    At this point I’ve gone and completed all the other shire arcs and came back to this one and am unable to progress (even though I already completed it once.)

  • Chenec04
    3 posts

    @scottaaaay same here! It is our final stretch and we can't proceed. Nothing more disappointing than getting so far in a game and then not being able to complete it.

  • Chenec04
    3 posts

    @ubiexcellent simply an unacceptable response. This has been a long outstanding issue that has a MAJOR impact on the gamers experience, which seems to not be of any importance to Ubisoft? How can there be such a "I don't care" attitude when you can clearly see plenty of frustrated gamers??

    This is something that needs to be escalated and treated with URGENCY!!!!!

    Your team finds out that there is a glitch where XP points can be mined and that was fixed within a week...BUT one of the main quests to complete the game takes a back seat??!

    To me, there is more than enough feedback from everyone explaining what the issue is, so I am not sure what you are still having to investigate?!

    This game was NOT cheap and to have these endless bugs not being fixed is seriously frustrating. People can only be patient for so long, especially when they do not get concrete feedback.

    I know it is not you who possibly assists with fixing the bugs...but you will get the backlash from such a vague update. Your team needs to start working together to get this fixed and start providing valid feedback...!!😔 😡

Suggested Topics

Community Details

56
Online
143.6k
Users
25.4k
Topics
132.0k
Posts