Welcome to discussions

Quick Suggestions

  • Tetzai
    2 posts

    I'm having the same issue. after 100+ hours, there's no way I'm restarting just for this one mission. I've been waiting patiently for about a week, so when I saw the patch 1.0.4 I got excited. "yeah, I can finally finish this game!" nope, they fixed everything but this quest line. I'm almost into mastery points, killed every oder member except three, and have collected all the equipment, fully upgraded a set of armor, etc. it's getting to the point where I'd rather play a bethesda game if I wanted bugs and glitches every twenty minutes of playtime. don't get me wrong, I love this franchise from the bottom of my heart, but if their games continue to be unfinishable, then I'll no longer be a fan. I spent $100 on the gold edition, and I'll be damned if I don't get to finish my game. I just want to be able to give the brooch to Hunwald and move on with the story. this all happened because I went to a sync point instead of directly to the quest marker. passed through the town he was in and went to a sync point north of aelfgarstun. some time between me climbing the structure and synchronizing, the quest marker just vanished. like it timed out or activated itself without me being there. not sure what happened, but I'm literally locked from finishing the story. this is the first time I've had this happen to me in any game other than skyrim. I just want to finish your game, Ubisoft.

  • Really_Dazed
    5 posts

    Yep, still not fixed. No way I'm going to restart after almost 50 hours of playtime. Never thought this was why I'd stop playing this game.

  • Zarkon1
    4 posts

    @luke22008 Same exact issue here. I cleared the castle of loot long before doing the quests here, and I already have the broach in my inventory. I can't investigate the box, so i can't proceed with the questline.

    On PS5 if that maters.

  • Zarkon1
    4 posts

    I am at the part where you are supposed to loot the crate for Hunderbeorht's Brooch. The issue is that I explored this castle long before I did any of the story missions in this zone, so the brooch is already in my inventory. It won't let me loot/search the crate so i can't continue with the mission. There's no way to sell the brooch, or otherwise delete it from my inventory, so the quest can never progress.

    I tried leaving the area completely, loading a previous save about 30 minutes back, and even tried questing in a different zone. When I visited the alliance table to come back to Lincolnscire, I was at the same exact spot in the quest with no way to continue forward.

    This completely stops all progress in the game for me.

    I am on PS5, and I am on the latest patch, 1.004

  • Ang3lOfD342018
    4 posts

    Can't progress any further in story,quest objective is blank during the part of the quest where you find the ealdormas dead body goes blank after cutsence. I have completed every other mission that I can for the main story and it still won't load after

  • Ang3lOfD342018
    4 posts

    @zarkon1 im having a similar issue except I don't believe I looted the broche already however that's where I'm stuck.. is really annoying as I have done everything else and can't progress any further till its fixed

  • Zarkon1
    4 posts

    I'm 94 hours into the game, and I probably explored this area 30 hours ago. Previous saves and/or starting over isn't an option.

  • Ang3lOfD342018
    4 posts

    @zarkon1 im only 60hrs in but I feel you there. Was ages ago when it glitched, was hoping after doing more quests it would fix itself with the next patch but no go there. Plus that seems to have made things harder now.

  • Ang3lOfD342018
    4 posts

    Have now realised the i looted the broche at some point prior to the quest, which I believe has caused the glitch.. Am unable to remove or sell the item and have no clue when I got it so can't reload previous save.

  • KillerBee4321
    4 posts

    @zarkon1 exactly the same situation here, but on xbox one

  • Emazon_95
    4 posts

    Same thing happened to me on PS4 a week ago
    new update didn't fix the bug and i'm still stuck on the last alliance quest in England

  • Emazon_95
    4 posts

    @ubi-raziel same problem on PS4,
    new patch didn't fix the bug

  • lienadback
    2 posts

    I am incapable of completing quest "In the absence of an Ealdorman" for lincolnscire. literally standing in front of the three of them with no quest marker and cannot speak with them. desperately just trying to take out all the templars BUT A SINGLE ONE relies on killing someone here (I already know whom but don't spoil it for others) i wish i could just kill them outright but i know its not how it works. in black flag i hunted down templars no quest and no problem but oh well thats not why im here. i got forward allot in my game and never had a recent save for this quest, not to mention game crashing while not connected to servers there was no auto save, so no way im going all the way back and restarting just for thors hammer. and yet still its not what im here to talk about. my problem is that i sat for a few days waiting for 1.03 and never got it, then i get 1.04 and none of my issues are fixed.
    no tech support has replied to my report other than to tell me to- delete and redownload the game reset my Xbox, and try passing on my disk to another xbox to see if the issue is with my own (i dont have the disk copy) neither through email, the main support page, Facebook, YouTube, here is my last resort.

    also problematic would be my inability to interact with my barracks manager in any way to collect the hordes of silver from my jomsviking being summoned every day, or to edit them in the first place. AND i cannot interact with my shipmaster for whom i have acquired many many schematics, all useless in this current state.

    please somone help

  • annatomia
    4 posts

    I am at the stage of the quest In The Absence of an Ealdorman where I am supposed to find him in a castle (after the investigation in the cave). I am in the underground chamber with a lady, where it’s supposed to be a cutscene but it doesn’t show up. I cannot go on with the quest and I keep getting the message to choose a quest to follow even though I’m already following this one. I hope you can solve this because I don’t want to loose 50 hrs of gaming...

  • Esmeralda1458
    7 posts

    I was able to track this quest even though I had previously gone through the tunnels. I saved my game mid-quest and upon reloading it no longer tracks and I cannot progress.

  • Frede_Spade
    4 posts

    I'm stuck in chapter 3 of the quest. I can't see the quest details in the left side of the screen or see the thing I need to loot when using Odins eye. I tried pledging to one of the other zones, but that didn't help at all, and now im stuck, beacuse i cant finish the last zone in England. I also tried, loading the game again, restarting the game and restarting my ps4, nothing helped.. The game also chrases 5-6 times for me when i play it. Soooooo, i need help.

  • xDAMONx2k
    4 posts

    Hi same bug and sti there i cant not interact with anything anymore in the quest of the ealdorman .... fix this ...

  • Medeor2010
    4 posts

    Same here on PC. Hunwald doesn't realize that I've found the brooch. No crash before (at least not in a timely manner). I hadn't picked up the brooch before.

  • Symitri
    3 posts

    Platform: PC
    Quest: In the Absence of an Ealdorman

    Issue: Have reached the stage of the quest where you find the ealdorman and need to find a trinket of his to return to his son. I am unable to loot the trinket because I have looted it already prior to starting this quest while exploring the zone for Wealth.
    The quest does not recognise that the trinket is already in my quest inventory and does not show the next step of the quest. My guess is the quest expects to be reading the looting of the chest as the quest objective completion rather than doing a check on the player's inventory.

    I looked up a guide and went to see if I could trigger the next step of the quest by talking to the son but the game does not acknowledge I have done the previous step.

    Troubleshooting: Have tried progressing in a separate quest to see if returning to it would change anything
    have changed zone maps (from England to Norway and back)
    have logged out and in again
    changed Eivor's gender in case it refreshes the quest

    I unfortunately do not have a save from before I looted the trinket so without restarting the game, I can't progress.

  • RedArrow182
    5 posts

    I am unable to progress with "In The Absence of an Ealdorman". I have collected the brooch previously while exploring and now because I need to collect it for the quest, I can't progress. Have tried reloading and going straight to Hunwald but can't even speak to him.

Suggested Topics

Community Details