Welcome to discussions

Quick Suggestions

  • FearlessReject
    3 posts

    Why can’t they just add a “reset quest objective” option or somethin lol? This is depressing af.

  • lordrain12
    2 posts

    I have the same issue. XSX and I have explored the castle previously. Now, I am unable to progress. The game has crashed on occasion, but nothing that would seem to trigger this. Please try to fix this.

  • trey1o
    2 posts

    Accidentally Grabbed the brooch for the Lincolnshire main quest beforehand and now I can't hand it in for the absence of an ealdorman quest I have 90+ hrs in and I really do not want to have to go back

  • fallzing
    9 posts

    @ubikobold It did not crash for me. The game never triggered a prompt to turn in the brooch even though it is in my inventory. I believe I looted the room before starting the quest, which is probably why it doesn't recognize that I have the brooch. I'm playing on PS4.

  • Zookeeper71
    2 posts

    I have this exact same problem.. 😞

  • StaplePort2478
    23 posts

    @ubikobold no crash just quest title and no description or marker

  • novastellaris
    2 posts

    i have this problem as well. i tried completing other arcs and coming back to it, but it was still bugged. the quest info disappeared after i talked to the lady, i was still able to investigate, but i couldn't do anything else because i already had the brooch

  • Jamie002020
    8 posts

    Same here it's my last mission and it's bugged I can't speak with the guy I am supposed to give the brooch to. Hopefully it's fixed soon because I can't go any further

  • Fembot06
    1 posts

    @scottaaaay same here. I have access but it won't let me investigate the clue in the room which is the document. It's also still showing that the key is present in the area below the waterfall. However, when I try to collect the key again (thought that might help) the body is floating inside of a rock and is inaccessible. So frustrating!!! 2nd time the game has force closed and I've lost hours of progress. Makes me want to quit.

  • novastellaris
    2 posts

    i got this bug on PS4. i looted the brooch before i began "in the absence of an ealdorman." i was able to get the cutscene where you find the ealdorman, but the quest objective disappeared after the cutscene ended. i was able to investigate the area, but nothing happened. i switched arcs and completed other quests, but "in the absence of an ealdorman" was still broken when i returned to it. i don't think i had any crashes during this, but i have been having random crashes (that's another issue tho).

  • nin8220
    9 posts

    Xbox one.
    No crash.
    Same as every one else.

  • evo609
    2 posts

    @Fembot06

    Same here.
    I quit, shame ubisoft

  • Petteflet88
    346 posts

    @ujellynelly dont worry guys, I will answer for them!

    This issue is under investigation.

  • RAMR0D43
    2 posts

    @ubiexcellent I am having this same issue. I am on xbox series x one caveat being my game never crashed, I just cant interact with Hunwald to return the brooch.

  • Rihlee4
    2 posts

    Same issue. Looted the item before the quest. Now stuck, because I cannot re loot the item or give it to the NPC.

  • docas22
    1 posts

    How we getting these weekly content updates but this is yet to solved?

    I would of completed the game by now if not for this bug. 🤬
    @UbiKobold pressure the team some more user experience being totally ruined right now..

  • Jamie002020
    8 posts

    In the absence of an ealdorman the mission and arc are bugged. I can't complete it because I can't give the brooch to the required npc, I picked it up by previously exploring the area earlier in gameplay. The game had crashed a few times but I can't say when exactly. Regardless the mission title remains on screen with no objective underneath. It's my last arc and pledge so I can't move forward and I know many other people have this exact issue.

  • SQB_96
    3 posts

    @ujellynelly Same issue and i completed the all of england stuck at 300 power because main quest story line is stuck.

  • PoisonAkuto
    17 posts

    Same issue here XBOX SERIES X - I picked up the brooch earlier on (about 50+ hours ago) when exploring, now I'm doing the mission the game doesn't recognise I have the brooch, thus I am stuck on this objective. Trying to turn the brooch in anyway does not work. And I am not undoing 50+ hours of work by reloading an older save before the brooch. I see many are having this issue and it is "Being looked at" but when are we getting a fix? looks like some people have been waiting an entire month already, where is the word from Ubisoft that this is being fixed in the next patch?

    It ends the adventure in a dead stop. We have all paid good money for the game in the midst of a pandemic, the least we deserve is some official word on when the fix will arrive. Do not punish players for exploring the world you created.

  • Jamie002020
    8 posts

    How many comments or complaints does a thread need to be warranted a sufficient enough problem? This is over a month I haven't heard ubisoft saying this will be fixed anytime soon I have the game complete only for this mission. 🤬

Suggested Topics

Community Details

111
Online
196.6k
Users
33.4k
Topics
166.6k
Posts