ubisoft discussions

Quick Suggestions

  • HateYourFace69
    10 posts

    You don't have to pick up the brooch early to get the glitch. I picked up the brooch as part of the mission and same thing. Actually think everyone is stuck in the same place. No fix this quarter probably. I will think long and hard about purchasing another Ubisoft game. Watchdogs was full of bugs and AC too. Looks like they don't care anymore.

  • HateYourFace69
    10 posts

    You don't have to pick up the brooch early. Mission is broken and has not been addressed in any fashion. I have a save file right before the mission and no matter how many times I pick up the brooch. the mission fails to advance.
    Expectation: None. They already have your money and don't give a hoot about our complaining. If I could access the code I could hot fix it in like 5 minutes and I'm a novice.

  • EQ-Geckoface
    21 posts

    Every time I turn on my ps4 the first thing I do is look at the notifications to see if there is a ACV patch to fix 'In the Absence of an Ealdorman'. There are a lot of problems with this game but that one is keeping me from playing it. I sever seen anything worst than Fallout 76 until now.

  • imcrazyblah0
    17 posts

    Would be nice for actual responses from ubisoft on this, and yet CDPR is getting sued by their investors. they had 1 bad launch but with ubisoft it is a continuous problem that gets worse every bloody game.

  • Pifimifi13
    1 posts

    @trickster_plays Same here. Last Arc, 115 hours spent and now waiting for them to fix it. Saw on reddit people posting about it 20 days ago and still nothing has been done about it.

  • NightGoblinX
    3 posts

    This issue just happened to me after 100+ hours gameplay. Didn't realise I already looted the brooch while exploring. Hope it will be fixed soon so I can finish the game.

  • PoisonAkuto
    17 posts

    When are we going to get some sort of timescale on a fix here!?!? THIS IS AWFUL CUSTOMER SERVICE/SUPPORT.

    You guys realise this is part of the MAIN QUEST LINE right? We literally can't finish your game until YOU FIX THIS. I am just about at the end of my patience waiting for this fix and I think the communication from Ubi has been absolutely disgusting thus far. "we've passed it along" "under investigation" "upload your saves" "The team are looking at it". Words, words words. It's a simple fix.


  • jdepaiva
    1 posts
    This post is deleted!
  • mrdazo
    2 posts

    Will not progress in the game when you already got the quest item in advance

  • miszczu_m
    4 posts

    They just close my case. They can't sort it so close case. What a joke that ubisoft is.

  • Aerial_Arts
    29 posts

    @eq-geckoface Reached out to a few over the past couple of days, i'll update when i have any responses.

    Tried to see if this issue have been raised by people covering the game and haven't really found anyone specifically mentioning this, the closest i got was a "a couple of issues in the Lincolshire questline" mostly about the glitch during pledging. This one specifically was never touched on from what i found.

  • gladjag57
    7 posts

    Having same issue, verified forums and seems like it is an issue for many to continue main story line. Even loading different times does not fix bug. see the npc in town hall but cannot open dialogue

  • gladjag57
    7 posts

    Having same issue, verified forums and seems like it is an issue for many to continue main story line. Even loading different times does not fix bug. see the npc in town hall but cannot open dialogue or return Brooch, from i can see this is ongoing since november. I am playing on PC and have logged over 110 hours, can Ubisoft support team get on this. Paying a lot of hard earned money to play a AAA game with tons of bugs ...... again.

  • imcrazyblah0
    17 posts

    ok enough being nice. FIX YOUR F#%$ING GAME NOW! or issue refunds.

  • wjx19910815
    6 posts

    The same problem is with me. I have completed all the tasks, and only the Lincolnshire task is left. Now this problem has caused the homeland to be unable to reach level 6 and the game cannot be completed. Please fix this bug as soon as possible

  • budzmcgee
    1 posts

    Same issue with somewhat different circumstances (from what I scanned).

    1. On Xbox series x.
    2. I collected Brooch as part of mission (not before)
    3. Instead of returning it immediately I decided to go to the Yule fest to get tokens I needed to get last items.
    4. Spoke to Reda and took 2 contracts. One (predators one) was right by camp so decided to take care of that. I still had the Ealdorman quest selected though.
    5. Completed Reda quest.

    Icon for Ealdorman quest was now missing on game menu as was "tracked" quest screen feedback (though quest was selected in menu). Unable to speak to npc by just going to location as well. Unable to progress now.

    Reading over thread the common theme seems to be that if the Ealdorman quest is interrupted in any way the game won't trigger the world event to speak to the NPC. For me it was doing another quest. Some it was a crash. For others having the item prior doesn't trigger the event for picking it up and same result. Maybe the sludge hammer solution here is to make it so anyone who hasn't beat the quest (after broach collected) and has broach in their inventory) has conditions for quest reset (triggers the expected event for picking up the broach) on game load or quest selection?

  • Toy_Gammer
    1 posts

    I am also stuck on "In the Absence of an Ealdorman', I explored the area and picked up to broach before I did the story quest. Then, when I arrived at the cellar where the Ealdorman had already died, I was unable to proceed for that point. No crash, when I returned to present the broach at the castle I was unable to interact with any NPC. Help!

  • Numbr4B0bby0rr
    2 posts

    @xgudnitex still not fixed on my end. I know they released that one update but this bug wasn’t included. Really frustrates me that they release the yule festivals update but people who paid for the game and can’t complete it because of this glitch are stuck twiddling their thumbs.

  • UbiExcellent
    756 posts

    Hi folks. I am sorry to say that at this time, we still do not have any updates to share with you all regarding a fix. I understand that this is not the update you all were hoping for, but I wanted to make sure you all knew our teams are still investigating this issue in hopes of finding a future fix. I'm extremely sorry for the continued wait, but I appreciate everyone's patience and understanding with our teams in the meantime.

  • LoudAssassin410
    10 posts

    @ubiexcellent so thats it?after a few weeks waiting for an update we get "sorry still looking into it?" I mean for [censored]'s sake offer refunds or at the very least helix credits for this because this issue has been around for months,people CANNOT continue the storyline and complete the game because of this bug,at this rate what is the point of even playing this game? The current game you have is broken and your events are bugged to [censored], Im trying my best to understand the situation with the pandemic and the holidays but to wait for months for a company to fix a bug so i can complete the story is outrageous,best believe that I will be writing to any game reviewing website about this.🖕 🖕 🖕 🖕

Suggested Topics