Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • neilgd
    18 posts

    @metspecial I did this and it worked! Seriously guys not a joke , get a exploding jar and use the jumping smash ability (can’t remember the actual name) it’ll break the jar which will set Halfdan on fire and he will get up and run away , if you’re lucky he will run to a point where you can interact with the body , pick the body up and take him to the throne . The cut scene will play , honestly dead happy to get that sorted out! If you choose to fight Faravid next tho you will have other things to do involving Halfdan, don’t be concerned tho he will still be dead on the floor but it doesn’t impact anything further , if you feel like the game randomly stops at any point and you don’t know what to do next either fast travel somewhere or save and reload the game, once you speak with Halfdan at Scarborough he will ask you to light the brazier, once you’ve done so, go back to see him and it should finalise the mission. Happy hunting fellas

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @neilgd I'm glad to hear MetSPECIAL's workaround helped you get past this bug! I've shared this with the investigating teams in hopes it furthers their investigation of this issue, so a more permanent solution can be found and implemented.

    Official Response
  • jegro002
    3 posts

    Great Thanks to u @metspecial. It took me like 4 hours. But FINALLY!!! Halfdan run down to the main stairs to the main hall, and i could finally continue with the quest. I have wait 3 months for these moment! So grateful! Thanks again @metspecial!!!

    Find oil jarl in Jorvik theatre and Multangular Tower!

  • Kcrik59
    1 posts

    Hey,

    I tried the jar, but his body just get on fire but he doesn't move at all....so the trick doesn't fix it. Am on PS5

    I worked in games and I still work in I.T, the community manager is lying in our faces. Urgent bugs are fixed on the spot, with work arounds if it can't be done properly.

    4 months, Ubisoft doesn't give a s*** as long as people have already paid for their game. I wish there was a legal route to force them into giving their unacceptable broken game.
    If you don't fix it within a couple of weeks, I will seek legal advice on you refunding or forcing you to do your flipping jobs.

    You are one of the worst company ever when it comes to bugs. Without kind gamers and internet, many people would be stuck. I hope q system where you get heavily financially penalised would be set in motion, so you actually do your job, and fix your s***

  • Ily_Winxx
    1 posts
    This post is deleted!
  • guest-laLwzA0b
    1 posts

    I cannot progress but from a different scenario. After talking to Moira, I go outside behind the hall. There is a little stick and straw building. Faravid is inside puking and puking etc. etc... No sign of Halfdan. Door is barred, I have a clean shot at the bar, but I can't draw any weapons. There is another person standing at the door and they just keep on knocking and knocking. Please fix!

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @kcrik59 I'm extremely sorry that our teams have not found a solution to this error with Halfdan being dead, which makes it so players like yourself are no longer able to progress in "Of Blood and Bonds". I've shared with our teams that this has also impacted your ability to move forward, and will continue to let everyone on this thread know where we are in the investigation process.

    Currently, the teams are still looking into this issue. For players on the PC or PS4, affected saves will be great to have! These can be attached to a support ticket, then the case number can be shared here for visibility purposes.

    @guest-laLwzA0b Would you be able to gather a video clip of this occurring, since this may be a slightly different issue? Once we've received this video link, we can go from there!

    Official Response
  • m0rgiah
    2 posts

    I, too, am stuck here on the PC version. I have tried the explody jar trick but unfortunately I cannot use any attack movement (i.e. jumping smash ability) nor can I shoot or throw the jar at him. The ONLY thing I can do is set it down on top of him and stare at it. This is SUPER frustrating. It's been a bug for at least 4 months and no resolution yet?? I guess I'm done with this game for a while. Sad face. 😞

  • m0rgiah
    2 posts

    UPDATE: FIXED! I have tried literally all the possible tricks on this thread and nothing worked EXCEPT going back to a previous save file (luckily I manual save often!) before Ricsige met his demise and I did NOT fast travel back to Jorvik but instead rode my horse the entire way and this time Halfdan was not face down and un-interactable! Thank you to whoever first mentioned this tactic. It worked for me! Hooray!

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @m0rgiah I'm happy to hear that by reloading a previous save and not fast traveling to Jorvik, you were able to workaround this issue, though I do apologize for the difficulties caused. Thanks for following up on this thread!

    Official Response

Suggested topics

Community details

19
Online
123.7k
Users
21.3k
Topics
109.6k
Posts