Welcome to discussions

Quick Suggestions

  • DanRag85
    10 posts

    Hi the legendary animal in sciropescire the beast of the hills is bugged for me. Instead of being underground eating from a barrel he is spawned above the ground near an enemy camp. If I attack him he does not fight back and if I kill him it does not count as clearing the mystery. I have tried saving and loading, leaving the area and coming back and also leaving the animus but nothing fixes it. I'm also still waiting for the daughters of lerion bug to be fixed that I reported over two weeks ago. I'm on x box one x. Thank you.

  • Ubi-Borealis
    Ubisoft Support Staff 2837 posts
    Best Answer

    Hello there!
     
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "Beast of the Hills" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
     
    If you are still encountering issues with "Beast of the Hills" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

     
    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
     
    Thank you! 😊

    Official Response
  • Darthtanien
    4 posts

    The bear is on top of the cave, not in it. If I go up top he is there, stuck in an animation. Reloading older saves do not work. Fast travel does not work either. I recorded a video of the problem. Anyone have any ideas?



  • MidgardGameplay
    1 posts

    Hi the legendary animal in sciropescire the beast of the hills is bugged for me too. Instead of being underground eating from a barrel he is spawned above the ground near an enemy camp. If I attack him he does not fight back and if I kill him it does not count as clearing the mystery. I have tried these actions:
    - saving and loading
    - leaving the area and coming back
    - leaving the animus

    Nothing fixes it. I'm on PS4. I saw another topic with the same problem but on Xbox (I actually copied the description of the bug since it is the same one: https://discussions.ubisoft.com/topic/85790/legendary-animal-beast-of-the-hills-bugged?lang=en-US )
    More than 70h of play, this screws my Platinum objective, please help. Thank you.

  • EricaAmerica_
    1 posts

    The game gives the prompt, shows the name of the mission but there is no bear there.

  • Darthtanien
    4 posts

    @darthtanien Thanks to Garrett H who posted a work around on my video. " I killed the bear up top and ran back to the lair and I completed quest " Thank you.

  • UbiKoreanBBQ
    Ubisoft Support Staff 217 posts

    @darthtanien Thanks for letting me know about the bear getting stuck! I'm glad to hear you were able to get this worked out though with community assistance. I've sent the video forward to the team in case any one else experiences this. 🙂

    Official Response
  • Onefastlife
    19 posts

    @ubikoreanbbq
    Please take a look at the jotunheim abandoned mine key bug. Various threads about it and no response.

  • DREWMAYES112
    2 posts

    I have the same problem, I killed it when it was glitched now I cant collect the quest it says still available but the bear is definitely dead.. 😕

  • morphus83
    3 posts

    Located the area for the legendary bear, however it will not spawn, been back 10 times now and still not spawning. is anyone else having this issue, obviously without this it will impact numerous trophies. Its bad enough having half the npcs bugged out.

  • m1au
    48 posts

    if you mean the brown/black one (terror of the hills?), mine spawned directly above his cellar in front of an enemy camp. was able to defeat him without him fighting back

  • guest-COwRcq2F
    12 posts

    If you're referring to the bear in Jotunheim I had to jump down into the pit with him to get him to activate.
    You also might have to do part of the storyline and hear the 3 ladies, Destiny, Fate and can't remember the name of the 3rd one talk about the Bear, the Serpent and the Tower for it to activate. I've had this happen before with having to do storyline for Wealth, Mystery or Artifact to be reachable.

  • tylerburke006
    1 posts

    Killed the beast of the hill and won’t give me the award and won’t let me fight the bear again

  • RabbitohsFan
    2 posts

    When I go to this fight, the bear is glitched just outside the camp above. I can kill the bear, but it doesn't even attempt to hit me. When I run back to the cave, the fight completes. I have loaded every save, with the same result. I'm on ps4.

  • vipandree
    8 posts

    @rabbitohsfan happended to me. Kill this beast very quickly and the beast didn't fight back.

  • morphus83
    3 posts

    @m1au it is the one on the hills, located in the wine cellar, lair of the beast from what I remember I will search around the area to see if I can spawn it, but watching videos it looks like it spawns in the wine cellar

  • m1au
    48 posts

    @morphus83
    yeah I know but mine did not spawn inside the cellar although he should. I got into that cellar than Eivor said something but nothing happened. Got out and saw that giant bear at the camp outside directly above the place where he should spawn

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    Hey all! Thanks for the information regarding this, as well as sharing your own findings!  morphus83 - I'm curious to know if you were able to find the bear in the end, or are you still having trouble locating it?

    Official Response
  • laughingvulcan
    2 posts

    Not sure if it's just me but when I found the beast of the hills, there was no creature in the actual underground dungeon, and I found it above ground roughly right above where its supposed to be, just sitting outside the nearby camp. I can fight/wound/kill it and it doesn't respond, nor does it give me the "legendary creature defeated" when its killed. I've fast traveled to other parts of the map since then but have no tried reinstalling.
    (picture: it stays in this position and then when I hit it it makes the "enemy spotted you" sound effect and it stands on four legs but still does not move or fight)

    EDIT: I've seen several other people have this glitch too
    undefined

  • laughingvulcan
    2 posts

    UPDATE: per someone else's comment, after killing the beast up near the camp I went back down to it's lair underground and it did give me the "legendary creature defeated" notification. It just wasnt where it was supposed to be and didn't fight back at all.

  • Bushwickedly
    109 posts

    Ran into this bug the other day. The Bear will be ABOVE Uriconium Ruins just outside the entrance to the enemy camp. Bear will NOT react to the player. Killing the bear will net you the 2 skill points, but no head.

    **Workaround:
    After killing the bear, go into Uriconium Ruins all the way to the end. Go under the wall through the hole to it's "lair" and it'll update as having been killed. IF you already killed it and now are stuck with it on your autosave, entering the lair should fix it.

    I did this and was able to complete the last Hunter's Hut Legendary quest and got the reward vs. waiting who knows how long for it to get fixed.

    P.S. Super easy kill. Manual Save before fighting to be safe. If for some reason it doesn't update once in lair AFTER killing it above, reload the save, and use a knock back attack (Dive of Valkeries or similar) and remove your weapons from both hands if high level and knock it back towards the lair above ground. If need be, go lair, pin mark on map above your marker, then go and knock it back to that area. Kill it (2 skill points will pop up), then enter lair (head and quest complete).


Suggested Topics

Community Details

191
Online
140.1k
Users
24.7k
Topics
127.8k
Posts