Welcome to discussions

Quick Suggestions

  • Hern_the_Hunter
    19 posts

    The oversized animal was not found in his den underground. He was standing upright near the east entrance of the nearby stockade pawing at thin air. Three soldiers walking towards the east side entrance all took fright on seeing the Beast. So much so that they ran out of the western side of the stockade never to be seen again. This made it easy to take out the remaining soldiers and loot the chest. I then went back to take up a position on the rock formation looking down at the Beast. The first arrow resulted in the Beast dropping onto all fours. However it didn't move or react as I loosed at least 15 more arrows at it's head until it fell with the front part of it's body on the ground and it's rear hanging up above the ground. On looting the body all I got back was one hunter arrow. I now go to the underground complex and on reaching the slide hole leading into it's den, I'm suddenly credited with killing the Beast of the Hills. I go into the den and am puzzled as to how it got out of there in the first place, as the only way in/out was that slide hole!?

  • Ubi-Woofer
    Ubisoft Support Staff 1195 posts

    Hello everyone! Thanks for posting here on the forums about this. It certainly does sound strange that the Beast was out in the wild! I've merged a few threads together that seemed to be for similar reports regarding this fight, so apologies if any conversations seem disjointed or out-of-place.

    As a quick question first of all - are you missing any rewards / quest completion etc. that you should have received, or is this meant just as a report that the Beast was not to be found in its correct location? If missing rewards or completion, did you ensure to return to the Beast's proper lair after defeating it outside of the ruins (if you were able to damage it) per the account of TYUHYUN? Alternatively, did hanging around in the mission area like guest-o3bRrgAw complete the fight for you?

    If any of you happen to have captured any video clips of the Beast's odd behaviour so that we could look into this further on our side, that would be fantastic. I know that my colleague KoreanBBQ passed on some information about this issue already, but it would be good to open a formal investigation if progress is being blocked by this. 🙂

    @Onefastlife Please do not seek to derail threads by posting about unrelated issues - we'll reply to each thread posted as soon as possible. Thank you!

    Official Response
  • Hern_the_Hunter
    19 posts

    @ubi-woofer Yes I was given the rewards at the time of being informed that I had killed the bear concerned. In fact it was the last mystery in Sciropescire (Shropshire) which along with artefacts are filled in and both ticked. I still have some wealth that I have yet to deal with. However I fear that I didn't think to capture any video clips of the encounter. Sorry!

  • leroy198532
    30 posts

    Same here

  • guest-D2tL2DSL
    1 posts

    He spawns above the cellar outside of a camp. He wont fight back so he will be easy to kill. Once you have killed him go back to the wine cellar he should be in and the quest will then complete it self.

  • peregrinorophin
    1 posts

    I went to see the legendary bear to gauge its power and see if I could kill it, while also getting wealth/loot just north of the legendary beast icon. After killing the Britons and heading towards the icon I noticed the bear outside the camp. However it was not moving in an aggressive manner, very passive. I attempted to kill it, and was successful with no interaction from the bear. Upon completion, Eivor was transported into mid-air and was free falling to the ground. I reloaded the game and the bear was in the same place, I attempted again and had the same result. Next game load I thought I would go to the correct location as indicated on the map, and there was nothing in the location and the bear was not spawning outside the camp to the north either.

  • Mona1605
    1 posts

    Hello, I have problems with the legendary animal the bear it is not in the cellar it is stuck above it on the mountain and does not move. The new update has not solved this problem.

  • Rise_Up44
    1 posts

    I finally beat the bear but a glitch threw me into the ceiling/wall upon his death and it gets stuck so the save reloads after the glitch catches up. Gone back two more times and same outcome. I am hoping that maybe when I try tomorrow it will work different. I may try to make sure the final blow is a bow arrow to keep away from him.

  • TheOutsider-NL-
    11 posts

    I just killed the Legendary Bear in Beast of the Hills (Sciropescire) And it was a tough one. But I do not receive confirmation that the mission has been completed. Instead, it remains open. I restarted the game but it doesn't matter. Anyone else having this problem?

  • Ubi-Borealis
    Ubisoft Support Staff 3931 posts

    Hello there,

    I'd like to reach out to you all with an update from the development team regarding "The Beast of the Hills" spawning outside of the event area. They intend to release a fix for this issue in a future update!

    We don't yet have a confirmed ETA for when this update will be released. Once we have more information to share, it will be posted within this thread and in the News & Announcements forum.

    Thanks all 😊

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 3931 posts

    Hello there!
    I'd like to reach out to you all with an update. I'm happy to announce that the development team intend to deploy a fix for "Beast of the Hills" in TU 1.2.2. This update will be deployed 15 June, 2021 at 2 PM CEST / 8 AM ET.
    If you are still encountering issues with "Beast of the Hills" following TU 1.2.2, please don't hesitate to update this thread so we can take a closer look. Please include a video that shows the following:

    • You have the latest Title Update installed on your platform. You can view this information in the opening game menu in the bottom right-hand corner.
    • That the issue continues to persists in-game following this update.

    Additionally, please ensure that you have an up-to-date save uploaded to the cloud. We can then pass these reports to the development team for further investigation.
    Thank you! 😊

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 3931 posts

    Hello there!

    As we have had no further reports of this issue persisting in-game following the release of TU 1.2.2, we will now be locking this thread.

    If you encounter any further trouble with the "Beast of the Hills," please don't hesitate to open up a new thread so we can take a closer look. When opening a new thread, please include as much information about the issue you're encountering as possible. Any images or videos that demonstrate the issue in-game are also helpful for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics

Community Details