Welcome to discussions

Quick Suggestions

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts

    Hello there @AP0TH30S1S4! Welcome to the forums 🙂

    The development team are still investigating this issue further. Once we have any new updates to share from the investigation, they will be shared within the News & Announcements forum.

    Would you be able to provide us with a video that shows you're unable to interact with Trygve, and that you're unable to proceed further with this quest? We can then pass this along to the development team for a closer look.

    Thanks! 😊

    Official Response
  • guest-Ou4NrgWO
    1 posts

    Been having the same problem. May have found a *POSSIBLE* fix for this. If you aim at his head with your bow, there's a certain spot that turns red. I shot at this and it let me speak to him straight away. Good luck 🤞

  • BriAtHK
    6 posts

    @guest-ou4nrgwo

    I tried just now and still no way to interact with Trygve.

    Ubisoft, please fix this. This area is the only one left for me to do and it is very frustrating that I cannot finish the main storyline because of a bug. I want to finish this but your game doesn’t allow me to!

  • maxbicking
    Original poster 3 posts

    @ubi-borealis OP here. I've been waiting for a fix for this since I originally started this thread in early December 2020. I uploaded a video at the link below (can't upload a vid directly as I don't have permissions)

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts

    Hello there!

    @guest-Ou4NrgWO - Thanks for sharing how you were able to interact with Trygve in "Borrowed Time." I'm glad to hear you've been able to proceed with this quest.

    @BriAtHK - Please be assured that the development team are investigating this issue further. Once we have any updates to share with you all from the investigation, we will post about this within the thread or within the News & Announcements forum.

    @maxbicking - Thank you for taking the time to share a video with us. You may not be able to upload the video directly to your posts, but sharing a link works great instead! I've added this video to your original report to the development team.

    Thanks all! 😊

    Official Response
  • Joelcito_
    1 posts

    Just had this glitch today on PS5 and was able to fix it by loading back to the Vili in the cave under the waterfall. When I got to Odin's Rest there was a talk option next to the NPC that disappeared when I pressed triangle. Finally I tried someone else's suggestion to shoot an arrow at his head and the option to talk reappeared so that I could continue the quest. Hope this helps if anyone else is stuck there.

  • UbiExcellent
    Ubisoft Support Staff 756 posts

    @joelcito_ Thank you so much for sharing this workaround! I'm delighted to hear that you were able to work past this issue with not being able to interact with Trygve at Odin's Rest. I also share the same sentiment and hope that this helps others that encounter this issue as well.

    Official Response
  • ShamelessHayden
    1 posts

    I am on pc and on borrowed time quest I made it to saving the people and one lady keeps walking back into the fire I saved her 3 times then I said screw it and tried to kill her then the last with the quest sign on her head she won’t leave the place she’s in and I have checked double checked all houses there is no one else to save yet I can’t progress can’t even leave the village I’m so sick of glitches with this game it’s ridiculous I’m about to just leave Ubisoft alone for good

  • BriAtHK
    6 posts

    @ubiexcellent
    happy to report that the update today handled this!

  • Ubi-Mark.
    Ubisoft Support Staff 996 posts

    Hello @BriAtHK,

    Thank you for sharing!

    We're glad that this issue has been resolved for you. Happy gaming and if you have any additional questions, please let us know.

    Official Response

Suggested Topics

Community Details

140
Online
139.3k
Users
24.5k
Topics
126.6k
Posts