Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • frev936
    1 posts

    @twincipher same for me

  • dam411
    5 posts

    Nope, still not working.

  • X13_verx
    2 posts

    @twincipher can confirm, still bollocksed. FFS

  • jensime
    21 posts

    The patch did not solve my issues either

  • MV212020
    3 posts

    Yea lw wanting my money back

  • guest-I4LnUaCI
    2 posts

    Delete game file (not saves), redownload game and update with patch 1.04, solved it for me (ps4) don't know if it'd work again but once was enough got past it.

  • salterq
    3 posts

    theres no way theyre gonna fix this. I cant even interact with valka and go to asqard since i never got her quest. nice scam ubi

  • andre7227
    1 posts

    I believe I found a fix. You'll first need to switch your mission in the quest tab to any other mission other than "A brewing Storm". After that you then have to go back to the main menu, and then load back into the game. There you should then get the cutscene to continue the story.

  • Silent_Player69
    1 posts

    Dag keeps attacking random npcs in my settlement after I got to sleep and wake up. I know what happens, instead of calling me out he just walks around and starts attacking npcs. I tried fighting him but every time I beat him he gets up at half health and keeps fighting. I tried loading an earlier save but that doesn’t work. Do I have to start all over?(I’m on the Ps5)

  • charly_046
    3 posts

    Hey Ubisoft solve the Fn issue why dont yoy? It is beyond conteptible how you are treating the gaming customers.
    Please address this in a decent fashion!!

  • charly_046
    3 posts

    @andre7227 what you mean load back? select one of the saves or just go back to the game ?

  • Godlifexxx
    2 posts

    Hello, does anyone else have a bug in " a brewing storm" mission? When I go to sleep it only shows black screen and after few seconds a save icon on bottom right. Nothing else is happening. Tried everything from uninstall to second ps4 and nothing helps. Already contacted Ubisoft support but to no avail. I think we need new patch or something like that.

  • dereknorman4
    7 posts

    @charly_046 he means to choose a different mission in the tracker then exit to the main menu (not the game) by clicking left on d pad while in game menu then hit exit to main menu. After this hit continue from the main menu and load back in. ***notice I have not tried this. I am just clarifying his words. I saw him post somewhere else as well and he was more clear

  • dd2324
    1 posts

    @dereknorman4
    It did nothing for me.

  • Sodipoppies
    2 posts

    I still haven't been able to. I feel like I've tried every fix. I've tried deleting the game and redownloading it multiple times, I've tried building structures beforehand, I've tried redoing the cent arc, I've tried changing the mission I'm on then reloading through the main menu. I really don't want to play through the last 30-40 hours again, I just want to get past this one quest.

  • dereknorman4
    7 posts

    @dd2324 yea. I doesn’t seem to have a fix. From other threads the bug seems to happen to players who did not do the Asgard quest. They really need to patch this. Kinda ridiculous with the amount of views and comments this thread has

  • chhmo2000
    10 posts

    I started over.... +40hours of gaming all for nothing. I need to finish the game, otherwise its gonna bother me, but I wont enjoy it like I did the first time...

    Ubisoft needs to get their [censored] together

  • voltage1972
    1 posts

    Yes I have the same problem for the last week!

  • xReverendGreen
    16 posts

    Also having the same issue - can also note that I have not done the Asgard quest yet (ironically because the game does not show the In Dreams quest or a prompt to speak to Valka). Super f****** annoying, especially now that this is happening to one of the main story quests.

  • cws117
    1 posts

    I've got a bug where I go bed wake up for a brewing storm no objective comes up and dag is just hostile to all, game doesn't work properly needs fix ASAP (xbox)

Suggested Topics

Community Details

72
Online
130.4k
Users
22.6k
Topics
117.2k
Posts