Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • FrustratedGamer
    28 posts

    @andersonlb_ Hey, that's awesome! I'm glad I was able to help out at least one person. 🙂

    Big relief isn't it? Took me about the same time. It's a slog, but if you're determined you can make relatively quick work of it.

    Collecting everything all over again - that's time consuming. I've made a point of just cruising around and doing everything from the monoliths to the tattoos in the areas I'd been to ... I still haven't started a new pledge after having surpassed the bug two weeks ago lol. It's nice to just enjoy the game again (still minus hoofbeats - but I'll take what I can get).

  • FrustratedGamer
    28 posts

    @fonz313313 Neither. I was doing the dirty with Randvi when I got the bug.

  • FrustratedGamer
    28 posts

    @rigger100472 I posted a detailed how-to a couple of weeks ago, if you want to search for it down below. One other player has reported success following it (speed run for both of us took approx. 12 hours).

    But, the suggestion above is spot on. Grind main quests, stay out of areas you're not pledged to. Don't build Valka's hut and keep settlement around level 3-4.

  • guest-ldR4bJDO
    3 posts

    add me to the list

  • oracleoftruth
    6 posts

    @renz832017 I agree in general but how would ubisoft know who genuinely had this issue?

  • ubimick7883
    2 posts

    will the dag glitch ever be fixed?

  • DiamondRaider19
    1 posts

    I am stuck on ‘A Brewing Storm’ like everyone else. When will the bug fix get released?

  • ubimick7883
    2 posts

    Are you any closer to fixing the brewing storm glitch where dag doesn’t appear?

  • GoreDDO
    3 posts

    Seriously guys! get it fixed, or at least let the community know that you are working on fixing this!

  • guest-bvBPQo9P
    5 posts

    How is this still a thing... I can’t wrap my mind around how little they care about and how they are trying to deny this is even happening. No acknowledgement, no empathy, and they take no accountability. What a gross company.

  • XxAce_DragonZxX
    1 posts

    @ubi-swaggins
    bro it’s fuckin April 15 and u guys still haven’t done anything bout this glitch or even addressed it this is soooo ridiculous!!!!

  • liahim13
    17 posts

    @Ubi-Borealis Ubisoft when are you going to fix the quest ??!?!!?

  • Amboahaolo
    8 posts


    I know it must be unpleasant for you support staff to read tons of angry comments on here, which is why I try to be nice about it, but seriously…I think a lot of people would appreciate it if someone could tell us roughly when the promised update is supposed to come out. Even if the exact date hasn't been announced yet, surely someone in the company knows if it's going to take another couple of weeks, a few months, or a few years, right?
    What I don't understand is, if a fix has already been found, why is it taking so long to make it available to all players?
    Also, will we be able to resume playing right where we stopped or will we still have to use an older save file?


  • DocHolliday182
    67 posts

    @amboahaolo I'll try to be nice as well for I might be sanctioned! Was told to be more patient!

  • fafner1010
    53 posts

    ................

    I have quit this game for two months.

    still the same situation??

    USELESS GAME TEAM. UBISOFT SUCK!

  • stoneshabad
    5 posts

    @FrustratedGamer

    Also, a quick update: My partner finally hit 'A Brewing Storm' and managed to avoid the bug. No restart, but she took my advice (well, some of it - lol) once I'd worked around the bug with a restart. She was on her third pledge when I hit the bug. So ... she took the same path as suggested, pledging to Cent after Sciropescire. She'd collected most of the wealth and completed most of the mysteries in the areas she'd pledged to. Completed the first Asgard arc. Settlement @ level 4. Completed Reda's contracts regularly.


    This is super helpful.

    The more we can narrow down the way to play to avoid the bug - helps everyone.

    Is it Building Valka's Hut or Pledging order or Exploration or Town Level or any combination that seem to be the current possible triggers. Is it building Valka's hut? Is that universal with bugged plays?

    Sucks that so many people are finding their way here because it means they are just as frustrated with this play stopping bug as everyone.

    Thank you for providing solutions. Thank you anyone that did replay if you responded back here with solutions.

  • guest-bvBPQo9P
    5 posts

    Im starting to think ubisoft and ac dev team worked on the johnson and johnson vaccine

  • guest-bvBPQo9P
    5 posts

    Have you ever bought a big bag of chips? Then when you open it, 60% of the bag is just air. Thats because ubisoft produced it.

  • LinesChen
    3 posts

    @ubi斯瓦金斯Avar wakes up like this. There's no animation. Dagger doesn't show upundefined

  • LinesChen
    3 posts

    @felinegnat22228 I have tried to change the gender,it didnt work.

Suggested topics

Community details

16
Online
123.3k
Users
21.2k
Topics
109.2k
Posts