Welcome to discussions

Quick Suggestions

  • ashwii
    3 posts

    Glitch when you go to sleep in a bewwing storm where you are supposed to be awakened by Dag. This doesn't happen for me and I awaken to just the storm. I find Dag walking round and when I kill him nothing happens and he spawns back to life. I can't talk to anyone in the game after I initiate this quest.

  • Liberty_Kat
    2 posts

    Yes same problem here, can't progress, can't talk to anyone or progress game after Brewing Storm bug on PC. I reloaded the entire game, same problem!! How to fix this?

  • Liberty_Kat
    2 posts

    Same here (PC version). I did not complete the quest, now Dag appears outside, but you cannot interact with him nor anyone else and the game is completely broken. Changing to different quest doesn't help. I reloaded the entire game, doesn't fix it. Cannot play the game at all until this is fixed!.

  • MV212020
    3 posts

    @liberty_kat did a chat woth ubisoft and they fixed my gameplay!!!! ALL THEY HAD TO DO WAS DELETE 50+ HOURS OF MY GAMEPLAY AND LOADED A SAVE HOURS BEFORE THE CENT QUEST. I LOVE THIS GAME SO MUCH. Im [censored]

  • maxxsinner
    29 posts

    From everything I have read, this stems back to a glitch with the upgrading the seers hut in Ravensthorpe. Only way to fix it so far is to load an old saved game from around Level 3 in Ravensthorpe and try to get the seers quest to work. Obviously this means around 20hrs of lost game time and if you're like me saving over old saves, chances are you will be all but starting the game from scratch.

    Disappointed that quality games are a thing of the past. Companies like Ubisoft that charge top dollar for titles that have major flaws like constant game crashes, corrupt save game files and major quest bugs only keep getting away with it because we keep paying. Need to let them know that we expect better and the only way is to vote with our wallets.

    Can see why this wasn't sold on Steam. Would be refunds everywhere.

  • UbiKoality
    Community Manager 440 posts

    @ashwii Hey there! I'm sorry to hear that you're stuck in this quest in Assassin's Creed Valhalla. The team is looking further into this, but can you please make sure you've completed all our troubleshooting steps listed here? Rebuilding your database specifically would be great to try! This process acts like a computer disk defragmenter and will not affect your save data. If the problem persists, please upload your save files in a case at support.ubi.com! This would help to aid the team in their investigation of this issue.

    Official Response
  • charly_046
    3 posts

    This will be almost a month old, and the only reply is restart your game? please come up with the fix. you should be ashamed of the product you are puting out. its a pity I love the AC games, but this is a major turn off from buying new ones.

  • playequipment
    2 posts

    So, there are a bunch of people that have reported this as a game breaking bug - the cutscene does not play when you are asked to go to bed and then the game breaks where you are not given a quest line item to fight Dag - there is another thread with more than 100 replies. After this, I broke the game even further by heading to Jorvik, without pledging to the area - starting the quest and then running in to a bunch of issues when it was time to inspect inside the Abbey. I then went back to an earlier save, re-did all of the pledges except Cent and after doing Cent still ran into the same issue. Overall I've probably spent more than 60-80 hrs messing around trying to get things working without having to restart, my main save game after Cent is at 2.5days played.

    It has now been a month since this was reported and there is no solution other than to restart the game. If you do restart your game, don't bother doing any of the side stuff and just go through the story - make sure you talk to Valk before upgrading her hut as that will break her questline too and you wont be able to get to Asguard. This is a steaming pile of poo at the moment, a game paid for and installed that I really wanted to finish before Cyberpunk came out - however it doesn't look like that is going to happen as there seems to have been no word on a fix for this.

    Ubi, I am not going to restart this game after the time invested. Please provide an update!

  • monaali791
    4 posts

    I have the same problem. I believe my issue is due to Valka. She didn't appear after i reached level 3 in Raventhorpe. I am now level 4 and she is still not appearing. The update patches couldnt help. And the support from Ubisoft asked me to upload the save to my complaint, but added that they wont do a personal fix but rather a global fix. So it is either they prepare a patch for it (which i doubt is possible) or you restart the game..

  • monaali791
    4 posts

    I have the same problem. I believe my issue is due to Valka. She didn't appear after i reached level 3 in Raventhorpe. I am now level 4 and she is still not appearing. The update patches couldnt help. And the support from Ubisoft asked me to upload the save to my complaint, but added that they wont do a personal fix but rather a global fix. So it is either they prepare a patch for it (which i doubt is possible) or you restart the game..

  • Scangeo
    3 posts

    @ubi-spud Do we have a resolution for this issue yet? Seems so many other people have run into this same problem. I've been waiting for days now for a patch because, after 100 hours of gameplay, I can't progress the story any further as no new story missions are available and, despite having left messages for tech support via Facebook and Twitter as well as here, nobody wants to respond... Not happy with Ubisoft at all right now. Your customer service is woeful.

  • guidedbyfailure
    1 posts

    I cant start the second story arc for lincolnscire I go to pledge and it just gets stuck i can move the camera but not the character and I can't open the map or create a save I cant do anything but move the camera and ive done every thing else on the map so I cant complete the game until this if fixed you spend 90 on a game and then find out you cant complete it because ubisoft let it come out with some many bugs

  • UbiKobold
    Ubisoft Support Staff 541 posts

    Hey! So sorry for my late reply, but thank you all for your patience during these busier times! This issue is currently being investigated, and I was wondering if you all would not mind providing your save game files? I would like to send them to the Game team for review. If so, please create a ticket and attach the files. Then, provide your ticket number here. Thanks!

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts

    Hello there!

    I've gone through the forums and merged all of the posts regarding being unable to interact with Dag following Eivor's rest in "A Brewing Storm" into one megathread.  In future, if you encounter this issue, please post it within this thread so all the information is in one place.

    Thank you all for your reports, and for sharing your experiences of the issue. We're sorry to hear that this has prevented you progressing within the game. By the sounds of it, it looks like if you don't complete Valka's quest ("In Dreams") prior to pledging to Cent, you're more likely to encounter this issue.

    The development team has been made aware of this issue and have been investigating further. They have been unable to reproduce this issue so far. We would like to collect more information from affected players in order to assist with their investigation 🙂

    If you've encountered this issue on any platform, please can you let us know the following:

    • Which platform do you use (PC/PS/Xbox)?
    • Have you been able to complete the quest "In Dreams" prior to this issue occurring? If so, could you let us know if you completed this quest prior to pledging to Cent?

    If you are encountering this issue on PC or PS4, please could you open a support ticket and attach the following files to your case:

    Once you have opened your support ticket and attached these files, please can you share your case number within this thread? We can then pass this information onto the development team. Thank you!

    Justus1302 - Thank you for sharing a video. I'll pass this onto the development team so they can take a closer look.

    Official Response
  • dereknorman4
    7 posts

    @ubi-borealis Hello I am having this problem on Xbox. I never completed “in dreams” because I did not level up my settlement to level 3 before doing cent. I tried to upgrade valkas hut in raventhorpe during my cent pledge but it did not do anything. Others have said that their valka quest was bugged and they never got it in the first place once they reached settlement level 3. I also have not completed jotunheim quest or vinland.

  • Ubi-Borealis
    Ubisoft Support Staff 2812 posts

    @dereknorman4 Hello there!

    Thanks for sharing this. I'll pass this onto the team 😊

    Official Response
  • H0mayun
    3 posts

    Ive completed all valka quests and the problem still remains, after waking up i find Dag in longship

  • guest-zBVz0ESF
    13 posts

    @ubi-borealis I have this problem on PS and i didn't do the In dreams quest. Moreover my settlement is level 5 or 6 and after doing valkus hut i didn't receive her quest , nor I'm being able to contact with her

  • Draekavak
    1 posts

    When i go to spleep the screen goes black and then i wake up and cant do anything.

  • Csquared4
    5 posts


    I am playing on PC.

    Did not start or complete the "In Dreams" quest at all. Settlement is currently level 5.

    Cannot talk to Valka, Reda, or Radvi.

    Already pledged to Cent and completed the Cent storyline and talked to Radvi. My next quest in the main story line, is A Brewing Storm. To start the quest, you must go to sleep in the Longhouse. I go to sleep, the screen goes black for about 5 seconds, then I wake up standing beside my bed with it raining outside. I can go outside and see Dag casually walking the settlement if he hasn't engaged in combat with someone within the settlement. If triggered, he enters combat with myself and allies around the settlement. Throughout the fight, he will slowly drop weapons. First he drops his shield and brings out two axes, then eventually throws 1 axe and just is left with 1 axe. Then afterwards, is eventually left with just his fist punching me. Once I get him to half health, a short cut scene zooms in while Dag and myself are locked with weapons and we have a short dialogue about us not having to fight. I drain Dag's health down to 0 and it does a short 'Kill Cam' of me kicking dag in the chest but my foot never hits him and he stills falls over. Then after 2-4 seconds, he stands back up and is half health. This can be repeated an infinite amount of times, he cannot be killed.

    Once I realize that, I revert back to my original save before going to sleep and play the game like normal, such as discovering things, upgrading my settlement, and doing side quest. Nothing I've done has 'resolved' or 'fixed' the Brewing Storm issue of the cutscene playing around going to bed at the start of the quest.

    I hope this helped.

Suggested Topics

Community Details