Welcome to discussions

Quick Suggestions

  • H0mayun
    3 posts

    Ive completed all valka quests and the problem still remains, after waking up i find Dag in longship

  • guest-zBVz0ESF
    13 posts

    @ubi-borealis I have this problem on PS and i didn't do the In dreams quest. Moreover my settlement is level 5 or 6 and after doing valkus hut i didn't receive her quest , nor I'm being able to contact with her

  • Draekavak
    1 posts

    When i go to spleep the screen goes black and then i wake up and cant do anything.

  • Csquared4
    5 posts

    @ubi-borealis

    I am playing on PC.

    Did not start or complete the "In Dreams" quest at all. Settlement is currently level 5.

    Cannot talk to Valka, Reda, or Radvi.

    Already pledged to Cent and completed the Cent storyline and talked to Radvi. My next quest in the main story line, is A Brewing Storm. To start the quest, you must go to sleep in the Longhouse. I go to sleep, the screen goes black for about 5 seconds, then I wake up standing beside my bed with it raining outside. I can go outside and see Dag casually walking the settlement if he hasn't engaged in combat with someone within the settlement. If triggered, he enters combat with myself and allies around the settlement. Throughout the fight, he will slowly drop weapons. First he drops his shield and brings out two axes, then eventually throws 1 axe and just is left with 1 axe. Then afterwards, is eventually left with just his fist punching me. Once I get him to half health, a short cut scene zooms in while Dag and myself are locked with weapons and we have a short dialogue about us not having to fight. I drain Dag's health down to 0 and it does a short 'Kill Cam' of me kicking dag in the chest but my foot never hits him and he stills falls over. Then after 2-4 seconds, he stands back up and is half health. This can be repeated an infinite amount of times, he cannot be killed.

    Once I realize that, I revert back to my original save before going to sleep and play the game like normal, such as discovering things, upgrading my settlement, and doing side quest. Nothing I've done has 'resolved' or 'fixed' the Brewing Storm issue of the cutscene playing around going to bed at the start of the quest.

    I hope this helped.

  • maxxsinner
    29 posts

    @ubi-borealis

    • On PC
    • "In Dream's" quest was not offered when I upgraded the Seer's tent. Was a quick cut scene with no quest added to my list.
    • Cannot talk to Valka even if I go back to an old save before the Cent quest
    • After completing "Pledge to Cent" and resting in bed, Dag becomes combative but is unable to be killed.
    • Support ticket was unable to be submitted as the 'submit my ticket' via chat button was grayed out even though I was logged in and submit via email button disappears when Gameplay/Achievement or Trophy missing options are selected (this doesn't come as a huge shock by at this point.....)


    I assume that the support teams are flooded with submissions at the moment. Guess that is the result of selling a broken game.


  • OakString250667
    1 posts

    I hope to see the glitch for the mission a storm brewing fixed soon I can't continue to play story been forced to play other games on a count of it

  • Xehanor
    1 posts

    I can't complete this mission which has a bug. Dag is under control, he doesn't want to talk (he's supposed to be waiting to talk) and is aggressive with everyone, I killed him like 20 times, but every time he wakes up again and again, how can I fix this?

  • randpsv
    1 posts

    @grandmasternort Still having the exact same thing on ps4. Also I did all the updates to the game

  • Bloodyvampie
    7 posts

    @ubi-borealis

    I'm running into some trouble with this quest as well. Was able to complete it but got some settlement glitches as reward afterwards:

    https://discussions.ubisoft.com/topic/87354/dead-horse-and-tove-glitch-after-a-brewing-storm

    Playing om Series X. No Valka issues, all done before this mission. Not sure about Jotunheim though...

    Would be great if you could look into my thread as well!

  • monaali791
    4 posts

    @ubi-borealis
    Hello,

    I am on PS4, Valka did not appear when I reached level 3, now I am level 5 in the settlement, still, she didn't appear.

    When activating a brewing storm, nothing happens after I wake up, and I cannot speak to any NPC nor fast travel.

  • guest-PrOUC62F
    1 posts

    i'm playing on ps4 pro. version 1.04 - version 1.10 as well.

    my town is level 5. i can't talk with valka, never went to asgard. never done the quest a man best friend. after the report of cent, in the quest brewing storm, i must go to bed. no cut scene, next scene i'm near the bed, outside is raining, dag is hostile vs me and vs the clan. game breaking.

  • Lumbi12
    1 posts

    Playing on PS4.
    No cutscene with Dag after sleeping.
    Valka never arrived „official“ with a quest in my town. I can find her by her house, but not speak to her. (Town level 4)

    Update to 1.1 don‘t fix it.

  • xReverendGreen
    16 posts

    On base PS4, AC version 2.00. I don't recall if I received the request from Valka to pick up thistle, but I know I instead went on with the main story quest. I have finished the Cent storyline but when I try and do "A Brewing Storm" I wake up after falling asleep and there are no objectives or cutscene with Dag and Dag is just a generic hostile NPC. I can kill him but the quest does not update.

    I have also tried to go back to Valka to complete the In Dreams quest, with 10 thistle in my inventory, but there are no dialogue prompts above her head and the "In Dreams" quest doesn't even show in my available quests (nor does it show up as a completed quest).

  • BoxyFlounder161
    4 posts

    @marcabisaad The new patch 1.1.0 does not fix the glitch, I tried.

  • BoxyFlounder161
    4 posts

    In the new patch 1.1.0, it still acts the same and now have to wait for like another month for a new patch.

  • Kaputende
    1 posts

    @boxyflounder161
    Was hoping it would too, currently can't do any story line or use anything in my settlement, including upgrading gear at Gunnar's. Only thing I can do is settlement upgrades. Gonna be super [censored] if I have to restart, but looking more than likely.

  • H0mayun
    3 posts

    I had to restart the game all over again after playing 40 hours, and fortunately this time i got the cutscence. But it was my most frustrating 15h in my whole life. I never expect such buggy game from Ubisoft.
    I played 15h without playing side quests and i believe most of this was riding horse or traveling with ship. It so unreasonable big game and it so boring.
    For those who decide to restart the game This time ive finished "in dream" quest before cent and played no other side quests

  • Darthkribs
    1 posts

    A Brewing Storm Glitch. I go to sleep wake up and there is no one to fight. I have to walk around the base camp to find him kill him 2 times and nothing happens. The latest patch still did not fix this issue. I have been stuck here for a week now and I have done everything I can. I can not advance the game. Any suggestions on how to do this quest?

  • dereknorman4
    7 posts

    @h0mayun that’s sad. I contemplated this but I had 30+ hours in side missions and free world that I refuse to do again

  • Niy4h12
    4 posts

    Can you guys plz fix the A brewing storm bug. I was enjoying the game till up to this point reaching this buggy quest. Your latest update did not fix this issue as well and I so much like to continue my story mode. I also refuse to do everything over as I have put in over 82 hrs in to this game and to do everything over will discourage me.

Suggested Topics

Community Details

59
Online
138.7k
Users
24.3k
Topics
125.8k
Posts