Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • EmoKid199387
    19 posts

    Yes please fix this I had to deal with the ubba bug now this bug come on or at least a hotfix

  • Niy4h12
    4 posts

    @emokid199387 They need to give us a hotfix ASAP

  • guest-r4j0ct2F
    1 posts

    Same happening to me. Please fix

  • jws1878-1953
    7 posts

    After I sleep the quest description is missing and Dag is roaming and figthing trough the village.
    quest is not finished if Dag is killed.

  • guest-zBVz0ESF
    13 posts

    still waiting for over a month for this bug to get fixed xd

  • Bloodyvampie
    7 posts
    This post is deleted!
  • Bloodyvampie
    7 posts

    @bloodyvampie @Ubi-Borealis

    So the Yune festival settlement update unfortunately didn't fix my dead horse carcass. Still there, please solve it 🙂

    Just need a "reset" of the settlement...

  • H0mayun
    3 posts

    Now im stuck again. There's no quest after kingdom's end. Im done with this game

  • guest-IpsUFvZ2
    1 posts

    @ubi-swaggins Any update on this? It has been a month. I am at the point of just returning the game for a refund.

  • Ubi-Raziel
    Ubisoft Support Staff 197 posts

    @guest-ipsufvz2 Hello! I'm sorry to read you're also affected by this.

    Our team were unable to reproduce this issue in a testing environment, it seems to happen under specific circumstances.

    Would it be possible to provide your save file, so our team can experience the issue first hand?

    This support article will help you find the save file: https://support.ubisoft.com/en-gb/Article/000080981/

    Thank you!

    Official Response
  • liahim13
    17 posts

    @ubi-borealis Hey Ubisoft, do you have any ETA for the fix of this quest? I can't progress from 3 weeks already.

  • Ubi-Orion
    Ubisoft Support Staff 148 posts
    Hello there!

    I've gone through the forums and merged all of the posts regarding being unable to interact with Dag following Eivor's rest in "A Brewing Storm" into one megathread.  In future, if you encounter this issue, please post it within this thread so all the information is in one place.

    Thank you all for your reports, and for sharing your experiences of the issue. We're sorry to hear that this has prevented you progressing within the game. By the sounds of it, it looks like if you don't complete Valka's quest ("In Dreams") prior to pledging to Cent, you're more likely to encounter this issue.

    The development team has been made aware of this issue and have been investigating further. They have been unable to reproduce this issue so far. We would like to collect more information from affected players in order to assist with their investigation 🙂

    If you've encountered this issue on any platform, please can you let us know the following:
    • Which platform do you use (PC/PS/Xbox)?
    • Have you been able to complete the quest "In Dreams" prior to this issue occurring? If so, could you let us know if you completed this quest prior to pledging to Cent?

    If you are encountering this issue on PC or PS4, please could you open a support ticket and attach the following files to your case:

    Once you have opened your support ticket and attached these files, please can you share your case number within this thread? We can then pass this information onto the development team. Thank you!

    Justus1302 - Thank you for sharing a video. I'll pass this onto the development team so they can take a closer look.

    Hey there folks.

    Just a reminder if you are playing on Playstation 4 or PC and you're experiencing this issue the development team are requesting save files from affected players. Please follow the links provided in the post above to get those to us. Thanks!

    Official Response
  • Csquared4
    5 posts

    @ubi-orion

    Hello. I just submitted my save file and a copy of my DxDiag.

    My reference number for my case is: 13639491

    Thank you

  • meatball22
    1 posts

    I have no idea why this KNOWN BUG isn’t your top priority. I’ve been playing ubi games for decades and I am about to throw in the towel and become a VERY VOCAL boycotter of your products. Shame on all of you.

  • pizzapaarty
    1 posts

    Hello everyone,

    I have a problem with a quest for "a brewing storm". My quest tells me to go to rest, and I am supposed to be awakened by Dag who provokes me into a duel. Now in my game, Eivor is resting and nothing happens. It is when I search in the village that I see Dag fighting with villagers. It starts a duel with him, but this one is infinite (I beat him on a loop) and nothing happens.

    I tried several solutions: dying during the fight, beating him several times (a dozen times), i tried fast travel and i came back, but it didn't change anything, i resumed an old backup with a previous quest but it didn't change anything. I uninstalled and reinstalled the game, I checked the files, I tried to change the graphics of the game. But nothing worked, the cinematics do not want to start and so I can not continue the main quest of the game.

    And as a result of that, I looked on forums, and I saw that some people were saying that you had to do the In Dreams quest before and that it helped to unlock the cinematic. But I don't have that quest. I built Valka's house well but I can't talk to him or anything, I don't have a quest about it either in my quest list, what to do?...

    I contacted Ubisoft support, sent my backup etc but for now the problem persists..


  • SofaJockey
    167 posts

    @meatball22 Which bug is this one?
    I've finished the game (for now) and It doesn't sound like one I bumped into. 🙄

  • Niy4h12
    4 posts

    @ubi-swaggins Imagine this was a month ago and you guys still haven't fixed this quest!!!!!! Wow!!!!

  • guest-F6Xk1t6S
    1 posts

    This is still a bug. Happened to me yesterday. I cant progress. I out in a support ticket hoping for a resolution. If it cant be fixed I'll want a refund also.

  • ashwii
    3 posts

    Glitch in A Brewing Storm where you cannot progress after killing Dag.

    Some forums who have the same issue have said it's because they haven't done the Valka quests and gone to Asgard.

  • CVonSkeletor
    1 posts

    I complete the brewing storm quest, give Dag Valhalla, then the quest completes. After it completes, I cannot access the alliance map and see no way to continue the story.

Suggested topics

Community details

19
Online
123.9k
Users
21.3k
Topics
109.9k
Posts