Welcome to discussions

Quick Suggestions

  • fafner1010
    53 posts

    hey @Ubi-Borealis

    We all realize that you are just player support agents and you are doing your job well.

    However, this cannot hide the fact that Ubi is indeed ignoring our group of players. All you can do is to represent us to express our anger and appeal to the internal team.

    To be honest, if it still doesn't work, it's either we deserve to die or you didn't fulfill our responsibility.

    I don’t blame you, but at present it seems that it’s useless for you to communicate the same thing internally.

    How should we examine whether you really express our demands? ? ? ? ? ? ? ? ? ? ? ?

  • Sessi10
    2 posts

    Dear Ubisoft team this is the best Assassin creed game franchise .Kindly please solve the issues especially the one i mentioned.

  • berkblode
    2 posts

    @dastanbq1999 Call your local support line and explain the situation. They ask you to follow a few solutions first and if the problem persists, they take refunds.

  • atilola
    4 posts

    @alphagoose46219

    Hey dude congrats on getting it to work - on your replay through, did you do the Asgard/jotenheim quests before Cent storyline?

    I just restarted myself - being underleveled sucks

    Thanks in advance!

  • AlphaGoose46219
    155 posts

    @atilola No, did them after.
    Did Asgard/Jotumheim just before i freed Sigurd.

  • Jhaan123
    15 posts

    I noticed something new that I haven't seen mentioned here yet. Whenever I enter the longhouse to complete "Report on Cent" and get the "A Brewing Storm" quest, some quests I haven't completed in Ravensthorpe disappear from my quest log:

    "A Brief History of the Hidden Ones" disappears
    "A Baker's Plaint" disappears

    I thought it could be that players are getting this Brewing Storm bug b/c the quest "A Brewing Storm" is overriding these other incomplete Ravensthorpe quests and messing up the game code...but then I completed both the above quests and tried again, and I STILL got the Brewing Storm bug.

    I think a hotfix for this is needed right away, and the quickest and simplest solution is to give players the ability to skip "A Brewing Storm". The code for it is clearly buggy and triggers conditions other quests in this game don't normally trigger (like forcing the player to rest, for example). It ends up doing really screwy things to the Ravensthorpe area and causes a gamebreaking bug that prevents players from advancing the story.

    If Ubisoft is concerned about how the quest's choice influences the ending, then here's a suggestion for a hotfix. After you return to Randvi and "Reporting on Cent" finishes, have a pop-up menu appear that says:

    Dag's growing distrust of you is becoming a problem. How do you want to solve the issue?

    Banish him, take his axe (Skip Quest, Deny him Valhalla)
    Banish and wish him well (Skip Quest, Let's Dag get to Valhalla)
    Wait until nightfall to speak to him (Attempt to do "A Brewing Storm")

  • PCOF69
    1 posts

    @jhaan123 Hi guys. I tried something diferent and it didnt solve the problem too. I still have my ps4 pro. I installed the game and used my ps5 saved games with it. After going to the bed appears another quest and everything continues the same.

  • Doner07
    31 posts

    @pcof69 nothing will work. The bug is also on PC and Xbox so dont expect diffrent results by changing platform you play on

  • Doner07
    31 posts

    It's not a problem with console, hardware or anything. Its not a problem with graphics settings on PC, resolution etc. as someone else notice i also notice that quest A brief history of the Hidden Ones disappears but it's not for a first time. I think that this quest also disappears to me somewhere near "Taken for Granted" quest which btw also disappears from completed quest after reloading save but there is another topic on this forum about that so nvm. Some [censored] is going on with this game. Bugged to the core so i only hope they will solve somehow all problem with quests but considering how many problems there are (You can check it on topic with Known Issues) i doubt it. BTW they gave us recently a fix for Jomsvikings. Now we will not only see them from the same player over and over but finally also from others. Great, thats what we really really needed. Thank You Ubisoft. Who cares about fixing REAL problems with your game, right?

  • Rowannicus
    8 posts

    SAME ISSUE (PC)

    Unable to progress in A brewing storm

    During Reporting on Cent got the cutscene where Dag confronts Eivor in the Longhouse
    Then another with Randvi after which the objective changes to “Rest in your bed”

    After selecting the action to go to sleep the screen fades to black with a small icon in the corner (exactly as per the video posted in the comments above)

    After waking there is obviously a rainstorm but no sign of Dag ...

    [From videos online it seems Eivor is meant to be woken by Dag yelling his name and challenging her to a duel to the death]

    If I go looking for him he can be found by the three statues of the Norse gods near the burial grounds, and although he shows as hostile he doesn’t attack or defend himself.

    I’ve tried loading manual and auto saves from various points prior to Reporting on Cent and replaying entire sequences prior to A Bloody Welcome but the glitch occurs at the same point.

    The game is totally stuck and this is really, really ticking me off.

    Is there a debug console command or something to force the game sequence to progress?

  • Tony-Mahony-
    16 posts

    So, completed the raids and all other bits it can. Maxed out my gear level so I've got really nothing left I can do in this game.

    It feels wrong as I've had some fun along with the incredible frustration this bug is causing. But I can return to amazon for a refund. I'd guess by the time this gets fixed the game will be considerably cheaper to buy again.

  • Wolverine0471
    1 posts

    Has anyone gotten this to work yet? I am on PS4 and essentially stuck. I have tried all kinds of things to get this to work and nothing. For me I wake up with the stotm happening. Everyone in the town is just standing in one place facing the same direction like some weird horror movie. Dag is nowhere to be found and there is no quest icon on the map. I opened a ticket with Ubi and all they said is to keep checking the forum for updates. $60 for a broken game. Wow

  • boris65
    1 posts

    So I am having the same issue as everyone else...I go to sleep...no cut scene...no Dag calling for me to fight...etc.

    I'm only posting this as I am sure Ubi will do what they can to compensate us for our troubles.

  • B.Flknr92
    5 posts

    When I wake up dag isn't wanting to fight or anything no dialogue at all. But I find him sitting by the grave in the forest at ravensthorpe..

  • B.Flknr92
    5 posts

    I am playing on a ps4. I have started the 2nd quest with valka but having issue with brew I'll no storm. When I wake up dag isn't yelling to fight I eventually find him just sitting by the late tattoo artists grave in ravensthorpe and I cant interact with him or anyone else

  • fafner1010
    53 posts

    After four months, there is no update or temporary solution. Either they are useless or they have no sincerity and determination to solve the problem!

  • Doner07
    31 posts

    The update is already in PS5 database. It will come next week to all players on all the platforms so let's hope they also fix this bug but we will see. Definitely there will be new content because game size increase by 8gb or so. Probably they add new river rides locations so i only hope they not only add new content and leave all glitches as they are

  • Rowannicus
    8 posts



    Is it possible to get a script or a console command to force progression?

    A while back there was a similar issue with Fallout 4 where a side quest hinged on dialogue with an NPC who wasn't where she was meant to be - the workaround was (and afaik still is) to use a debug console command to teleport the NPC to the player location and if that didn't work there was another command to force the quest to progress to the next stage.

    Considering that this bug is affecting so many players and has been unresolved for over four months now maybe we could get a script to force progression as an interim workaround pending a proper bug fix?

  • guest-yYQboZDd
    1 posts

    I have the brewing storm glitch problem right now. I even attempted to load a previous saved point and come back and I still had it. How can I fix this?

  • B_Waggy
    1 posts

    Why the hell has this not been patched?

    55 hours into the game and it's grinded to a halt.

    What the hell am I supposed to do? Is the amount of people here complaining about the same thing not enough for them to release a patch?

    Waited for this game and I was so excited for ages, not been able to move from my console since I got it and now all that excitement is done.

    What do I need to do as I've tried reloads left right and center and always end up in the same situation as everyone else where dag just doesn't turn up and there is nothing else I can do..

Suggested Topics

Community Details

32
Online
130.7k
Users
22.6k
Topics
117.6k
Posts