Welcome to discussions

Quick Suggestions

  • Doner07
    31 posts

    It's not a problem with console, hardware or anything. Its not a problem with graphics settings on PC, resolution etc. as someone else notice i also notice that quest A brief history of the Hidden Ones disappears but it's not for a first time. I think that this quest also disappears to me somewhere near "Taken for Granted" quest which btw also disappears from completed quest after reloading save but there is another topic on this forum about that so nvm. Some [censored] is going on with this game. Bugged to the core so i only hope they will solve somehow all problem with quests but considering how many problems there are (You can check it on topic with Known Issues) i doubt it. BTW they gave us recently a fix for Jomsvikings. Now we will not only see them from the same player over and over but finally also from others. Great, thats what we really really needed. Thank You Ubisoft. Who cares about fixing REAL problems with your game, right?

  • Rowannicus
    8 posts

    SAME ISSUE (PC)

    Unable to progress in A brewing storm

    During Reporting on Cent got the cutscene where Dag confronts Eivor in the Longhouse
    Then another with Randvi after which the objective changes to “Rest in your bed”

    After selecting the action to go to sleep the screen fades to black with a small icon in the corner (exactly as per the video posted in the comments above)

    After waking there is obviously a rainstorm but no sign of Dag ...

    [From videos online it seems Eivor is meant to be woken by Dag yelling his name and challenging her to a duel to the death]

    If I go looking for him he can be found by the three statues of the Norse gods near the burial grounds, and although he shows as hostile he doesn’t attack or defend himself.

    I’ve tried loading manual and auto saves from various points prior to Reporting on Cent and replaying entire sequences prior to A Bloody Welcome but the glitch occurs at the same point.

    The game is totally stuck and this is really, really ticking me off.

    Is there a debug console command or something to force the game sequence to progress?

  • Tony-Mahony-
    16 posts

    So, completed the raids and all other bits it can. Maxed out my gear level so I've got really nothing left I can do in this game.

    It feels wrong as I've had some fun along with the incredible frustration this bug is causing. But I can return to amazon for a refund. I'd guess by the time this gets fixed the game will be considerably cheaper to buy again.

  • Wolverine0471
    1 posts

    Has anyone gotten this to work yet? I am on PS4 and essentially stuck. I have tried all kinds of things to get this to work and nothing. For me I wake up with the stotm happening. Everyone in the town is just standing in one place facing the same direction like some weird horror movie. Dag is nowhere to be found and there is no quest icon on the map. I opened a ticket with Ubi and all they said is to keep checking the forum for updates. $60 for a broken game. Wow

  • boris65
    1 posts

    So I am having the same issue as everyone else...I go to sleep...no cut scene...no Dag calling for me to fight...etc.

    I'm only posting this as I am sure Ubi will do what they can to compensate us for our troubles.

  • B.Flknr92
    5 posts

    When I wake up dag isn't wanting to fight or anything no dialogue at all. But I find him sitting by the grave in the forest at ravensthorpe..

  • B.Flknr92
    5 posts

    I am playing on a ps4. I have started the 2nd quest with valka but having issue with brew I'll no storm. When I wake up dag isn't yelling to fight I eventually find him just sitting by the late tattoo artists grave in ravensthorpe and I cant interact with him or anyone else

  • fafner1010
    53 posts

    After four months, there is no update or temporary solution. Either they are useless or they have no sincerity and determination to solve the problem!

  • Doner07
    31 posts

    The update is already in PS5 database. It will come next week to all players on all the platforms so let's hope they also fix this bug but we will see. Definitely there will be new content because game size increase by 8gb or so. Probably they add new river rides locations so i only hope they not only add new content and leave all glitches as they are

  • Rowannicus
    8 posts



    Is it possible to get a script or a console command to force progression?

    A while back there was a similar issue with Fallout 4 where a side quest hinged on dialogue with an NPC who wasn't where she was meant to be - the workaround was (and afaik still is) to use a debug console command to teleport the NPC to the player location and if that didn't work there was another command to force the quest to progress to the next stage.

    Considering that this bug is affecting so many players and has been unresolved for over four months now maybe we could get a script to force progression as an interim workaround pending a proper bug fix?

  • guest-yYQboZDd
    1 posts

    I have the brewing storm glitch problem right now. I even attempted to load a previous saved point and come back and I still had it. How can I fix this?

  • B_Waggy
    1 posts

    Why the hell has this not been patched?

    55 hours into the game and it's grinded to a halt.

    What the hell am I supposed to do? Is the amount of people here complaining about the same thing not enough for them to release a patch?

    Waited for this game and I was so excited for ages, not been able to move from my console since I got it and now all that excitement is done.

    What do I need to do as I've tried reloads left right and center and always end up in the same situation as everyone else where dag just doesn't turn up and there is nothing else I can do..

  • tempete0390
    53 posts

    So, it's March 13th and, apparently, this is STILL HAPPENING???? I just got to this part of the game. Eivor is woke up and NOTHING. I have already completed the first part of Asgard with Valka way before this. I'm on PS4. What the [censored]? This is absolute [censored]. I have had SO MANY bugs and breaks with this game that I've lost count. It happens every time I play. I can't believe that I gave you my money for a steelbook and THIS is what I get for it. When the hell is it getting fixed?! And, no, going way back or starting all over are not fixes. I refuse to do either of those things. I can't believe this is in an AC game.

  • tempete0390
    53 posts

    @ubi-borealis [censored] it. I'll just play RDR2 or Witcher again. I'm over this. I've bought and played every AC game since the start and I have never been so [censored] and felt so taken advantage of. This level of incompetence is undeserving of my money. Too bad. AC used to be my favorite game franchise.

  • Minden1759
    4 posts

    @guest-yyqbozdd same for me cant progress game ubisoft unbelievable tried everything fed up want money back

  • allysonjb
    1 posts

    Having read the comments, this is a problem that has been known for MONTHS and nothing has been done to fix it.
    This game is broken, I now face the only option of restarting after many hours of gameplay, unsure whether ai will end up with the same game breaking bug a second time.
    After spending almost £60 on this game I would expect it to [censored] well work.

  • DMedlock22
    1 posts

    Just adding my name to this.... I go to sleep and the Dag cut-scene never starts. I've tried everything.

    It took me an hour to read this entire thread... even more time I can't get back I guess!

    It's long overdue to fix this Ubisoft. Love your games. I've beaten all of the Assassin Creed's games. Even saw that terrible movie. A game-breaking bug needs to be your #1 priority.

  • atilola
    4 posts

    Hi All, I hope you're all as well as can be.

    I'd like to also add that I've also been fortunate enough to complete this mission and progress as expected after starting a new game. For what it's worth, I'm playing on PC.

    So for me personally it's been: 139 hours
    -80 hours first time through and then hitting the bug
    -6 hours recapping to before cent to complete the Valka/Asgard/jotenhiem quests, then Cent, then hitting bug
    -20hours (after going back to a save file of 58hours) catching back up, as well as 100% asgard & Jotenheim, completing pledge areas (not winchester) before Cent storyline, then hitting bug
    -33hours Starting a new game - mostly doing story, with some extra bits to get better gear etc (detailed below) to then have the cutscene play as expected, fight Dag, and complete 'A Brewing Storm'

    Also some bits below on restarted playthrough which may or may not be relevant, feel free to ignore:

    I didn't do any of the Valka Asgard/Jotenheim quests.
    I didn't do any of the settlement quests (i.e. Petra's hunting quest, the kids with the wolf, sweet bakery ete, none of them, other than what was mandatory like the forge).So much to the point where I thought I hit another bug at one point because I couldn't progress beyond Grantsbridge/Ledecester story arcs - then realised this was because I hadn't said hello to the Opal Trader when he arrives to trigger progression of the main story (lol).
    I didn't build Octavius's house until after I completed 'A Brewing Storm' - That may or may not be relevant.
    I didn't do Vinland, winchester or Snottingham before I did the Cent story line.
    I killed all possible members of the order (including all Zealots) that you can kill before doing the Cent story arc (Note I hadn't done the Snottinghamshire, or Winchester arcs yet/their targets - Don't know if there are any - I haven't gotten this far in the story before).
    I had the complete Hidden One's Armour equipped, all upgraded with Tungten Ingots, my main hand weapon was a Tungsten upgraded Blacksmith Hammer, with the Briton Shield (tungsten) as the secondary weapon. I had the bow that gives health on hitting weak spots equipped (Tungsten)
    I had upgraded Raventsthorpe to level 5 - Village
    I hadn't initiated any romance quests (Randvi or Petra)
    I was initially playing as a Male character until just prior to starting the Kingmaker/Ledecester arc - then switched it to 'Let the animus decide'
    I had defeated the Drengirs: Erik loyalskull, Thor fish dude & Orwig Neverdeath before starting the Cent story arc.


    TLDR: Encountered bug multiple times. Started a new game from scratch, didn't encounter bug and was able to complete mission and progress story. A lot of time was spent.

  • Kenny_truong
    2 posts

    I experienced the same issue here on PS4, Dag just stands near the 3 tall rocks and does not fight at all. The whole village is broken. I can't interact with any of them. No fast travel, no raid, and no side quest available. I don't expect to see such a huge break game bug in a triple-A game like this. Someone here recommended reloading back before Cent quest. That will erase around 30h playing from my game. And it does not guarantee to work.

    I tried to upgrade the village to level 5 and finished Jotunheim and Asgard but it doesn't work on this bug. Save your time, just wait around 2 months for the update. Hope Ubisoft put the patch on this bug.

    They bundle this game with immortal Fenyx Rising. That means more people will join the thread.




  • Manlius1007
    1 posts

    Same problem here (PC)... just adding another disappointed player's name to the list...
    It's ridiculous how low the quality of AC series has fallen.
    Did they REALLY tested the product before releasing it, considering how blocking the bug is?
    I'm doubting it, just as I'm doubting the professionalism of a group that has known the issue for four months and has not yet solved it.

Suggested Topics

Community Details

21
Online
130.7k
Users
22.6k
Topics
117.6k
Posts