Welcome to discussions

Quick Suggestions

  • allysonjb
    1 posts

    Having read the comments, this is a problem that has been known for MONTHS and nothing has been done to fix it.
    This game is broken, I now face the only option of restarting after many hours of gameplay, unsure whether ai will end up with the same game breaking bug a second time.
    After spending almost £60 on this game I would expect it to [censored] well work.

  • DMedlock22
    1 posts

    Just adding my name to this.... I go to sleep and the Dag cut-scene never starts. I've tried everything.

    It took me an hour to read this entire thread... even more time I can't get back I guess!

    It's long overdue to fix this Ubisoft. Love your games. I've beaten all of the Assassin Creed's games. Even saw that terrible movie. A game-breaking bug needs to be your #1 priority.

  • atilola
    4 posts

    Hi All, I hope you're all as well as can be.

    I'd like to also add that I've also been fortunate enough to complete this mission and progress as expected after starting a new game. For what it's worth, I'm playing on PC.

    So for me personally it's been: 139 hours
    -80 hours first time through and then hitting the bug
    -6 hours recapping to before cent to complete the Valka/Asgard/jotenhiem quests, then Cent, then hitting bug
    -20hours (after going back to a save file of 58hours) catching back up, as well as 100% asgard & Jotenheim, completing pledge areas (not winchester) before Cent storyline, then hitting bug
    -33hours Starting a new game - mostly doing story, with some extra bits to get better gear etc (detailed below) to then have the cutscene play as expected, fight Dag, and complete 'A Brewing Storm'

    Also some bits below on restarted playthrough which may or may not be relevant, feel free to ignore:

    I didn't do any of the Valka Asgard/Jotenheim quests.
    I didn't do any of the settlement quests (i.e. Petra's hunting quest, the kids with the wolf, sweet bakery ete, none of them, other than what was mandatory like the forge).So much to the point where I thought I hit another bug at one point because I couldn't progress beyond Grantsbridge/Ledecester story arcs - then realised this was because I hadn't said hello to the Opal Trader when he arrives to trigger progression of the main story (lol).
    I didn't build Octavius's house until after I completed 'A Brewing Storm' - That may or may not be relevant.
    I didn't do Vinland, winchester or Snottingham before I did the Cent story line.
    I killed all possible members of the order (including all Zealots) that you can kill before doing the Cent story arc (Note I hadn't done the Snottinghamshire, or Winchester arcs yet/their targets - Don't know if there are any - I haven't gotten this far in the story before).
    I had the complete Hidden One's Armour equipped, all upgraded with Tungten Ingots, my main hand weapon was a Tungsten upgraded Blacksmith Hammer, with the Briton Shield (tungsten) as the secondary weapon. I had the bow that gives health on hitting weak spots equipped (Tungsten)
    I had upgraded Raventsthorpe to level 5 - Village
    I hadn't initiated any romance quests (Randvi or Petra)
    I was initially playing as a Male character until just prior to starting the Kingmaker/Ledecester arc - then switched it to 'Let the animus decide'
    I had defeated the Drengirs: Erik loyalskull, Thor fish dude & Orwig Neverdeath before starting the Cent story arc.


    TLDR: Encountered bug multiple times. Started a new game from scratch, didn't encounter bug and was able to complete mission and progress story. A lot of time was spent.

  • Kenny_truong
    2 posts

    I experienced the same issue here on PS4, Dag just stands near the 3 tall rocks and does not fight at all. The whole village is broken. I can't interact with any of them. No fast travel, no raid, and no side quest available. I don't expect to see such a huge break game bug in a triple-A game like this. Someone here recommended reloading back before Cent quest. That will erase around 30h playing from my game. And it does not guarantee to work.

    I tried to upgrade the village to level 5 and finished Jotunheim and Asgard but it doesn't work on this bug. Save your time, just wait around 2 months for the update. Hope Ubisoft put the patch on this bug.

    They bundle this game with immortal Fenyx Rising. That means more people will join the thread.




  • Manlius1007
    1 posts

    Same problem here (PC)... just adding another disappointed player's name to the list...
    It's ridiculous how low the quality of AC series has fallen.
    Did they REALLY tested the product before releasing it, considering how blocking the bug is?
    I'm doubting it, just as I'm doubting the professionalism of a group that has known the issue for four months and has not yet solved it.

  • sowerofhate
    4 posts

    Logged in only to add another name on the list. Cyberpunk was bugged af, but at least I was able to finish it.
    And I have an idea - send this thread to Eurogamer, Polygon or whatever big name, maybe they will make it a big thing. Right before dlc release. Hit where it hurts the most.

  • HzRules
    3 posts

    Guy let's make a #BrewingstormBug and all post a tweet with the description for more share of it .they will be forced to answer fast !!it's a shame that only cyberpunk was aimed for bugs in articles , this bug is worst than all bugs in other bugged games!!

  • HzRules
    3 posts

    @hzrules mention also @assassinscreed in the tweet!

  • evaneon33
    3 posts

    I add my name to this. Ubisoft you [censored] up, half a year has passed. Fix the game! PS4

  • Ubi-Orion
    Ubisoft Support Staff 148 posts
    Hello all!

    I'd like to reach out to you with an update from the investigation. The development team hopes to resolve this issue in a future update. This means that we will no longer need any additional save files or videos. Thank you to everyone who took the time to submit these for investigation.

    Currently, we are unable to provide a definite time-frame for this update. Once we have more information to share with you all regarding its release, we will share it within this thread and within the News & Announcements forum.

    I would also like to take the time to remind you all that the agents you see working within the Player Support forum, such as myself and @Ubi-Woofer, are player support agents. We are not members of the development team. As part of our role as player support agents, we collect the reports made by our players within the forums and pass these along to the development team to be used in the investigation. We also provide updates, when available, about the investigation status, or if any additional information is needed by the development team. The development team themselves do not post within the forums.


    Hey there folks.

    Thanks for your additional reports regarding this issue. As confirmed by Ubi-Borealis in an earlier post a few days ago this issue is planned to be fixed with an upcoming update to the game. As soon as we have a definitive confirmation of a date for this update we'll share this to our forums and social media channels. In the meantime we do apologise for any inconvenience caused as a result of this.

    Official Response
  • Newbie_neil91
    6 posts

    This is ridiculous. I want this game deleted and my money back. Just wasted 67 hours on this 69 now after trying for hours to fix it.

    Can't believe there is no resolution for this.

    I will be boycotting Unisoft from now on.

    The game was so full of glitches anyway it is ridiculous!

    I have emailed about this issue so please get back to me.

    What a shame.

  • GraylySquirrel
    2 posts

    Adding my name to the list.

    Nothing fixes this. I tried re-loading a save before I had pledged Cent. Spent 4 hours today re-doing the Cent storyline. Bug was still there. Not cutscene. Dag did not appear. Still bugged out hanging around by the rocks.

    Submitted a ticket (for all the good that will do), but this is ridiculous. And the salt on the wound is them announcing a paid DLC in the next few weeks, but can't fix a game-breaking bug they have known about for months.

    I have 58 hours in my main save. I'm not re-starting. I'll be refunding. And if that doesn't work I'll do a chargeback. This is a defective product.

  • Newbie_neil91
    6 posts

    @rentothea they don't have a clue, I think they mean look at our FAQs which don't even mention this issue.

    They are stalling so they don't have to refund us. Which they really need to do.

  • Newbie_neil91
    6 posts

    @graylysquirrel how do we start a refund?
    I'm looking to do so on ps5

  • Newbie_neil91
    6 posts



    I suppose they blocked this post, but follow it if you can and retweet @assassinscreed #BrewingstormBug #wewantRefunded

  • royhobs92
    1 posts

    Add another one. Really aggravating. Come on guys.

  • SadFatClown
    1 posts

    +1 to this - have tried everything, just stuck with black screen and no cut scene. Not going to play further until there is a fix, or will just get a refund (live in Australia, and our consumer protection laws are awesome).

  • enarc
    1 posts

    Got this bug yesterday. Fortunately, I have "A brewing storm" completed by today.
    I was lucky and had an autosave right before "Report to Randvi" after the Cent questline. I gave it a shot 2 times. On the very first load of this save, the same bug appeared. On the second load, I had the cutscene end fight with the Dag. The quest worked with the same preconditions as when the bug appeared (the only difference I had a short break in the game and reported to Randvi when it was night).

    So I assume you don't need to start the game from scratch to beat this annoying bug 🙂

    I hope it will save some time for you.

  • tempete0390
    53 posts

    @enarc Farthest I can go back is taking Rouecistre Fortress so I'll try what you did with a quick save before talk to Randvi. I'm not going near Canterbury until I have a quick save first. I really don't expect any results but maybe??? /s

  • tempete0390
    53 posts

    Hadrian's Priory not Canterbury. Brain no work good from game rage.

Suggested Topics

Community Details

17
Online
131.1k
Users
22.7k
Topics
118.1k
Posts