Welcome to discussions

Quick Suggestions

  • Tony-Mahony-
    16 posts

    I restarted, and like others just did the main quests and got it to work.

    I did get the homestead to lvl3 but no quests out of England. I only detoured to pick up the full magisters set and suttangers claw/yngling seax combo.

  • Renz832017
    6 posts

    Tony-Mahony are you on Ps4 or PC or Xbox?

  • guest-fAwMAEuw
    1 posts

    Does anyone know when will a brewing storm will be fix? I been waiting Since last year to be fix and nothing has happened

  • Doner07
    31 posts

    @renz832017 Platform does NOT matter

  • Tony-Mahony-
    16 posts

    @renz832017 PS5, but I don't think the platform matters.

    It took about 18 hours.

  • tempete0390
    53 posts

    @minden1759 It's not Sony's fault. There are people here across the entire spectrum. DL game, disc game on every single generation of every single platform capable of running Valhalla. This is 1,00,000,000% Ubisoft's fault, their fault alone, and their massive problem to fix. They've chosen to ignore us and send a generic copy/pasted response to all of us that opened a ticket.

    All you can do is create a manual save and start a new game. One of the worst parts about starting over is that [censored] skill tree. I already hated that skill tree in my first play attempt. I was letting fate decide everything since I had all adrenaline slots and my Eivor was op af. Now, I have to pick and choose the goddamned skills every 3.9 seconds when 2 MORE skill points come through. I really miss Kassandra and Greece. [censored] Valhalla.

  • stoney1985james
    10 posts

    Sorry guys I'm New Here and got sent by customer support to this page wondering if there's been any fixes to a Brewing storm Assassin's Creed thank you for your time

  • guest-tM0tGZPY
    1 posts

    I had the same bug in a brewing storm on my first run 70hours in. (PS4)

    I restarted the game from the beginning and now just got it to work - completed the A brewing storm mission.

    things i did differently on the second run.

    I did ONLY the main quest, and in order of the suggested levels - Grantbridge, ledescestre, east anglia, oxford, london, sciropscire, then Cent. I thought maybe I go along with the games designed flow it would work

    I got to settlement level 3, and helped valka with her box, but did not do any further missions with her. In the first run i completed asgard, and went ahead to get the jotenheim (suggested lv 180?) potion before valka qued me.

    I built the hunters house - (?could this be the bug?). In the first run i haven't built when i started a brewing storm. the Dag fight happens outside the longhouse with the hunters hut as part of the background - maybe the game crashed on that?

    I haven't triggered any of the romance quests.

    I didn't venture into areas the main story hasn't prompted.

    Hope this helps.

  • Rowannicus
    8 posts

    @sleinroux THANK YOU !!!

    Loaded your save game as per your instructions and for the first time ever the cutscene triggered, Eivor awakens to Dag yelling and I finally got to fight Dag.

    It feels a bit strange loading another player’s save as my favourite weapon (the Yngling Seax or however it’s spelled) isn’t in Eivor’s inventory but who cares because at long last I can finish this stupid stage and move onwards in the game.

    I am eternally grateful to you for being such an awesome team player.

    Thank you for helping out your fellow assassins.

    [Since so many of us have been affected for so long by this bug Ubisoft really should have given us a workaround like a script (which it would take a dev about five seconds to write) or a debug console command to trigger the stupid fight.]

  • Rowannicus
    8 posts

    @sleinroux merci infiniment 😀 grâce à vous c’est réglé. Génial.

  • Taiyototsuki
    1 posts

    I am on PS4 and have the same issue. The cutscene with Dag won't happen and I am stuck.

    The only thing that is strange in my safe file (aside from the bug itself) is that the castle I had to storm during the Cent arc (Rouecistre Fortress) seems not to be fully conquered after completing the Cent Quest Arc. By that I mean that when I reenter the fortress (which is only possible through the main gate) the sound of the shattering of the gate due to the ram can be heard and the fortress ist still full of enemies that attack me. Should it not be under my control like the other assaults that were completed in other regions arc?

    Perhaps the Cent Arc ist not registered as actually complete (even though it appeared on screen) and therefore the subsequent quests are bugged?

  • Doner07
    31 posts

    @taiyototsuki yeah, i checked and the same thing is on my save so maybe it is connected somehow. Really intresting

  • thanatoarms1217
    5 posts


    Wow. Good find. I'll check on my save files as well

  • stoney1985james
    10 posts

    @niy4h12 4 months on and still no fix even with a new update

  • stoney1985james
    10 posts

    Is there a fix to this yet guy's or are we still waiting thanks

  • MarcinG_89
    4 posts

    @stoney1985james Still no fix mate. So sad...

  • stoney1985james
    10 posts

    @fraggass yh your so right is in the news it's in the Washington times and it's all over Google that yet for some reason unisoft unaware of this problem how comical after 5-months of the game being available you still have this problem but they're ok taking your money for a season pass and because of that we will make sure your ok by doin a update that doesn't fix a problem from 5 months ago looks like there a cyberpunk problem going on😂🤣 I have to laugh as I'll only get mad for paying £60 for a game I can only play half off

  • Nawafalgh13
    2 posts

    @justus1302 i have the same problem I really want to finish the game😩

  • Christmas33
    2 posts

    @sleinroux Thank you very much.
    It feels a bit strange loading another player’s save.
    I am grateful to you for being such an awesome team player.
    Best Regards

  • H.SoloShotFirst
    10 posts

    @taiyototsuki in my safe file the Rouecistre Fortress is fully cleared and i don't have any suspiscious sounds around this place. Maybe there is a connection, so it is still worth mentioning. Im on PC, so maybe this is why.

Suggested Topics

Community Details