Welcome to discussions

Quick Suggestions

  • Nawafalgh13
    2 posts

    @justus1302 i have the same problem I really want to finish the game😩

  • Christmas33
    2 posts

    @sleinroux Thank you very much.
    It feels a bit strange loading another player’s save.
    I am grateful to you for being such an awesome team player.
    Best Regards

  • H.SoloShotFirst
    10 posts

    @taiyototsuki in my safe file the Rouecistre Fortress is fully cleared and i don't have any suspiscious sounds around this place. Maybe there is a connection, so it is still worth mentioning. Im on PC, so maybe this is why.

  • H.SoloShotFirst
    10 posts

    Ubi is doing a patch every month, so the next hope to fix that bug is probably about middle of the april, hopefully it will be the end of this problem.

  • Josippo78
    2 posts

    FOR GODS SAKE UBISOFT.
    You are obviously not able to fix this bug, just gives us the quest achievement BEFORE going to bed and let us continue the game. Your team is not capable to make a fix quickly, so take the fight out of the game and let us play the game and put it back in when its fixed.

  • fafner1010
    53 posts

    @josippo78 ABSOLUTELY RIGHT!

    USELESS TEAM. UBISOFT SUCK !


  • skyhawg
    10 posts

    So I have been reading that they have disabled parts of the Ostara event because it is causing crashes. I'll tell you what, I would trade crashing for not being able to progress in the game because of a bugged quest.

    So what are they doing about it??? Well after only a couple of days they are going to hot patch the Ostara event to fix it.... I dont have any words that I can put here to describe what I think about that. No, lets not fix the game, but instead put more cats that I can trip over and hey, lets fix the party decorations too.... forget about the game breaking bug, we gotta have the village looking good....

    Perception is everything and Ubisoft is not doing very good right now. But you have a chance to partially redeem yourself..... include a fix, workaround, whatever for this bug, let us give Dag his axe, or not, and let us move on for Gods sake. Make this part of your hot patch this week, we have waited long enough and it is a serious enough issue it deserves its own hot patch, so at least include it during the one this week.

  • gmargarido
    1 posts

    Hello, guys. I'm from Brazil and I'll try to explain what, and how it, happened for me. (Sorry for now by my english).

    I'm using Xbox One. I had almost 100 hours on my save when I got the bug. For that, I'll try to list some information of my context to help each other a find a way with your older saves.

    My game situation:

    • Eivor is a woman.
    • I was coming back from Cent, with the Valka's herbs. In other words, Asgard 1st phase completed and Jotunheim and Asgard 2nd phase pending.
    • Ravensthorpe was at lvl 4.
    • I was at lvl 200, or something close to that.
    • I killed a lot of devotees.
    • I killed just the weakest Lerion's daughter, Goneril.
    • I did the Dandelion Puff mission and the fox was in Ravensthorpe when I came back from Cent. In some attempts to avoid the bug, I saw the fox glitching in the Valka's hut or Randvi office.
    • I noted that after talk with Geadric, in the end of battle, the Rouecister Fortress turn into a Saxon territory again. (And to top it off, the Nordics who were with me are murdered by the Cynebert Saxons)


    What I tried:

    • I tried to deliver the herbs to Valka before talk with Randvi - No difference.
    • I tried to deliver the herbs to Valka before attack the Rouecister Fortress - No difference.
    • I tried to conclude Asgard and Jotunheim before talk with Randvi - No difference.
    • I tried to conclude Asgard and Jotunheim before attack the Rouecister Fortress - No difference.
    • I tried to "clear" the Rouecister Fortress during, and after, the attack, but it's impossible 'cause Saxon guards appear everywhere during the battle. And after, not works - No difference.
    • I did some raids and tried update Ravensthorpe. I got the lvl 5 - No difference.


    Based on this, I have some assumptions:

    • The bug is on the answer that you give to Dag before start the Cent arch.
    • I guessed the fox very glitchy, then I agree with some posts ago that it can be the reason.
    • After the Dag's bug, other bugs are appearing on the game. Example: My battle with Fenrir had a lot of bugs, like to "fly" close the Yggdrasil or be killed by it with just one blow, even at level 220.


    I'm very disappointed with Ubisoft. It's very frustating you have the experience interrupted by a blocking bug with more than 4 months.

    It's a shame for a company release a game with this dimension with a bug like this and do nothing during 4 months. Why they don't give a patch to "skip" this mission as mentioned posts ago? It's possible to do that in many ways. But no, they don't care about Customer Success and our experience. Release a festival, or new items to sell inside the game, is more important than solve a blocking bug.

    Thanks for the posts, folks. If I find some way to avoid this bug, I come back to update you.
    Bye bye!

  • Rowannicus
    8 posts

    @h-soloshotfirst IF YOU’RE ON PC look for a post from @sleinroux sometime around March 19 - they found a workaround and posted a link to a detailed how-to.

    It’s involves backing up your own bugged save games and then downloading a working save that they kindly shared via Google Drive, then editing a string in the downloaded save with an open source app to make it work with your Eivor.

    Most importantly IT WORKS.

    [If you follow this method though you might need to edit your Internet Options and security settings in Windows to run downloaded exe files + you also need to first deactivate cloud saves in your UPlay settings otherwise your cloud backups will overwrite the un-bugged save]

    PS for those on console: IF you know how to connect your console to a PC so it displays like a HDD + you can access, edit and upload save games it would probably work for console too - but that’s a bit like jail breaking an iPhone and I suspect it voids the warranty so really isn’t the kind of thing one should be discussing here.

  • Rowannicus
    8 posts

    Hey Ubisoft

    Since some of us affected by this bug on PC have found a workaround by using someone else’s working savegame (after editing the user id encryption string in an Open Source app to associate it with our Eivor etc) maybe you could pass this information on the dev team help them isolate the problem?

    Maybe it has something to do with quest progression data stored in the save game becoming corrupt?

    That might explain why it affects players on all platforms.

    I have my 20 bugged save games backed up so maybe you could compare one of bugged saves to one of the un-bugged saves (the first one was shared via Google Drive by another player, then edited to work with my Eivor) and run a forensic analysis ?

  • H.SoloShotFirst
    10 posts

    @rowannicus thanks for suggesting, maybe it is weird but i am really attached to my save, because I like to clear every corner of the map 😛 I will wait another month for the fix, if it will not come then i will surely try his save to atleast be able to finish the game

  • SixFeetUnder828
    5 posts

    Once again, yet ANOTHER player here stuck with the "A Brewing Storm" game ENDING bug. I am playing on Xbox One.

    Let me get this straight... the new festival release was so bugged that they had to immediately hotfix it. Due to the settlement decoration quest (that I had already COMPLETED) being bugged, they took the settlement decorations out and removed the quest (which didn't affect my game at all).

    WHY CAN'T UBISOFT DO THAT WITH THE BREWING STORM QUEST?! I do not care about that quest.
    Until you get it fixed permanently, REMOVE THE QUEST! For people that have COMPLETED it, it shouldn't affect gameplay, and for the thousands of us who are getting ready to walk away from the game (and ubisoft), it will allow us to fully use the product we paid for (not be the defrauded consumer who was sold a product that was previously known to be faulty by the company).

  • Seanski2021
    2 posts

    I cant talk to hytham either or find dag Anywhere in my settlement, i dont know what to do and i have done so much. Please someone help i wont lose all the things i have and done

  • zpals
    11 posts

    Still glitched. ive tried everything mentioned here but im not willing to loose over 30 hours gameplay just to load a save point and have it happen again. Its a game finisher as theres no way to proceed. I was loving this game until now 😞

  • zpals
    11 posts

    @sixfeetunder828 yea we get a stupid festival but they cant fix a game breaking bug!

  • sowerofhate
    4 posts

    UBI - just admit it's not profitable for you to help us 🙄

  • TBURNAK
    2 posts

    Just happened to me today. Wake up and there's nothing. What a waste of time. It's too bad too because Odyssey was such a good game.

  • SHANEOC89
    1 posts

    when is this going to be fixed I am still having an issue with this, the game was out in November and still nothing this is terrible I have been playing for over 100 hours doing missions and side quests and I refuse to start the game from the beginning for a glitch that still hasn’t been fixed in over 3 months, I will be looking for a refund if this is not fixed,
    over €70 for a game that has issues that are not being fixed, updates haven’t done anything to help whatsoever fix the underlying issue before you create new ones

  • Orinaius
    4 posts

    https://www.washingtonpost.com/video-games/2021/03/16/ac-valhalla-bug/

    According to this article Ubisoft said "they are not able to reproduce the bug" this sounds like they aren't close to fixing and don't know how to, just let us skip at this point, you are hotfixing a temporary festival but not this gamebreak bug??

  • SixFeetUnder828
    5 posts

    @zpals
    I know, right? I got a reply from support today saying the standard "We are aware of this issue, and are currently investigating this. Any new information can be found on our support forums." I'm starting to get the feeling that they will acknowledge this problem, but aren't putting it high in the list of things to fix. After 5 months of countless players encountering this obvious, serious flaw, they've shown that fixing a texture issue of a cloak and adding a festival that was the answer to the question no one asked (and a aspect of the game that probably 2% of players will even bother to play), is MUCH higher on their to-do list. Fixing a game ENDING error encountered by, it looks like, half of the players? "Buy the season pass so you can get the new expansion coming out April 29th!".

Suggested Topics

Community Details

32
Online
130.7k
Users
22.6k
Topics
117.6k
Posts