Welcome to discussions

Quick Suggestions

  • ThankyouMoore
    1 posts

    I too have been stuck for months now with this bug. Haven’t posted before waiting for a resolve. But since it seems like it’s taking way to long. Figured maybe one more complaint wouldn’t hurt and least my issues would be noted with the rest of everyone. Seems a fix has been being worked on for a month with no update. Kind of sad you release a product that is faulty and then take this long to acknowledge a problem and to fix it.

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I apologise for the double post. I'm happy to share that the development team deployed a fix for "A Brewing Storm" in TU 1.3.1. This issue should now be resolved.

    If you are still unable to progress in "A Brewing Storm" after waking up, please don't hesitate to update this thread so we can investigate further. Please include a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
    • You are unable to progress in the fight with Dag.


    I'd recommend uploading your video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread. We can then forward this to the development team for further investigation.

    Thanks! 😊

    Official Response
  • VicDeMan
    2 posts

    I also have gotten stuck at "A Brewing Storm "
    Ive completed every area Ive been in except East Anglia, have a settlement level of 5, completed Vinland and Asgard, poet level of 287 and now the game wont progress any further after waking up. Dag is in the corner of the Village and nothing else happens in game. What do we do?

  • VicDeMan
    2 posts

    @boxyflounder161 same issue but when I find Dag on PS5 he is just standing in thr corner doing nothing

  • guest-pIT9sxPR
    1 posts

    Same bug here.. I hope they fix it in our lifetime!

  • guest-v10hHXHw
    1 posts

    Dear Team @Ubi,

    Please help us.

  • guest-8YNZMt9R
    1 posts

    I been stuck with this bug for a couple months now as well, and like others I'm just adding a post in hopes it can speed up the process. It's a bit unbelievable that it's taking this long, considering when I initially sent this issue over to customer support they said they were aware of it. I don't play many games but when I do, I like to finish them.

  • azullFR
    1040 posts

    Update Patch 1.2.1.0 is already on PS Database

    Of course Ubisoft Support Team is not allowed to talk about this...
    Ubisoft hierarchy, what are you doing, what is this this silence strategy ???

    Date : April 21 2021
    Source :





  • Xlucky57
    1 posts

    Same for me on Series x.
    UBISOFT Wake up !!!!!

  • azullFR
    1040 posts

    @xlucky57
    The patch will be avaible for all platforms at the same time in few days

  • Arrowfey
    2 posts

    I also have this problem on PC 9900k CPU, Nvidia RTX 2800, 32 GIG HyperX RAM.

    It happens even when I completely reload and do the Cent quests over-- it happens in a train, on a plane, in the dark, in a park-- it's driving me insane, Sam I am. Bad flyting, I know lol!

    It just sucks to pay this much for what you assume to be a quality game from one of the best companies out there, only to find that they've known about this issue (and many other game-breaking bugs...) FOREVER, and yet haven't fixed it. They just keep pumpin' out the ADD-ONs and other junk without paying attention to existing issues like this one.

    Btw I also can't find any kind of repair function to check the file integrity. Anyone know where I would find that tool for this game?

  • Arrowfey
    2 posts

    @azullfr says:
    "The patch will be avaible (sic) for all platforms at the same time in few days"

    Post a link to the source of your info, please? Thanks.

  • Doner07
    31 posts

    @arrowfey you dont need a source to know that. It was like that in all previous patches so its obvious that this time it will be the same.

  • Dragonkid13
    5 posts

    @arrowfey I agree we need a link. I won't believe this is actually being addressed until someone from Ubisoft officially acknowledges it.

  • azullFR
    1040 posts
    This post is deleted!
  • azullFR
    1040 posts

    @arrowfey
    @Dragonkid13
    Already sourced : with the date and the link .....
    2 post earlier before the one you quoted ....
    Few days meens between 2 or 7 days
    Please note that I never said this bug will be patched

    I just say : there is a new patch coming for Valhalla
    https://discussions.ubisoft.com/topic/88357/unable-to-progress-with-a-brewing-storm-after-waking-up-post-here/9?_=1619053626109

  • azullFR
    1040 posts

    @Arrowfey

    will be avaible (sic)


    *available. Thanks for giving me the correction... that's so kind 😜









  • DocHolliday182
    67 posts

    @azullfr The source is not an official source. Maybe it is leaked information, I don't know. @Ubi-Woofer Do you know something about Assassin's Creed: Valhalla Update 01.021.000? Specially if it fixes the Brewing Storm bug?

  • azullFR
    1040 posts
    This post is deleted!
  • VegasHeart
    39 posts

    @frustratedgamer Thanks for the humor man,really needed smthn like this in this thread sometimes 🙂

    @azullfr I also saw this tweet,then i found this post on reddit:

    Herculianus 1 month ago

    On the Ubisoft support megathread for this issue someone recently posted saying that there is an update scheduled in the coming week (they claimed it was “already in the PS5 database) that could possibly fix this problem.

    Original post link:https://www.reddit.com/r/ubisoft/comments/m0ce9a/a_brewing_storm_bug_any_fix/gqsv9a3/?utm_source=share&utm_medium=web2x&context=3

    That post was made,just before update 1.2.0 was released.Then in comments below ppl figure out its not.Seems same story repeats 🙂

    Link to that thread: https://www.reddit.com/r/ubisoft/comments/m0ce9a/a_brewing_storm_bug_any_fix/

    People just hoping that it will be fixed,so just add some prediction.

  • VegasHeart
    39 posts
    This post is deleted!

Suggested Topics

Community Details

69
Online
192.3k
Users
32.4k
Topics
162.1k
Posts