Welcome to discussions

Quick Suggestions

  • dereknorman4
    7 posts

    @csquared4 the other thread had so many comments they actually somewhat figured out the issue I believe. This issue seems to occurs if you did not do the valla quest before pledging to cent. So if u have a save before pledging to cent go to that then complete valka and redo cent. Which is quite unfortunate because for me and others we do not have a save before cent pledge

  • xReverendGreen
    16 posts

    @dereknorman4 I am in the same boat: over 65 hours in without a save before Cent, the Brewing Storm quest is bugged with no way to start the interaction with Dag, and I never did the Valka "In Dreams" quest.

    But here's the ironic thing about that: I couldn't ever do the Valka quest because I had a bug very early on that made it so the "In Dreams" quest never appears as available and Valka shows no dialogue prompts. So I'm literally screwed BOTH WAYS in terms of progressing in the story. I can *literally* only do mysteries, wealth, raids, etc. It's so frustrating.

  • noiseinmotion
    2 posts

    @justus1302 same thing for me on Xbox One

  • noiseinmotion
    2 posts

    Same for me on XboxOne with internet connection always open for automatic updates of the game

  • fiddz0r
    4 posts

    I'm just here to report the same issue for me. No cutscene, dag attacks villagers, I've tried going back to an earlier save (still pledged to cent) and I tried reloading outside the longhouse and sleep multiple times.

    I have not done the valka quest and I can't see the character that unlocks it

  • fiddz0r
    4 posts

    @ubikobold nope no crash for me, on PC, I tried reloading outside the longhouse and went to sleep. Apparantly there's supposed to be a cutscene when you sleep but it has never showed up

  • Csquared4
    5 posts

    @fiddz0r I am in the same boat. Have tried countless things to try to 'workaround' this but it all stems from the cutscene not playing when we wake up. It was also discovered in another thread with over 100+ people with the same issue, that it might be due to us not doing a quest for Valka when she came to the settlement, which explains why I can't talk to her or go to Asgard.

  • monaali791
    4 posts


    i am currently stuck in a brewing storm quest where no NPC is talking to me, [censored] is identified as enemy but not attacking. I am also stuck in reporting on Vinlad where i cannot speak with Randvi as i cannot speak to any NPC. I cannot also fast travel. I have updated the game and the bug is still there.

  • fiddz0r
    4 posts

    @csquared4 yeah I found that thread and added my voice to it. Kinda sucks being stuck and cannot progress, as the only solution for me seems to be to restart the game

  • alimigmig4400
    1 posts

    this is unacceptable i pay for this game and i cant finish it .for evry new game ubisoft do worse this is disappointing i love AC especially origin which i done it %100
    same problem here a brwing storm nothing happenswhen i wake up i cant do anything i see the ending in youtube the game i spend 2 weeks for it

  • guest-zBVz0ESF
    13 posts
    This post is deleted!
  • kaleokai19
    1 posts

    I get up to the fight against Dag, win it and after Evior speaks to the crowd around the game bugs out and crashes. It’s been like this for days. It’s like I’m stuck in a time loop

  • ashwii
    3 posts

    Glitch when you go to sleep in a bewwing storm where you are supposed to be awakened by Dag. This doesn't happen for me and I awaken to just the storm. I find Dag walking round and when I kill him nothing happens and he spawns back to life. I can't talk to anyone in the game after I initiate this quest.

  • Liberty_Kat
    2 posts

    Yes same problem here, can't progress, can't talk to anyone or progress game after Brewing Storm bug on PC. I reloaded the entire game, same problem!! How to fix this?

  • Liberty_Kat
    2 posts

    Same here (PC version). I did not complete the quest, now Dag appears outside, but you cannot interact with him nor anyone else and the game is completely broken. Changing to different quest doesn't help. I reloaded the entire game, doesn't fix it. Cannot play the game at all until this is fixed!.

  • MV212020
    3 posts

    @liberty_kat did a chat woth ubisoft and they fixed my gameplay!!!! ALL THEY HAD TO DO WAS DELETE 50+ HOURS OF MY GAMEPLAY AND LOADED A SAVE HOURS BEFORE THE CENT QUEST. I LOVE THIS GAME SO MUCH. Im [censored]

  • maxxsinner
    33 posts

    From everything I have read, this stems back to a glitch with the upgrading the seers hut in Ravensthorpe. Only way to fix it so far is to load an old saved game from around Level 3 in Ravensthorpe and try to get the seers quest to work. Obviously this means around 20hrs of lost game time and if you're like me saving over old saves, chances are you will be all but starting the game from scratch.

    Disappointed that quality games are a thing of the past. Companies like Ubisoft that charge top dollar for titles that have major flaws like constant game crashes, corrupt save game files and major quest bugs only keep getting away with it because we keep paying. Need to let them know that we expect better and the only way is to vote with our wallets.

    Can see why this wasn't sold on Steam. Would be refunds everywhere.

  • UbiKoality
    Community Manager 445 posts

    @ashwii Hey there! I'm sorry to hear that you're stuck in this quest in Assassin's Creed Valhalla. The team is looking further into this, but can you please make sure you've completed all our troubleshooting steps listed here? Rebuilding your database specifically would be great to try! This process acts like a computer disk defragmenter and will not affect your save data. If the problem persists, please upload your save files in a case at support.ubi.com! This would help to aid the team in their investigation of this issue.

    Official Response
  • charly_046
    3 posts

    This will be almost a month old, and the only reply is restart your game? please come up with the fix. you should be ashamed of the product you are puting out. its a pity I love the AC games, but this is a major turn off from buying new ones.

  • playequipment
    2 posts

    So, there are a bunch of people that have reported this as a game breaking bug - the cutscene does not play when you are asked to go to bed and then the game breaks where you are not given a quest line item to fight Dag - there is another thread with more than 100 replies. After this, I broke the game even further by heading to Jorvik, without pledging to the area - starting the quest and then running in to a bunch of issues when it was time to inspect inside the Abbey. I then went back to an earlier save, re-did all of the pledges except Cent and after doing Cent still ran into the same issue. Overall I've probably spent more than 60-80 hrs messing around trying to get things working without having to restart, my main save game after Cent is at 2.5days played.

    It has now been a month since this was reported and there is no solution other than to restart the game. If you do restart your game, don't bother doing any of the side stuff and just go through the story - make sure you talk to Valk before upgrading her hut as that will break her questline too and you wont be able to get to Asguard. This is a steaming pile of poo at the moment, a game paid for and installed that I really wanted to finish before Cyberpunk came out - however it doesn't look like that is going to happen as there seems to have been no word on a fix for this.

    Ubi, I am not going to restart this game after the time invested. Please provide an update!

Suggested Topics