Welcome to discussions

Quick Suggestions

  • xReverendGreen
    16 posts

    On base PS4, AC version 2.00. I don't recall if I received the request from Valka to pick up thistle, but I know I instead went on with the main story quest. I have finished the Cent storyline but when I try and do "A Brewing Storm" I wake up after falling asleep and there are no objectives or cutscene with Dag and Dag is just a generic hostile NPC. I can kill him but the quest does not update.

    I have also tried to go back to Valka to complete the In Dreams quest, with 10 thistle in my inventory, but there are no dialogue prompts above her head and the "In Dreams" quest doesn't even show in my available quests (nor does it show up as a completed quest).

  • BoxyFlounder161
    4 posts

    @marcabisaad The new patch 1.1.0 does not fix the glitch, I tried.

  • BoxyFlounder161
    4 posts

    In the new patch 1.1.0, it still acts the same and now have to wait for like another month for a new patch.

  • Kaputende
    1 posts

    Was hoping it would too, currently can't do any story line or use anything in my settlement, including upgrading gear at Gunnar's. Only thing I can do is settlement upgrades. Gonna be super [censored] if I have to restart, but looking more than likely.

  • H0mayun
    3 posts

    I had to restart the game all over again after playing 40 hours, and fortunately this time i got the cutscence. But it was my most frustrating 15h in my whole life. I never expect such buggy game from Ubisoft.
    I played 15h without playing side quests and i believe most of this was riding horse or traveling with ship. It so unreasonable big game and it so boring.
    For those who decide to restart the game This time ive finished "in dream" quest before cent and played no other side quests

  • Darthkribs
    1 posts

    A Brewing Storm Glitch. I go to sleep wake up and there is no one to fight. I have to walk around the base camp to find him kill him 2 times and nothing happens. The latest patch still did not fix this issue. I have been stuck here for a week now and I have done everything I can. I can not advance the game. Any suggestions on how to do this quest?

  • dereknorman4
    7 posts

    @h0mayun that’s sad. I contemplated this but I had 30+ hours in side missions and free world that I refuse to do again

  • Niy4h12
    4 posts

    Can you guys plz fix the A brewing storm bug. I was enjoying the game till up to this point reaching this buggy quest. Your latest update did not fix this issue as well and I so much like to continue my story mode. I also refuse to do everything over as I have put in over 82 hrs in to this game and to do everything over will discourage me.

  • EmoKid199387
    19 posts

    Yes please fix this I had to deal with the ubba bug now this bug come on or at least a hotfix

  • Niy4h12
    4 posts

    @emokid199387 They need to give us a hotfix ASAP

  • guest-r4j0ct2F
    1 posts

    Same happening to me. Please fix

  • jws1878-1953
    7 posts

    After I sleep the quest description is missing and Dag is roaming and figthing trough the village.
    quest is not finished if Dag is killed.

  • guest-zBVz0ESF
    13 posts

    still waiting for over a month for this bug to get fixed xd

  • Bloodyvampie
    11 posts
    This post is deleted!
  • Bloodyvampie
    11 posts

    @bloodyvampie @Ubi-Borealis

    So the Yune festival settlement update unfortunately didn't fix my dead horse carcass. Still there, please solve it 🙂

    Just need a "reset" of the settlement...

  • H0mayun
    3 posts

    Now im stuck again. There's no quest after kingdom's end. Im done with this game

  • guest-IpsUFvZ2
    1 posts

    @ubi-swaggins Any update on this? It has been a month. I am at the point of just returning the game for a refund.

  • Ubi-Raziel
    Ubisoft Support Staff 197 posts

    @guest-ipsufvz2 Hello! I'm sorry to read you're also affected by this.

    Our team were unable to reproduce this issue in a testing environment, it seems to happen under specific circumstances.

    Would it be possible to provide your save file, so our team can experience the issue first hand?

    This support article will help you find the save file: https://support.ubisoft.com/en-gb/Article/000080981/

    Thank you!

    Official Response
  • liahim13
    26 posts

    @ubi-borealis Hey Ubisoft, do you have any ETA for the fix of this quest? I can't progress from 3 weeks already.

  • Ubi-Orion
    Ubisoft Support Staff 875 posts
    Hello there!

    I've gone through the forums and merged all of the posts regarding being unable to interact with Dag following Eivor's rest in "A Brewing Storm" into one megathread.  In future, if you encounter this issue, please post it within this thread so all the information is in one place.

    Thank you all for your reports, and for sharing your experiences of the issue. We're sorry to hear that this has prevented you progressing within the game. By the sounds of it, it looks like if you don't complete Valka's quest ("In Dreams") prior to pledging to Cent, you're more likely to encounter this issue.

    The development team has been made aware of this issue and have been investigating further. They have been unable to reproduce this issue so far. We would like to collect more information from affected players in order to assist with their investigation 🙂

    If you've encountered this issue on any platform, please can you let us know the following:
    • Which platform do you use (PC/PS/Xbox)?
    • Have you been able to complete the quest "In Dreams" prior to this issue occurring? If so, could you let us know if you completed this quest prior to pledging to Cent?

    If you are encountering this issue on PC or PS4, please could you open a support ticket and attach the following files to your case:

    Once you have opened your support ticket and attached these files, please can you share your case number within this thread? We can then pass this information onto the development team. Thank you!

    Justus1302 - Thank you for sharing a video. I'll pass this onto the development team so they can take a closer look.

    Hey there folks.

    Just a reminder if you are playing on Playstation 4 or PC and you're experiencing this issue the development team are requesting save files from affected players. Please follow the links provided in the post above to get those to us. Thanks!

    Official Response

Suggested Topics