Welcome to discussions

Quick Suggestions

  • Niy4h12
    4 posts

    @ubi-swaggins Imagine this was a month ago and you guys still haven't fixed this quest!!!!!! Wow!!!!

  • Ubi-Borealis
    Ubisoft Support Staff 3625 posts
    Best Answer

    Hello there!

    I apologise for the double post. I'm happy to share that the development team deployed a fix for "A Brewing Storm" in TU 1.3.1. This issue should now be resolved.

    If you are still unable to progress in "A Brewing Storm" after waking up, please don't hesitate to update this thread so we can investigate further. Please include a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
    • You are unable to progress in the fight with Dag.


    I'd recommend uploading your video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread. We can then forward this to the development team for further investigation.

    Thanks! 😊

    Official Response
  • guest-F6Xk1t6S
    1 posts

    This is still a bug. Happened to me yesterday. I cant progress. I out in a support ticket hoping for a resolution. If it cant be fixed I'll want a refund also.

  • ashwii
    3 posts

    Glitch in A Brewing Storm where you cannot progress after killing Dag.

    Some forums who have the same issue have said it's because they haven't done the Valka quests and gone to Asgard.

  • CVonSkeletor
    1 posts

    I complete the brewing storm quest, give Dag Valhalla, then the quest completes. After it completes, I cannot access the alliance map and see no way to continue the story.

  • Csquared4
    5 posts

    @ubi-orion

    Hello.

    I replied to your comment on December 20th stating I submitted a support ticket and gave you my reference number.

    Can you confirm that you actually looked at it? Or that it was at least used? Almost 2 months now since I have yet to progress in this game due to this quest and I am not playing 50 hours of content back over again if I can help it.

  • osmm05
    2 posts

    @darthkribs Same glitch have u head how to fix it?

  • Americanvikin48
    2 posts

    Ok so my game has done the same thing as I see others are dealing with. A brewing storm I cant talk to anyone. Cant find dad. I have loaded it up again 4 times no change. I have tried to fast travel but it says unavailable. Please help me I have 99 hours in already I dont want to have to start over. Xbox gamer tag is Emil8377. Please fix

  • Mulkey89
    1 posts

    I am running version 1.0 no i will not update(as 2.0 doesn't fix it) and this useless bag of dirt is sitting in the ship. He spots me but no cutscene doesnt leave ship. Just a small thought here if your going to have a character turn on the player maybe don't make him essential in the boat. Bad game design. Last save is hour old. Will see if reloading fixes but hope looks small.

  • Ubi-Woofer
    Ubisoft Support Staff 1009 posts

    Hello everyone,

    I've merged a few more threads into this megathread to make sure that we are keeping all relevant details regarding issues with "A Brewing Storm" together in one place. If having issues with fighting Dag after waking up, or if you have already defeated him but the next objective has not appeared, please make sure to reply to this thread to let us know.

    Currently, we're still collecting additional videos and save files (DXDIAGs also helpful from PC players) to submit to the developers for these issues with this quest; if you are able to provide either, it would be greatly appreciated and very helpful in the team's efforts to identify the root cause of the issues and resolve them. Please let us know your case reference numbers here in this thread if you do submit any of the aforementioned files in a support case or via Live Chat, as well as confirming the platform you play on and which specific objective you are struggling to complete.

    @Csquared4 Thank you for submitting your save files and DXDIAG in case 13639491! These have been forwarded to the developers for them to review, and we'll keep everyone updated here in this thread as soon as we receive further information about the status of the ongoing investigation into this issue.

    @pizzapaarty Thank you for your reply! After building Valka's hut, did you collect the five thistles and hand them to her? This is the initial objective for "In Dreams", after which she makes the potion for you to drink. If you didn't do this yet, can you try taking five thistles to her hut and see if anything happens? You also mentioned sending your "backup" to us - do you mean your save file? If so, could you tell me the case reference number you were given so that I can send your save to the developers? Thanks!

    @Americanvikin48 Just to be sure, did you also try loading an older save and progressing through the quest again, as well as restarting the game client? Are you playing on Xbox One or Xbox Series X|S as well please? 🙂

    @Mulkey89 If you are not running the latest game version we are unable to troubleshoot the issue further with you, as it is the live version of the game (ie. 1.1.0 right now) where testing takes place and issues are verified. I would strongly recommend ensuring that your game is fully updated before reaching out again if needing further assistance from us.

    Official Response
  • lord__jesse
    2 posts

    I started the brewing storm mission. When I was about to choose between giving him his axe or not. The game received an error and it closed. When I restarted the game I could no longer start the conversation with him. I can no longer do anything in the home village. Not even upgrade my gear!

  • lord__jesse
    2 posts

    I have a problem that looks very alike. I have seen the cutscene and just before the end of the battle there was a choice. When i reveived the choice the game crashed and i am unable to continue. He just stand there and there are invicible people around him. I cannot continue anything of the story or interact with the npc's in my village

  • Ubi-Wan
    Ubisoft Support Staff 631 posts

    @lord__jesse Hey there! Thanks for reaching out with this. Could you let me know a bit more about the issue you've encountered in game? Are you encountering any issues with Dag? Additionally, are there any other details which you can share regarding this issue? A video or screenshots showing what's stopping you from proceeding would be particularly helpful!

    Official Response
  • johnnybangbang
    2 posts

    I also having the same issue on PS5 where Eivor goes to bed and is not woken up by Dax.

  • Americanvikin48
    2 posts

    A brewing storm.
    After entering the settlement. I argued with Dax. Spoke Randvi and then slept. Now I cant find Dax. I cant fast travel, I can speak to get quests, i can buy or sell or upgrade anything if i have to talk to an npc. Please fix this. I have 99 hours played

  • nobis1989
    1 posts

    @ubi-woofer

    so it says that due to covid there is only Live chat, then it says Live Chat is not available and I should use another support method. How do you expect me to send you my save file?? Raven?

  • maxxsinner
    33 posts

    @nobis1989 Had the same issue since November. They keep asking for save files and DxDiag files but no way for us to send them due to the support system being overwhelmed, I assume.

  • Lizaprecious
    1 posts

    Having this issue on Xbox One.

    Wasn’t offered the Valka quests and now the cutscene with Dag will not trigger. I’ve tried going back to an earlier save to see if I can trigger In Dreams but Valka won’t even talk to me!

    I’m 50 hours in but haven’t been able to progress since November 22nd (when this glitched first appeared for me). Please can you provide a fix for this? I was really enjoying the game and I’m now losing hope with everyday that passes without a solution.

  • RentotheA
    2 posts

    @ubikoality I've been experiencing the same issue since November and am still unable to progress, even after the most recent update. I tried to access the link with the troubleshooting steps that you mentioned but was sent to a general page. Can you please resend the link?

  • RentotheA
    2 posts

    @ubi-woofer I'm experiencing the same issue and unable to progress once I go to sleep once speaking to Randvi.

  • pearapple30
    2 posts

    @actionpackdude there’s no boy in my longhouse

Suggested Topics

Community Details

102
Online
192.1k
Users
32.3k
Topics
161.8k
Posts