Welcome to discussions

Quick Suggestions

  • holydudman16
    33 posts

    @gingerface642 the settlement is a little over level5
    and still nothing

  • Ubi-Borealis
    Ubisoft Support Staff 3561 posts
    Best Answer

    Hello there!

    I apologise for the double post. I'm happy to share that the development team deployed a fix for "A Brewing Storm" in TU 1.3.1. This issue should now be resolved.

    If you are still unable to progress in "A Brewing Storm" after waking up, please don't hesitate to update this thread so we can investigate further. Please include a video which shows the following:

    • You have the latest Title Update installed on your platform. You can check this in the bottom right-hand corner of the main game menu.
    • You are unable to progress in the fight with Dag.

    I'd recommend uploading your video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread. We can then forward this to the development team for further investigation.

    Thanks! 😊

    Official Response
  • Gingerface642
    13 posts

    @holydudman16 oh ok, I'm trying to think of anything that might make a difference
    Only other things I can are just trivial stuff like hair etc but I really can't see that affecting it
    Maybe try uninstalling the game and reinstalling it but that might end up a huge waste of time if it ends up the same

  • holydudman16
    33 posts

    its so frustrating

    the dude that said ((you have to upgrade a little bit for your settlement)) are you sure we are not wasting time??

  • holydudman16
    33 posts

    @gingerface642 already did it yesterday

  • holydudman16
    33 posts

    @gingerface642 i hope you enjoyed beating the [censored] out of dag 🙂

  • Justus1302
    Original poster 17 posts


    Honestly waiting for Ubisoft right now is probably the best option.
    Hoping to get the game to work by doing all kinds of random stuff has such a low chance of success.
    Returning to early saves, dream quests, upgrading village, changing armor, hair and graphical settings didn't do anything for me.

    I just want to kill Dag and make sure he actually stays dead so I can progress the story. The longer I actually spend trying to get it to work only makes me more frustrated it's still not working.

  • holydudman16
    33 posts

    @justus1302 but there are people that had the same problem like us but they did something and it worked

  • Gingerface642
    13 posts

    Aw damn, I'm pretty stumped for ideas
    It seems the only people that will be able to sort it are Ubisoft and I don't see that being very quick
    Dag certainly deserved it after all the crap he's putting everyone through

  • Justus1302
    Original poster 17 posts


    Dag has died a thousand deaths in my game so I'd say he's certainly going through some kind of hell for what he's doing to my game.
    I'll keep trying to randomly get the cutscene to play but I don't imagine I'll actually succeed at this point. Maybe we just need to get lucky once.

  • actionpackdude
    4 posts

    Been keeping an eye on this thread hoping someone found a solution, cause this is a really annoying problem. Why can’t he just stay dead?

    In all seriousness, thanks for anyone who offered a solution.

  • Gingerface642
    13 posts

    I think that might be the only way, Leave the game for a week or so until Ubisoft get it patched
    Sucks though, especially if it was a preorder

  • chhmo2000
    10 posts

    Got the same problem. Been having it for a day now. Tried all of the things above but nothing...

  • Justus1302
    Original poster 17 posts


    Everyone that has the same problem and reads this. Please reply to this post so it gets bigger and gets noticed faster.

  • Nahk1s
    3 posts

    Same problem here. Have tried everything there is to fix it. Even tried to pet every animal in my settlement. Hope this will be fixed soon . Didnt pay 60 bucks for this

  • chhmo2000
    10 posts

    Yes, I was thinking the same! Everyone who experiences this problem should reply!

  • DrewDavidNZ
    1 posts

    I also had this problem but I've managed to get passed it by loading my passed manual save back to when I arrived at Ravensthorpe to talk to randvi to complete the pledge to cent. After re loading I spoke to randvi and then defeated dag and completed the mission. All I can suggest is going back to an older save and then manual save before you complete the pledge to Cent and go back to that save if the problem occurs.
    I am on ps4 by the way.

    Loving the journey thus far but the game is riddled with bugs stopping me from completing many world events, the game is constantly crashing also which is frustrating. I've decided to stop playing Valhalla until ubisoft have resolved all these problems. The game has so much potential and I fear not all these issues will be dealt with quick smart.

  • GorillaHeadXCVI
    6 posts

    @drewdavidnz lucky for you but I don’t think you are having the same problem as the rest of us? I personally have reloaded to the reporting on cent save now about 50 times , sometimes I even wake up beside the bed on my reporting on cent save which leads to a panic reboot so that it doesn’t fully overwrite this save ,, I have tried doing mysteries to get my gear level passed what it should be and come back I have raided areas 20 levels above mine on Drengr difficulty (awful pain) just to upgrade my village to flawless standard to see if this helps and then saved again outside the hut to try do the reload a save trick another 20 times in a row doing something else and coming back and do the reload again. I tried starting the game again today but I couldn’t go through with it I want to save my second play through for a ng+ where I am a [censored] where I say [censored] Sigurd I will take his crown and his wife,, but the way things are looking I will be lucky to make it to the end of the first play through

  • holydudman16
    33 posts

    my bug is like this= i sleep in the bed and 10 seconds after that i spawn near the bed standing still
    and its rainy and stormy outside
    dag is on my ship
    i even reloaded my save from before cent and pledged every other regions and still didn't work
    im just so tired of trying and trying to get a result 😔
    its so frustrating i hope one of us finds the problem and tell one another

  • holydudman16
    33 posts

    @holydudman16 there is no cut scene no dialogue and dag is not there
    i cant do anything not even fast travel

  • holydudman16
    33 posts

    can someone please explain to me the
    ((reload a save trick))

Suggested Topics

Community Details