Welcome to discussions

Quick Suggestions

  • crypt-gardian
    1 posts

    I have same problem There's no cut scene after going to sleep. Dag is showing red but non responsive.I kill him but he just gets up. You would think the game developers would have fixed it by now instead of adding another event{Ostara Festival}.Even this has a glitch on the Lets get Festive challange where you cant decorate the camp as the posts are missing. Anyone else have this problem as its been shown on you tube

  • tempete0390
    53 posts

    I emailed IGN. I tweeted at Erik Kain and Paul Tassi (Forbes gaming and other nerd stuff). Half the time I warn people on Reddit I get downvoted to [censored] but the person I've warned is grateful and that's just Reddit. It feels like there's so many of us but we aren't being seen. When the internet is able to organize itself, things happen. But it's the organizing that is the hard part. I recommended everyone email IGN at the link that was provided above. If enough people bother them, it could at least get another fresh story out there calling Ubisoft out. The Washington Post covered it for [censored]'s sake. That's a pretty big deal but there needs to be more.

  • tempete0390
    53 posts

    @crypt-gardian They removed the decoration quest with a handy dandy hot fix at lightning speed. The #brewingstormbug club is just in eternal purgatory.

  • SixFeetUnder828
    5 posts


    I emailed IGN as well. I've put the Washington Post story out on Twitter too. I have another question... What happens to materials packs that you have purchased with helix credits if you have to start a new game? I'm assuming that you're out of luck as far as that goes.

    If they can't fix the issue, they need to at least give us a "new game plus" mode accessible at any point, not just if we finish the game (which 50%+ of players CAN NOT). I don't feel like losing all of the skill points, abilities, and upgrades because of something that I had nothing to do with.

  • tempete0390
    53 posts

    @sixfeetunder828 Materials you're probably sol. The Huldufolk gear I bought eventually showed up in my new game but it was weird and randomly timed.

  • AlphaGoose46219
    158 posts

    @saintlyllama420 See https://discussions.ubisoft.com/topic/88357/unable-to-progress-with-a-brewing-storm-after-waking-up-post-here/6 there are some "tricks" to go around it (use someone else his save) for PC but most are desperate waiting for a fix.

  • AlphaGoose46219
    158 posts

    @sixfeetunder828 Played the game 3 times from the start, you will get all your Helix and ultimate items available after you have visit your king (step father) in Norway.

  • ArgutusRi
    2 posts

    Playing on PS4 Slim

    Heya, just want to add some of my info to this in case it helps. I just finished the Cent arc yesterday, went to report to Randvi, got confronted by Dag, and when I went to sleep and woke up nothing happened. Everything was foggy, I couldn't talk to anyone, and no Dag to be seen (I didn't check the graveyard though).

    I had a save just far enough back to reload, right after I pledged to Cent. I pledged to Jorvik and that seems to override the Cent pledge, so I'll occupy myself with that for now. It does lose me about 20 hours of gameplay (I fish a lot), but 20 hours out of 111 isn't so bad to lose. I have not done Snotinghamscire or Vinland yet, though I will while waiting for this bug to be fixed.

    Specifics on my game that may or may not help:

    • Asgard arc is complete, I have not done the Jotunheim arc but by the time I had finished Cent I had the new herbs, plus a couple of extra.
    • Settlement was level 5 I believe.
    • I did not romance Randvi, so I don't think that's it.
    • I haven't seen anyone mention it so maybe it's nothing, but I have had nudity, dismemberments and assassination sequences toggled off for the entirety of my playthrough. Blood is still on.
    • I'm playing on Berserkr difficulty with hard stealth difficulty.
    • Throughout my game, when I've come back from River Raids the settlement glitched out a lot like this, but closing the game and booting it back up again fixed it.
    • I haven't bought anything through the helix store.

    I can't think of anything else that might be helpful. But I do want to say: thank you, Ubisoft reps, for continuing to go through this thread. I know it can be rough seeing all these complaints, legitimate though they are.

    Also want to say, to everyone who's having the same problem, being upset and wanting your money back is totally fair. This glitch does kind of make the game incomplete, and therefore it shouldn't be full price. I definitely think someone somewhere is not allocating resources to this glitch like they should. Five months is a SILLY amount of time to go with a game breaking glitch.

    However, don't direct that ire at the Ubisoft reps in this thread, or even at the development teams. They don't have the power to fix this, to force higher-ups to focus on it. I've dabbled in game development and talked to a lot of people from the industry, and it really isn't the fault of individual developers or social media representatives. If it is a problem of not prioritizing this glitch, that's on the shoulders of someone in management, probably pretty high up the totem pole. If it's just because the glitch is that hard to fix, developers are probably doing everything they can. But developers can only work on what they've been told to by project managers. It isn't the fault of the developers, and certainly not reps. Reps are just the messengers and can only relay what they have been told.

    Anyhoo, while waiting for a fix I'll work on the other arcs and do a lot of fishing. I adore this game, and this glitch has been super disheartening because I really want to continue with the story, but I will definitely be watching out for a fix and ready to get back into the action, whenever that may be. Someone at Ubisoft is screwing something up, but it's impossible to know who so I shall save my anger for more important issues.

  • tempete0390
    53 posts

    Holy. [censored]. Crap. The replay worked! Omg it worked!!! Here is a painstakingly detailed and very long review of what I did and didn't do for those of you who may want to try a start over.

    In Fornburg/Rygjafylke (starting/turorial area) of Norway I did every artifact and most mysteries except the lost drengr (Erik Loyalskull). I did all flyts in Norway with large bet for each (excluding Hordafylke if there even are any flyts there). Two other things I did that I 90% ignored in my first play attempt are I competed and won each drinking game (including Alrekstad) with medium bet for each. I played and won each Orlog game. I did main quest in Norway quickly and moved on to England.

    In England I did the territories in the order the game wanted (Grantebridgescire, Ledecestrescire, East Anglia, Oxenefordscire, Lunden, Sciropscire, Cent) and ignored all sidequest-style mysteries. It should be noted that I did them in this order the first time, too, but on my replay, I did not run around picking up every mystery/artifact, wealth and I did not explore around the territories the main story hadn't pushed me to yet with two exceptions: a quick side-trip into Hamtunscire to grab Death-Skald and another quick side-trip to Eurvicscire for 3 tungsten ingots to upgrade my seax because I was severely underleveled when I got to Sciropscire and had the Ivarr fight coming. I did no viewpoints, games or any other nonsense in either of these two territories; straight in and out.

    In England, I played and won each drinking game (all medium bet), won every flyt (all large bet) and played every Orlog game until I won as soon as I came across them in the territories ordered above. I caught a few random papers here and there but they weren't in any particular order. I didn't trigger any of the main romances but I did accidentally trigger the "plow sword" brother ... it didn't matter in the end. I picked up viewpoints and wealth in all territories when they were conveniently placed along the way of the main quest grind.

    I meant for Ravensthorpe to reach and remain at 3 but it somehow got bumped to 4 after reporting on Lunden to Randvi. Initially, I built the blacksmith, Hidden One's Bureau, Yanli's trading post, and Rowan's stable. Reda just kind of moves in so yeah. I absolutely did not want to build the tattoo and hair shop because the cemetery is where Dag's dumb [censored] is sitting in-glitch. But then the tattoo guy died anyway and I had to go talk to Tove at his grave so I just built it--since the game makes the cemetery area unavoidable--and crossed my fingers. After I reached 4, I built the barracks and shipyard too and remained 4. NO hunter's hut, fish monger, or any of the other crap. I did some of Reda's dailies/the weekly but not all. I helped Valka move her box and then stayed as far away from her hut as I could. No Asgard/Jotunheim.

    I intended to only kill OotA's that the main quest forced me to but I did kill one other unintentionally, Odyssey-style, when he ended up being the kill target for one of Reda's contracts. I gave NO MEDALS TO HYTHAM. I spoke to him after Lunden as per main quest but no medals. So no Vinland. I also did not explore or even go near any of the abandoned Assassin's Bureaus with a ten-foot pole whilst main questing in those territories.

    The *only* mystery/sidequest I did in England was Freyja's Friend (where you get boat cat). It was late, I was tired, I'd been grinding for hours, and I actually just [censored] up and did it on accident. In the end, it didn't matter for me but I'd still not recommend doing any real sidequesty-heavy mysteries. In England at least. My Norway sidequests were a dice roll and I got lucky.

    I did none of the Ostara nonsense. No wolf Mouse, no Dandy poof. Other than the Norway Elk, no legendary animals. None of it. When I got to the Cent pledge, any and all flirting with danger came to a screeching halt. What I did differently: the first time I played, on my way to depart for Cent, I told Dag to get on the boat. This time I told him to do whatever he wanted. Upon arriving in Cent, no drinking contests/flyting/Orlog. In Cent, I changed one of my answers to Basim too. Instead of just saying where's Sigurd, I asked what does Fulke want with Sigurd. I did no viewpoints in Cent. No blue, gold or white dots at all. pure 100% main quest only.

    After Cent concluded--as much as part of me wanted to fast travel or at least take the boat--I got on my horse and took a long anxiety-ridden 5,000+m beeline ride/swim all the way back to Ravensthorpe. Truthfully, this might have just been me afraid the bug would happen again and trying to drag it out. I just had a weird feeling I should do it that way. The very same type of weird feeling I had the first time I saw those fateful words telling me it was naptime.

    My gear: full Huldufolk armour set (on my first play attempt I alternated between the Raven Clan pieces, Huldufolk, and Magister's set with the majority of my play being with Magister's), Huldufolk light shield (I was dual-wielding the Yngling Seax and and Huldufolk Blade on my first play attempt), Hunnish Bow on the first quarter of my restart game, Skadi's Wrath on the second quarter, and Death-Skald for the last half. This second successful attempt took me about 20 hours.

    No idea if any of the above matters but, since Ubisoft doesn't care, I have no idea what ridiculous, piddly little thing could or could not trigger the bug so I've included every bit of the information I can think of atm. If you're going to try again and have questions that aren't already answered ^^^ go ahead and ask!

    HUUUUUUUGE thank you to @chachalote for the helpful start-new-game info!

  • Jhaan123
    15 posts

    Hi all. I've been following this thread for a while, reading posts. I got the bug 3 weeks ago, and it wasn't looking like Ubisoft was fixing anytime soon so I went ahead and restarted the game...

    ...I didn't get the bug and got past "A Brewing Storm" after restarting the entire game. I was on console. Wanted to share my experience to isolate what the potential problem may be, as well as let others know how to do it without encountering the bug again:

    Estimated Time- 12-15 ish hours. More if you don't skip dialogue

    To start, DON'T DO ANYTHING APART FROM THE MAIN QUESTS. This is the only guaranteed way to avoid the bug.

    Second, don't leave England once you arrive. This means don't leave the animus nor return to Norway once you land in England. The part in the story where you're forced to leave before arriving in England is fine.

    Third, it's probably best to do nothing in areas the game doesn't recommend you enter due to power level. This means no Hordafylke in Norway too (apart from the one story quest you have to go to). I've seen a couple of players mention they wandered into higher leveled areas to get weapons, but in my playthrough I stayed away from them just in case. When I ventured to Cent, I went through Lunden and avoided Essex.

    Since the recommended order of main quests in Valhalla gets unclear at points, here's the progression I did in my game:


    Order of main quests - Ledecestrescire, Grantebridge, level up village to lvl 3*, Escort Valka on the docks to her new home*, talk to the Reda merchant*, East Anglia, Oxenefordeshire, Sciropeshire, Cent

    *I rested in my bed multiple times. I usually did it before reporting to Randvi to pledge new areas
    *I did not do any side quests during any of these, including Reda quests. I DID slightly venture off the beaten path in these areas whenever there was a spellbook or gear nearby
    *I built the Blacksmith, Hidden Ones Bureau, Item Shop Tattoo Shop and Barracks in that order. Nothing else. I escorted Valka to her house at Village LVL 3, but didn't start any of her quests
    *I only talked to Hytham once-- to get the Leap of Faith ability. I never spoke to him again before "A Brewing Storm"
    *I did not speak to the child in the longhouse to start the "A Little Problem" quest to get your dog.
    *I also didn't speak to any villager apart from the Blacksmith, Item Shop owner, Tattoo shop owner and one instance w/ Alvis & Holger where they're arguing about Flyting.


    As previously mentioned, I've been following this thread for a while now and I've seen how some players do certain things and get the bug, while others do completely opposite things and still get the bug. So I'm going to list all the things that I think haven't been contradicted that might be causing this bug.

    1. Valka's questline - This is the big one. I think somewhere along the way, starting Valka's questline before A Brewing Storm borks the game. If I had to guess where, I'd say it's linked to WHEN you build her hut. I overcame this bug by simply not building it at all, and just escorting Valka to her tent when my village reached lvl 3.
    2. The 3 Sisters side quest - I didn't interact with anything involving the "Daughters of Lerion" questline and was able to get past the bug. I think starting this questline before "A Brewing Storm" might be messing w/ some game flags.
    3. The Getting Your Dog side quest- This one hurt, but I didn't engage with the side quest "A Little Problem". Maybe your dog causes weird pathing issues w/ A Brewing Storm - I mean it DOES rest in your bedroom alongside you. To avoid this quest, simply don't talk to the kid w/ the "..." box over his head in the longhouse.
    4. The Fox side quest - Since I wasn't doing any side quests I didn't get the village fox, which I noticed also has weird pathing. You get a Fox during the Oxenefordshire quest "A Dog's Rescue"
    5. The Hunter's Building side quests - The hunter building is right outside the area where the "A Brewing Storm" cutscene triggers. Perhaps doing a side quest involving the Hunter building causes the bug
    6. Building certain village buildings / getting to Village LVLs above LVL3 - In my playthrough I only built the Blacksmith, Hidden Ones Bureau, Item Shop, Tattoo Shop and Barracks. Maybe one of the other buildings (Valka's Hut or the Hunter's Hut??), or being Village LVL4 or higher causes the problem
    7. Entering Higher-level zones before your recommended power level- I only stuck to what the game recommended path-wise: Ledecestrescire, Grantebridge, East Anglia, Oxenefordeshire, Sciropeshire, Cent. I briefly went into Lunden to get to Cent but didn't interact w/ anything while there.
    8. Talking to Hytham - Hytham gives you quests in multiple areas of the game. I didn't speak to him at all b/c I was afraid he might be triggering flags that conflict w/ your current main story gamestate. I got past the bug when I didn't speak with him.
    9. A quest in the Cent storyline - Cent's got very wonky main quests since Basim follows you in a lot of them. Maybe a quest in this line doesn't FULLY complete gameflags due to Basim's positioning when you complete quests, and that's what's causing the "A Brewing Storm" bug.
    10. A quest in the Oxenefordeshire storyline - Oxenefordeshire's quests have similar problems to Cents, in that Basim AND Sigurd follow you in a lot of them. Maybe a quest in this line doesn't FULLY complete gameflags due to Basim or Sigurd's positioning when you complete quests, and that's what's causing the "A Brewing Storm" bug.
  • Jhaan123
    15 posts

    @tempete0390 oh shoot sorry! I didn't see your post otherwise I would've waited on mine! Haha-- glad you got past the bug too tho brother!

  • Jewelianne510
    2 posts


    Unfortunately, I think most of those things don’t matter. My husband and I are playing on the same console. We have pretty much followed the exact same path on each of our accounts even down to choosing the same answers. We have both killed 2 of the witch sisters, built the hunters lodge, gotten the dog and Fox, and our settlements are on level 5. He did build Valke’s hut before I did. I completed the whole Asgard Arc prior to cent. He has only finished the first part in Asgard. He is playing as maleándole I’m playing as a female. I’m level 260 and he is 200. I have done more mysteries than him. He has collected more wealth. I got the bug. He played through cent later the same day to see if he was going to get the bug too. He didn’t. We are on a ps5. It’s absolutely infuriating! The gameplay has been glitchy from the start but we overlooked that to just play the game. However, for this bug to completely block you from finishing the game is beyond unacceptable. Especially with the fact that players are here trying to figure it out for 5 months with no fix.
    Im happy that your second play through worked out for you!

  • pweeks65
    3 posts

    @argutusri I agree with most of your post, but i did more than dabble in game development. IMO this bug was known when they shipped...they wanted to be a launch title, but because the bug is 50% (or less), the said "ship it". Management does to some extent determine what bugs get worked on and in what order, but a known A bug that stops the game, in my day, never let a title ship, even if it meant revenue loss. The fact that no one is visibly working on it, and that they're making patches for things like Ostarra, along with an immediate hot fix for problems with Ostarra, is among the reasons that everyone is so bent. Ostarra was free so Ubi isnt making money on providing that patch, so it should have no priority over a 100% game progress stop bug. And as evidenced by the speed with which they put out a bug fix for Ostarra, makes it obvious that they could apply a hot fix for this current issue. Fine if you want to continue to put resources on what the root cause is, but put out a fix for the many players that are currently stopped with a game that they (or someone if it was a gift), paid 50-70 bucks for. Agreed that the forum moderators and support staff don't need to be a given a raft of s**t, but they signed up to be the frontline person for a company that has an apparent disregard for the player base.

  • Jhaan123
    15 posts

    @jewelianne510 That's honestly shocking, I'm sorry to hear that! Hmmm......it's either multiple things then, or might be something extremely granular, like 1 mission during the Cent storyline— I still think Basim acts extremely buggy during all Cent missions, and I'm wondering if players who complete quests w/ him while he's doing something buggy is causing the A Brewing Storm bug.

    It might also be a particular building, or doing a particular villager mission, like the Hunter mission just before you can romance Petra. Are there any differences from you and your husband's playthrough in those regards?

    Also, since you and your husband's playthroughs are exactly the same choice-wise and you can change Eivor's gender at any time...can you load up one of his playthroughs AFTER the bug and just switch your gender, making that your new playthrough file?

  • tempete0390
    53 posts

    @jhaan123 No worries! When we're becoming how-to-beat-the-bug-by-starting-over novelists en masse, it's a good thing lol ... since we're all each other's tech support.

  • tempete0390
    53 posts

    @jhaan123 I agree with the Basim theory. On my first playthrough, when we were riding to find Sigurd (his arm), Basim tells that big long story about his dad and the mosque of Samarra and the corrupt caliphate and the library in Baghdad with the astronomer and blah blah blah blah. After he finishes, he just starts over and keeps rambling along while we're sneaking in resulting in sneaking going all to hell and him only shutting up with the story on repeat after we're spotted and he snarkily tells *me* "so we just blunder in like clumsy oxen then?" Like ... all your fault Basim, suck it. Additionally, he kept hopping off his horse for no reason, jumping onto mine with me, running back the way we came or running after me on foot so I had my Eivor starting and stopping and turning her horse in circles to try and figure out [censored] Basim and keep up with his buggy hijinks while he rambles his story. After the bug I went to a previous save that was after I finished Cent but before nap and he was standing in that same place you meet him before finding Fulke, fiddling with that apple or peach or whatever on an infinite loop. More than once I wished he'd just go [censored] off somewhere. I didn't need his help.

  • PixelWitcher
    2 posts

    Stuck now for a week! saw this thread and feel sorry for the people who are stuck for months! Ubisoft put your best dev on this, not your part time trainess dev.. fix this! delete the dumb quest or something. i have a save before this stupid mission. Delete this dumb mission or fix the mission.

    Do something!

  • Jewelianne510
    2 posts


    It has to be some small little decision/mission that I did as opposed to him. I just checked with him and I was mistaken... he hasn’t built the hunter’s lodge so that could contribute to it. Basin was glitchy in his with jumping off the horse and jumping on his horse with him. Basin wasn’t like that in mine. One think I noticed in mine was that after cent, I went back to the construction site where you kidnap the guy during the mission and the character was still there but on his knees with arms behind back in one of the buildings. I couldn’t interact with him until I hit him with my ax. Then he gets up and says he is going to keep pretending to be the guy he was pretending to be. Sorry I can’t remember the names right now. Haha Right after I did that, I went to report to Randvi and go to sleep. Then I woke to the bug. He avoided going back to that area after completing cent. Another difference we had was that I had completed Vinland and he had not gone there yet.
    I can continue on a manual save of his but I’m waiting a little longer hoping that they will patch it and I can finish my game. I’m studying for a board exam right now (step 1) so not being too invested in a game isn’t a bad thing. Hopefully they fix it by May when I take my test. 😂

  • ArgutusRi
    2 posts


    Yeah, it’s a super sucky situation and I ain’t happy about it. I didn’t know they knew about the glitch before launch! I still love the game and empathize with everyone working on it…but shipping the game like that is just messed up.

  • guest-GlxSd8Ts
    2 posts

    @thedzik_2137 me tooooooo100000000000player

Suggested Topics