Welcome to discussions

Quick Suggestions

  • Seanski2021
    2 posts

    Cant do any more missions bcs of a bug in (more Intel) cant speak to hytham or find and fight dag. Cant talk to anyone or upgrade my things. I cant do anything in my own settlement, please help.

  • swazzle2000
    5 posts

    @guest-glxsd8ts well, sucks to be them because I'm just going to play something else until they fix it. And until they fix it, I won't be buying any more of their games 😊

  • zHerofighter
    4 posts

    Having this issue as well since 2 weeks ago and yet Ubisoft still did not fix it. Just put this issue on top priority please and fix it ASAP. It's a 4 months ago issues and yet until today still occuring. Instead of wasting time on stupid festival, just fix this issue already. I am so frustrating, spend 100++ hours and still [censored] bug quest prevent me from proceed to the main story.



  • Brandon534
    1 posts

    I can not progress in the story or do anything can you please address this problem bug start the mission an there is no dag to fight an can not interact with anything else in the game cuz the mission is still playing..

  • medhedlll
    2 posts

    Just ran into this bug yesterday... I had a save before Cent so I went back and finished the Asgard missions and then did Cent again but to no avail...please fix this! This is worse than Cyberpunk lol and we all know how much they screwed the pooch...

  • Doner07
    31 posts

    @medhedlll Yeah, Asgard missions probably doesn't matter because many people, including me and you try that already and we still had bug. As other players stated, the problem probably is with our settlement level. I had it on lvl 4 when i get a bug, then i upgrade it to level 5 and i still had problem with A brewing storm so maybe you can't have lvl higher than 3 or maybe it depends on what you build. Maybe it's a problem with Valka Hut, maybe something diffrent or not even related to settlement. Or it is problem with decoration you pick... i don't know. The only common thing i notice is that all people who have this glitch were playing very thoroughly. Probably 100% completed all areas they pledged...

  • wakanda_oz
    1 posts

    I have the that problem as well. I'm playing on ps4 and after going to sleep, no cutscene, et etc. I managed to do the first 2 missions from valka, everything works properly but I still have this bug. The update I'm playing is the 1.2.0.1 is there a y solution?

  • EpicAar
    25 posts

    I wouldnt mind helping get a class action suit going. Bestbuy wont return my money because its past the date. And Ubisoft doesn't stand behind their product.

  • tempete0390
    53 posts

    @doner07 When I did my replay to get past the bug I meant to have Ravensthorpe at 3 but it accidentally got to 4. I still got past the bug though. My current best theory is Basim is just all sorts of buggy [censored] up in Cent and the Brewing Storm bug happens. So far, from my extensive and totally expert online research, people who had Basim act normally on the horseback ride got no bug and people who had Basim on meth got the bug. My first play was meth Basim. My second was normal Basim.

  • tempete0390
    53 posts

    @epicaar I second that. Amazon laughs at me after 30 days. Suebisoft.

  • H.SoloShotFirst
    10 posts

    @tempete0390 I didn't had any bugs in the Cent arc until the Brewing Storm quest of course. But this bug is surely occuring when you try to clear the map, so it has to be related to certain side activity.

  • Castro_Eux
    1 posts

    Hi,

    I'm currently on the Cent missions, ( A storm is brewing _ PS4) after waking up from sleep i can't continue. I can't speak to anyone or do anything besides walk around/sail around. 
    When i looked online i saw that I'm supposed to confront Dag outside by the bell, but this isn't available...
    I deleted the saved game data leading up to those missions, i only could have deleted up until we captured Tedmund. And then the 2 missions to find Fulke. I tried this 3x already and i even deleted and pledged to another city and came back to Cent, but still no progress .

    Can you help me please, i really enjoy the game and i invested a lot already, i can't afford to start over.

  • Doner07
    31 posts

    @tempete0390 yeah, it could be the problem because Basim was also buggy is hell in my game. Besides i dont know why but i lost quest with codex pages to Hytham. Quest just wanished from journal.

  • McPolish77
    1 posts

    I have the same issue. I completed the pledges in order of suggested power level, my village is at level 5, completed the Asgard quest in the Valka quest line, character is at power level 314, completed the first set of River Raid quests as well as a few others. Like many others, I invested a lot of time into this game. After 130hrs, which is about half completed, I can’t continue. I even moronically purchased some DLC content, which I thought was worth it before running into this. It is beyond belief that after 5 months a resolution has not been flowed down from this group. Instead the game gets useless fixes, and an inadequately tested festival content update with even more bugs. I also want to point out to the program managers, financial managers and corporate managers that you are working on an expansion pack for a game that will not allow the players to complete due to this bug. So how do you plan to create revenue for the Druid expansion if players won’t purchase it, because the base game is broken and can’t finish. A smart person would look at the fact that it’s been 5 months without a solution to a major problem, which is so bad that the Washington Post ran an article about it, and commit their best resources to solving this before wasting more time on an expansion that will be DOA without a fix. If this doesn’t get fixed, then I will not be purchasing another game published by UbiSoft, and I will make the same suggestion to everyone that I know.

  • Doner07
    31 posts

    @tempete0390 I know it probably doesn't matter but did you do anything related to Valka? Im asking because ravensthorpe is on lvl3 and Valka is waiting in the docks. Im playing really carefull now, don't want to be left with bug again.

  • xTIGERLILY87x
    1 posts

    @brandon534 good luck. I've had this issue for over a month and looked into it and some have been reporting for over 4 months and still no fix. I deleted and reinstalled the game and nothing. I've sent multiple messages to ubisoft they just say they are working on it and have no further info.

  • shtephan123
    1 posts

    Same here. After sleeping the duel witth Dag doesn't trigger. I can find him in the settlement's graveyard, beat him but he neither dies nor fight back. Some people noticed that this bug has appeared only to those who have not completed the God Arcs before pledging to Cent.

  • Doner07
    31 posts

    @shtephan123 god arc? You mean arc in asgard? Yeah, someone notice it but few months earlier. It's not true, I completed Asgard after i visit East Anglia so it was after my 3rd pledge. About jotunheim... Most people waiting to complete this quest after cent storyline because these herbs that Valka wants you to find are in Cent. I saw somebody playthrough when he was in Asgard but not in jotunheim, complete Cent storyline, found herbs and didnt had bug. I've done the same and had so it's nothing related to this "God Arcs"

  • maxxsinner
    33 posts

    Quick stats on just this thread

    • 735 Replies & almost 1800 views. Can safely assume that well in excess of 1000 people are affected by this bug
    • It's been 4 months, 13 days since the first post
    • There have been over 4 patches & updates in that time and none have even acknowledged this bug
    • In that time the only response that we have received is 'we are looking into it'
    • March 18th - 4 months after the first report of a game breaking bug, the Brewing storm bug was finally added to the known issues report
    • 2 weeks since an Ubisoft official has posted on this thread


    And considering the prioritization of adding cats and Easter eggs instead of literal game breaking bugs from the Ubisoft dev team, if I was a support team member, I would be too embarrassed to comment too.

    I hope everyone affected by this remembers that next time an Ubisoft game is released, that the only way we can show them this is unacceptable is by voting with our wallets. This is nothing short of [censored] theft.

  • certaindestiny4
    2 posts

    @vindictivemercy I remember being promised a fix for this bug BY ONE OF THE AGENTS not that long ago...they still haven’t followed through with what they said to me.

Suggested Topics