Welcome to discussions

Quick Suggestions

  • 38 Likes/1377 Replies/46294 Views
    4 posts

    I have the same problem. I believe my issue is due to Valka. She didn't appear after i reached level 3 in Raventhorpe. I am now level 4 and she is still not appearing. The update patches couldnt help. And the support from Ubisoft asked me to upload the save to my complaint, but added that they wont do a personal fix but rather a global fix. So it is either they prepare a patch for it (which i doubt is possible) or you restart the game..

  • monaali791
    4 posts

    I have the same problem. I believe my issue is due to Valka. She didn't appear after i reached level 3 in Raventhorpe. I am now level 4 and she is still not appearing. The update patches couldnt help. And the support from Ubisoft asked me to upload the save to my complaint, but added that they wont do a personal fix but rather a global fix. So it is either they prepare a patch for it (which i doubt is possible) or you restart the game..

  • Scangeo
    3 posts

    @ubi-spud Do we have a resolution for this issue yet? Seems so many other people have run into this same problem. I've been waiting for days now for a patch because, after 100 hours of gameplay, I can't progress the story any further as no new story missions are available and, despite having left messages for tech support via Facebook and Twitter as well as here, nobody wants to respond... Not happy with Ubisoft at all right now. Your customer service is woeful.

  • guidedbyfailure
    1 posts

    I cant start the second story arc for lincolnscire I go to pledge and it just gets stuck i can move the camera but not the character and I can't open the map or create a save I cant do anything but move the camera and ive done every thing else on the map so I cant complete the game until this if fixed you spend 90 on a game and then find out you cant complete it because ubisoft let it come out with some many bugs

  • UbiKobold
    Ubisoft Support Staff 702 posts

    Hey! So sorry for my late reply, but thank you all for your patience during these busier times! This issue is currently being investigated, and I was wondering if you all would not mind providing your save game files? I would like to send them to the Game team for review. If so, please create a ticket and attach the files. Then, provide your ticket number here. Thanks!

    Official Response
  • Ubi-Borealis
    Ubisoft Support Staff 4552 posts

    Hello there!

    I've gone through the forums and merged all of the posts regarding being unable to interact with Dag following Eivor's rest in "A Brewing Storm" into one megathread.  In future, if you encounter this issue, please post it within this thread so all the information is in one place.

    Thank you all for your reports, and for sharing your experiences of the issue. We're sorry to hear that this has prevented you progressing within the game. By the sounds of it, it looks like if you don't complete Valka's quest ("In Dreams") prior to pledging to Cent, you're more likely to encounter this issue.

    The development team has been made aware of this issue and have been investigating further. They have been unable to reproduce this issue so far. We would like to collect more information from affected players in order to assist with their investigation 🙂

    If you've encountered this issue on any platform, please can you let us know the following:

    • Which platform do you use (PC/PS/Xbox)?
    • Have you been able to complete the quest "In Dreams" prior to this issue occurring? If so, could you let us know if you completed this quest prior to pledging to Cent?

    If you are encountering this issue on PC or PS4, please could you open a support ticket and attach the following files to your case:

    Once you have opened your support ticket and attached these files, please can you share your case number within this thread? We can then pass this information onto the development team. Thank you!

    Justus1302 - Thank you for sharing a video. I'll pass this onto the development team so they can take a closer look.

    Official Response
  • dereknorman4
    7 posts

    @ubi-borealis Hello I am having this problem on Xbox. I never completed “in dreams” because I did not level up my settlement to level 3 before doing cent. I tried to upgrade valkas hut in raventhorpe during my cent pledge but it did not do anything. Others have said that their valka quest was bugged and they never got it in the first place once they reached settlement level 3. I also have not completed jotunheim quest or vinland.

  • Ubi-Borealis
    Ubisoft Support Staff 4552 posts

    @dereknorman4 Hello there!

    Thanks for sharing this. I'll pass this onto the team 😊

    Official Response
  • H0mayun
    3 posts

    Ive completed all valka quests and the problem still remains, after waking up i find Dag in longship

  • guest-zBVz0ESF
    13 posts

    @ubi-borealis I have this problem on PS and i didn't do the In dreams quest. Moreover my settlement is level 5 or 6 and after doing valkus hut i didn't receive her quest , nor I'm being able to contact with her

  • Draekavak
    1 posts

    When i go to spleep the screen goes black and then i wake up and cant do anything.

  • Csquared4
    5 posts


    I am playing on PC.

    Did not start or complete the "In Dreams" quest at all. Settlement is currently level 5.

    Cannot talk to Valka, Reda, or Radvi.

    Already pledged to Cent and completed the Cent storyline and talked to Radvi. My next quest in the main story line, is A Brewing Storm. To start the quest, you must go to sleep in the Longhouse. I go to sleep, the screen goes black for about 5 seconds, then I wake up standing beside my bed with it raining outside. I can go outside and see Dag casually walking the settlement if he hasn't engaged in combat with someone within the settlement. If triggered, he enters combat with myself and allies around the settlement. Throughout the fight, he will slowly drop weapons. First he drops his shield and brings out two axes, then eventually throws 1 axe and just is left with 1 axe. Then afterwards, is eventually left with just his fist punching me. Once I get him to half health, a short cut scene zooms in while Dag and myself are locked with weapons and we have a short dialogue about us not having to fight. I drain Dag's health down to 0 and it does a short 'Kill Cam' of me kicking dag in the chest but my foot never hits him and he stills falls over. Then after 2-4 seconds, he stands back up and is half health. This can be repeated an infinite amount of times, he cannot be killed.

    Once I realize that, I revert back to my original save before going to sleep and play the game like normal, such as discovering things, upgrading my settlement, and doing side quest. Nothing I've done has 'resolved' or 'fixed' the Brewing Storm issue of the cutscene playing around going to bed at the start of the quest.

    I hope this helped.

  • maxxsinner
    33 posts


    • On PC
    • "In Dream's" quest was not offered when I upgraded the Seer's tent. Was a quick cut scene with no quest added to my list.
    • Cannot talk to Valka even if I go back to an old save before the Cent quest
    • After completing "Pledge to Cent" and resting in bed, Dag becomes combative but is unable to be killed.
    • Support ticket was unable to be submitted as the 'submit my ticket' via chat button was grayed out even though I was logged in and submit via email button disappears when Gameplay/Achievement or Trophy missing options are selected (this doesn't come as a huge shock by at this point.....)

    I assume that the support teams are flooded with submissions at the moment. Guess that is the result of selling a broken game.

  • OakString250667
    1 posts

    I hope to see the glitch for the mission a storm brewing fixed soon I can't continue to play story been forced to play other games on a count of it

  • Xehanor
    1 posts

    I can't complete this mission which has a bug. Dag is under control, he doesn't want to talk (he's supposed to be waiting to talk) and is aggressive with everyone, I killed him like 20 times, but every time he wakes up again and again, how can I fix this?

  • randpsv
    1 posts

    @grandmasternort Still having the exact same thing on ps4. Also I did all the updates to the game

  • Bloodyvampie
    11 posts


    I'm running into some trouble with this quest as well. Was able to complete it but got some settlement glitches as reward afterwards:


    Playing om Series X. No Valka issues, all done before this mission. Not sure about Jotunheim though...

    Would be great if you could look into my thread as well!

  • monaali791
    4 posts


    I am on PS4, Valka did not appear when I reached level 3, now I am level 5 in the settlement, still, she didn't appear.

    When activating a brewing storm, nothing happens after I wake up, and I cannot speak to any NPC nor fast travel.

  • guest-PrOUC62F
    1 posts

    i'm playing on ps4 pro. version 1.04 - version 1.10 as well.

    my town is level 5. i can't talk with valka, never went to asgard. never done the quest a man best friend. after the report of cent, in the quest brewing storm, i must go to bed. no cut scene, next scene i'm near the bed, outside is raining, dag is hostile vs me and vs the clan. game breaking.

  • Lumbi12
    1 posts

    Playing on PS4.
    No cutscene with Dag after sleeping.
    Valka never arrived „official“ with a quest in my town. I can find her by her house, but not speak to her. (Town level 4)

    Update to 1.1 don‘t fix it.

Suggested Topics