Welcome to discussions

Quick Suggestions

  • Ubi-Baron
    Ubisoft Support Staff 789 posts

    @Hazardous2Fish @Momma_loves_me Thank you for letting us know.

    This has been passed on to the team, as we have had other reports of this occurring.

    Official Response
  • Kaihlos787
    4 posts

    @ubikoality yes I have tried everything and still ends up with Eivor not moving just the camera and now it saved automatically in the start of the mission so now when I load the game I can't do anything its starts like that and cant progress!

  • Maltanoro
    1 posts

    This is on xbox one.
    I am not Even able to start the Lunden arc.
    I pledge to Lunden, go there and get to the gate. The screen turns black and the loading icon appears in the corner. It loads for quite a while and then I'm back in the game world, but I can't move Eivor. Every thing Else seems to be okay, NPC's are moving around and taking etc, but I can't move. When i press the pause button, I only get the choice to returen to game or quit to menu.

    Seems like the game is trying to load a cutscene, but then fails in some way.

  • guest-cV0qS9GG
    7 posts

    same here on ps4

  • maxmzd
    3 posts

    Same here on Xbox. Completed all other available territories so I'm now totally stuck. Game over for me.

  • maxmzd
    3 posts

    @ubi-baron thank you for looking into this. This is a critical game breaking bug. I've completed all other territories and can't continue with the story. Game over for now.

  • maxmzd
    3 posts

    @ubi-baron I've been seeing lots of people report this bug here and on Reddit. It's a total dead end for me, so hoping a fix comes soon.

  • WillMurderface
    1 posts

    Traveling to Lunden and meeting Stowe at the gates with the "Travel To Lunden" mission active results in the game locking up. A cutscene fails to load, sounds of combat are heard, then the player is frozen in place watching NPCs go about their business.
    I'm playing on PS4. The right analog still moves the camera, and Options still brings up the pause menu but the rest of the controls are locked.

    I didn't know what was the problem until loading an earlier save and changing my pledge.

  • Momma_loves_me
    3 posts

    @maxmzd i'm in the same spot, it's all i have left and it sucks I can't complete it atm

  • Steven52910
    1 posts

    I’m playing the game making my way towards Lundon and when I arrived it starts to autosave and go black like usual when a cutscene is about to begin, but then the screen just kinda goes back to how the last scene was and I’m not able to do anything except move the camera angle. I can’t move, use my weapons, go to the menu to fast travel, nothing. I’ve tried repeatedly to close out of the game and playing again. Sometimes even to a part before I arrived in Lundon, or at least a dozen meters away from the entrance. I’ve also tried dropping in from above to see if that would help. It didn’t.
    look on Reddit and you’ll see others are having the same issue.

  • not.mine
    2 posts

    I had a chat with a support guy and what has helped me was to rebuild the PlayStations internal database.

    To do so, shut down the PlayStation, hold the Power Button for ~7 seconds until the System beeps a second time and than connect a controller via USB cable and select rebuild the database (hope it is called so in English).

    After that I was able to access/start the mission.

    I don't know if this option might also exist on Xbox.

  • Geastahpo
    1 posts

    When arriving in Lunden for the first time through the north gate the game kind of freezes. A cutscene is supposed to happen but after the loading screen I go back into the game world but Eivor is frozen.

    The weird thing is that my girfriend encountered the same issue on her, turned off the game and after loading the latest save the cutscene just triggered by itself and all was good, I had no such luck.

    This is happening on base PS4 by the way.

    I've tried reinstalling the game, load from different saves, go to the gate from different angles, always the same result.

    I still have other territories to explore with the main questline so I keep busy outside Lunden, but I'm afraid I won't be able to finish the game if this issue isn't adressed.

  • Cidney_Dessel
    1 posts

    Having exactly the same issues on PS4, walk up to the entrance from the north side, goes to a loading screen, come back an I'm just stuck on place. I can move the camera around an that's all

  • guest-0jz0QWKS
    2 posts

    Travel to Lunden objective is bugged, everytime I attempt to start this mission Eivor is stuck in place after a loading screen. I can rotate camera and quit to title screen that's it. Tried reloading saves, entering multiple ways, not using fast travel to get there, doing other quests in between and returning but the exact same bug continues. Incredibly frustrating for a game that costs so much. Amongst other bugs however this one means I cannot progress the story.


  • Mcnilty
    3 posts

    @geastahpo I am having the same issue but on ps5. Tried reloading the last save point several times and even restarting the game, but no luck

  • InSAinThumAN
    1 posts

    Many thanks not.mine it worked like a charm, hopefully it might even sort Reda mission😁

  • Gikka218
    6 posts
    This post is deleted!
  • Gikka218
    6 posts

    I'm having the same issue on PS5. I had also gotten the viewpoints and some of the wealth/mysteries/artifacts before pledging and starting the quest. I've tried approaching from different angles, restarting the game, etc. but Eivor just ends up frozen.

  • Gikka218
    6 posts

    I'm having the same issue on PS5. I've tried rebuilding the database, approaching from different angles, restarting the game, etc. but Eivor still ends up frozen.

  • broadbentski14
    2 posts

    I'm having the same issue on a PS4, I've approached from all different angles, meditated to morning/night etc to try and prompt something but no matter what I've tried, everytime I approach the gate it will load as if it's going to progress, then load a frozen Eivor where my only option is to move camera or quit the game.
    Extremely frustrating, any advice Ubisoft?

Suggested Topics