Welcome to discussions

Quick Suggestions

  • longjohn119
    538 posts

    @tyranusvader I haven't had the game installed on my computer in months because I needed the space to play games that actually work (plus modding games takes up a lot of space) ... I haven't tried to set up Special K although I probably could get it working with Valhalla because there are still a ton of other issues that need to be addressed (Autosave/save bugs and Aim Assist) that I need to confirm are actually fixed before I waste any time on it ..... I'm just glad I got my copy through an AMD promotion last July rather than actually shelled out my own money for it .....

    After the RDR2 PC debacle (It took 3 months before it was playable for me) I decided I wasn't going to waste my time on a buggy game ever again and will just wait until it's confirmed to be fixed .....

  • TyranusVader
    102 posts

    @longjohn119 I don't blame you.

    Sign of the times

  • Kormac67
    613 posts

    @tyranusvader Tried it and without the overlay I'm getting way better frame rates.
    Makes me angry to think I played the whole DLC with that garbage on.
    Thank you for the hint!

  • TyranusVader
    102 posts

    @kormac67 Glad to hear!

    I didn't think it was as simple a fix as that!

    Achievements still work btw, you just won't see the notifications.

    Hopefully a moderator will forward this news to the tech team.

    Skal!

  • longjohn119
    538 posts

    @tyranusvader The overlay is part of the Ubisoft Connect app and it's been a steaming pile since it's release ..... Currently it is causing crashing issues for many people in AC Odyssey too and I'm guessing there was an update to it a couple of weeks ago because Odyssey hasn't had an update in months

    I have long suspected it is a major cause of the "unable to proceed ...." save bugs that has plagued this game since release and also the crashing problems that seem to happen at the exact same time an autosave is made to the cloud via the Connect App ..... There is simply bad code in the Connect App, Valhalla or most likely both and no one at Ubisoft seems to have a clue as to how to fix it

  • TyranusVader
    102 posts

    @longjohn119 ironically, uPlay was more functional than Connect.

    uPlay never gave me issues such as the ones Connect seems to be having.

  • CrimsonWolf-YT
    29 posts

    @tyranusvader It doesn't work. Overlay is here since beginning so that aint the problem. Problem is low cpu utilization.

  • TyranusVader
    102 posts

    @sirwoldrenyt ideally, you're supposed to have low cpu utilization and high GPU utilization.

    Having a high CPU utilization implies that a bottleneck is occurring.

    What's your cpu and gpu?

  • longjohn119
    538 posts
    @tyranusvader It doesn't work. Overlay is here since beginning so that aint the problem. Problem is low cpu utilization.

    Not really .... The problem is poor asset streaming between the CPU and VRAM ..... The CPU can only work as hard as the information going to it allows .....

    The bottleneck isn't the CPU or the GPU but the memory transfer between system RAM and VRAM or from disk to VRAM and has to do with how the PCIe buss is utilized

    As you move through a world in a game, GPU memory (VRAM) constantly transfers textures, shaders and geometry (asset streaming) via many small CPU to GPU transfers basically in 256 MB chunks ..... With PCIe 4.0 ** if properly implemented *** that chunk size can be increased to where the CPU essentially has direct access to all of VRAM at once theoretically (In practice that doesn't happen but the chuck size is increased to the GBs) ..... However Ubisoft botched something when they tried to implement it in the game engine core and it affects all systems and seems to affect Intel CPUs more than AMD CPUs ,,,,,

  • T1GFX
    33 posts

    A good portion of users will be happy because someone has finally made a fix that makes the game use full CPU power.

    https://www.pcgamingwiki.com/wiki/Assassin%27s_Creed_Valhalla#CPU_utilization_fix

    Now it would be great if ubisoft "developers" implemented an official fix...

  • TyranusVader
    102 posts

    @t1gfx I never had CPU issues with the game and now I know why. I have a Ryzen 7 3700X which had 16 threads.

  • longjohn119
    538 posts
    A good portion of users will be happy because someone has finally made a fix that makes the game use full CPU power.

    https://www.pcgamingwiki.com/wiki/Assassin%27s_Creed_Valhalla#CPU_utilization_fix

    Now it would be great if ubisoft "developers" implemented an official fix...


    Never ever download an unverified DLL ..... It's just asking to be hacked ..... XInput9_1_0.dll is very commonly substituted by Malware to infect a system and get around anti-virus by masquerading as a legit Windows system file ......

    Unless it comes from an official Microsoft server I sure wouldn't trust it ......

    I seriously doubt a DLL for a gamepads is causing this problem

  • T1GFX
    33 posts

    @longjohn119 You sir really are one of a kind. Seems the computer basics class for seniors didn't pay off. As a matter of fact, you are getting hAcKeD right now because you installed a heap of Skyrim mods a year ago. I'm not even going to bother with the rest of your nonsense. Take it or leave it 🤡

  • longjohn119
    538 posts
    @longjohn119 You sir really are one of a kind. Seems the computer basics class for seniors didn't pay off. As a matter of fact, you are getting hAcKeD right now because you installed a heap of Skyrim mods a year ago. I'm not even going to bother with the rest of your nonsense. Take it or leave it 🤡


    I worked for a major computer manufacturer back in 1988-1992 ..... Other than laptops I have never bought a pre-built x86 computer ..... I got my BSEE in 1993 and my MSEE in 2000 ... I built my first computer an Altair 8800 in 1976-77 from a partial kit and got most of the parts as "floor sweepings" from IBM where my Uncle was a prototype engineer for 15 years

    Skyrim mods aren't hackable ..... Texture mods are not hackable system files .... DLLs are core system files and one of the main ways malware and viruses are installed on computers ... The last time I had a successful virus or malware infection Bill Clinton was President

    There are basically 2 official XInput9_1_0.dll files available from Microsoft .... one is 9kb and the other is 11 kb ..... The one you pointed to was 18 kb so it's obviously had code added to it and you can do a lot of damage with 7 kb - 9 kb of Assembly code

  • CrimsonWolf-YT
    29 posts

    @tyranusvader Look, gpu and cpu are around 50% all the time.
    My cpu is weak for the gpu i have. Like the title says, with my conf i had much higer fps before 1.1.0.
    After that very low, same settings.
    In raids i had around 40,now 30fps and less.
    Cpu was arounx 50 60, but gpu was always 99%
    And temp was higher then it is now.
    Its like my gpu(ours gpus, not just mine, cuz there are people on this threas that have same problem) aint even trying to work.

  • TyranusVader
    102 posts

    @sirwoldrenyt what's your CPU?

  • CrimsonWolf-YT
    29 posts

    @tyranusvader i54460 gtx 1060 6gb
    On medium and textures high i had solid 40-70fps
    40 in cities and raides, and up to 70 in forests and open fields.
    I have video dating before 1.1.0 patch it is linked somewherw here but its old post.
    Someguy here mentioned why its happening, its due to threadings.
    And he mentioned whole list of affected cpus. Mine is in the list.

  • CrimsonWolf-YT
    29 posts

    @t1gfx @Tyrandium this post I mean

  • TyranusVader
    102 posts

    @sirwoldrenyt A quad core, quad thread CPU. Still a somewhat decent one for gaming.

  • RitzPaul94
    20 posts

    still no fix....gg ubisoft

Suggested Topics

Community Details

58
Online
138.4k
Users
24.2k
Topics
125.5k
Posts