Welcome to discussions

Quick Suggestions

  • UNSOLVED [PC] After TU 1.1.0, I am experiencing FPS drops / low CPU and GPU utilisation | POST HERE

    64 Likes/1308 Replies/44772 Views
    Surtr-Destroyer
    45 posts

    @longjohn119 Yea, my cpu is now around 90% and gpu consistently 95-100
    I have i54460 and gtx 1060 its back to how it was before 1.1.0

  • petek
    87 posts

    @longjohn119 hi noticed slight improvement FPS wise even before the patch - still often stuttering /slow downs in fights etc... Thanks

  • dodokjv
    22 posts

    I cant believe they really fix this!! I can now play at almost 60 fps instead of 30 like before. On my poor 1060 3GB. The only issue I have is with huge spikes and fps drops but when i play offline its good. Finally!
    Now im an idiot and will probably give ubisoft more money for season pass dlcs and far cry 6...

  • Surtr-Destroyer
    45 posts

    @petek How much fps u had before 1.1.0?
    Cuz for me it worked 🙂
    Ur gpu is maxed.

  • petek
    87 posts

    @surtr-destroyer Hiya - it was more that I had a stable 50-60 FPS with no slow downs even is assaults and other AI heavy situations. Although FPS is better in benchmark still crawls to single digits in some fights.... I have to admit I've kind of given up.... Thanks

  • Surtr-Destroyer
    45 posts

    @petek yes, i know. I have unstable game aswell but at least its 60+fps and not 30 hahaha but its not always unstable. It's usually first time I ran the game in the day its unstable.

  • petek
    87 posts

    @surtr-destroyer Hiya - for me it's most fights (and also pretty random!) Just pisses me off that it worked fine before the patch. Ubisoft really don't seem to go with the "if it ain't broke don't fix it" on this game (mounted combat, transmog etc..) Cheers

  • Ubi-Borealis
    Ubisoft Support Staff 4569 posts

    Hello there,

    I apologise for the delayed response. Thank you for continuing to share your reports regarding FPS drops and low CPU / GPU utilisation within this thread. I'm glad to hear that this issue has been alleviated for a number of you following the release of TU 1.4.0! 😄

    If you are still experiencing FPS drops and low CPU / GPU utilisation after the release of TU 1.4.0, I'd like to reassure you that the development team are still investigating this issue further. To assist with the ongoing investigation, if you have not already, please can you provide us with the following information:

    • A screenshot of your graphical settings in-game
    • A video that demonstrates the FPS drop you're encountering in-game. Additionally, please can you show the usage percentage of your GPU and CPU while running the benchmark on the settings that you are using


    I'd recommend uploading this video to a sharing platform, such as YouTube or Google Drive, as this will allow you to post a shareable link within this thread. Once you have provided us with this information, we will also open up a support ticket for you so we can collect a copy of your system's DxDiag. This system file will be helpful for further investigation.

    Thanks! 😊

    Official Response

Suggested Topics