Welcome to discussions

Quick Suggestions

  • Avelius666
    2 posts

    Me to

    SPECS:
    i5-7600K CPU @ 3.80GHz (4 CPUs)
    GeForce RTX 2060 SUPER 8GB
    RAM - DDR4 - 16GB
    Nvidia driver 460.79
    Windows 10 64 BIT

    Game settings - very high

    FPS drops ~ from 50-65 to 32-40 (especially in villages and towns)

    undefined

  • ryankwaker
    38 posts

    @UbiKoreanBBQ
    how long it takes to fix this framedrop bug? Mine is gtx 1070 and i5 7400 and 16 gb ram and the game fps goes 60 for the most and drops severely around 33 to 38, and 27 for the lowest when raiding and going to towns.......and the setting is in high....
    By the way, Korean bbq is my favorite one!!!

  • MeowNuts
    9 posts

    I dont want to spoil the gaming experience. So I have to wait for Valhalla to patch. I have to wait for Cyberpunk to get patched.

    What is wrong with these AAA developers? We paid full price for a half working game then wait to get patched. People always say support the dev, support the company. But you get half finished mess in return while the bosses laugh to the bank and customers wait for the product to get fixed.

    I recommend BBB for Ubisoft and CD Projekt Red. And they are not getting my money next time.

  • ryankwaker
    38 posts
    This post is deleted!
  • ryankwaker
    38 posts

    @ryankwaker @UbiKoreanBBQ if possible, can you tell us specific date of when this will be fixed?

  • davis8537ac
    2 posts

    Same problem here, at least let us downgrade to patch 1.0.4 while we wait for a fix pls.

  • RyanHalevyX
    10 posts

    @UbiKoreanBBQ

    Same issue here. I'd run at a steady 60fps before the patch, now I'm tanking at 40fps. Sometimes it goes as low as 20-ish. I updated the game at the same time the 460.89 NVIDIA drivers released. But that was a very minor and specific update to Quake II and some AMD GPU users are also getting the FPS drops so I'm fairly certain it has something to do with the 1.1.0 patch.
    undefined

  • Zarael1721
    95 posts

    @ryankwaker

    I would like to know the date too or at least get assure that they plan do something with it and make for us the game playable again... Hope the company is better than Blizzard in comunication with customers...

  • ryankwaker
    38 posts
  • T1GFX
    34 posts

    Everyone on Intel is experiencing this. Performance overlay shows that videocard and cpu cores aren't being fully used and there is literally no workaround. How it's gone unnoticed by any higher-up here is unbelievable. Knowing they have holidays it probably will stay like this until after the first timed seasonal event ends. Can't even rollback to the previous version of the game which was unironically much more stable than this performance hogging "update".

  • CrimsonWolf-YT
    31 posts

    @t1gfx Guess I'm going to die then. With my i54450 gtx1060 and 8 gb ram I ran this game on low-med-hig settings on 40 to 70 fps 45 in towns...raids same....now just 30 in raids ope field 50 lol It is stupid how this game is unplayable now. I mean i played on worse fps. But the thing that I played it more smoothly then, that bugs me..

  • KebabTom71
    1 posts

    @ubikobold
    Thanks for picking this up - really appreciate it!
    I'm having the same issues. I've opened a support case 13608979
    https://support.ubisoft.com/en-US/Cases/13608979

  • Javier_Pazdan
    7 posts

    I am useing GTX 1070 from MSI. I have notice that I lose fps when I install new drivers for graphic. I have install old drivers like 442.59 and game is working good.

  • CrimsonWolf-YT
    31 posts

    Yes same for me.
    Before patch I could run game in 40-50 in raids on med-high settings. As well in towns and cities.
    Now I run it on 30 fps in raids and in towns same. Much poor performances.
    Here is video of me playing ACValhalla before patch on Medium high Settings, AA low. Bear in mind that i dont have stutters. In video stutters are due to handbrake software



  • PatrykGrzech
    6 posts

    I can confirm. frame drop after latest update is significant... 😞

  • rj2396
    3 posts

    Same here, Im running on an RTX 2080Ti and i7 8700... Installed the game on an SSD also... my fps was around 70 to 90 @1440p Ultra at patch 1.0.4 but lately it goes down into 40 to 55... undefinedundefined

  • Peterfogaren
    4 posts

    Yeah what a joke this is. Same issus for me after the patch. [censored] Ubisoft! Fix it!!

    i5 6600k
    geforce gtx 1070
    16 gig ram
    SSD disk

  • Peterfogaren
    4 posts

    UPDATE

    Might have found a fix to the problem; in Ubisoft launcher select Assassins Creed Vallhalla in "games", then select "properties". After that look for "local files" and select "open folder", click it and look for "ACVallhalla_plus", right click and select "run as administer" . My game runs much smoother now. Hope it helps. 🙂

  • guvenerturk
    13 posts

    @peterfogaren it does not work

  • peterlaub
    Original poster 61 posts


    I tried it too. Unfortunately, it did not work for me either.

Suggested Topics

Community Details

130
Online
140.7k
Users
24.8k
Topics
128.6k
Posts