Welcome to discussions

Quick Suggestions

  • Zarael1721
    96 posts

    @ryankwaker

    I would like to know the date too or at least get assure that they plan do something with it and make for us the game playable again... Hope the company is better than Blizzard in comunication with customers...

  • ryankwaker
    38 posts
  • T1GFX
    38 posts

    Everyone on Intel is experiencing this. Performance overlay shows that videocard and cpu cores aren't being fully used and there is literally no workaround. How it's gone unnoticed by any higher-up here is unbelievable. Knowing they have holidays it probably will stay like this until after the first timed seasonal event ends. Can't even rollback to the previous version of the game which was unironically much more stable than this performance hogging "update".

  • CrimsonWolf-YT
    40 posts

    @t1gfx Guess I'm going to die then. With my i54450 gtx1060 and 8 gb ram I ran this game on low-med-hig settings on 40 to 70 fps 45 in towns...raids same....now just 30 in raids ope field 50 lol It is stupid how this game is unplayable now. I mean i played on worse fps. But the thing that I played it more smoothly then, that bugs me..

  • KebabTom71
    1 posts

    @ubikobold
    Thanks for picking this up - really appreciate it!
    I'm having the same issues. I've opened a support case 13608979
    https://support.ubisoft.com/en-US/Cases/13608979

  • Javier_Pazdan
    7 posts

    I am useing GTX 1070 from MSI. I have notice that I lose fps when I install new drivers for graphic. I have install old drivers like 442.59 and game is working good.

  • CrimsonWolf-YT
    40 posts

    Yes same for me.
    Before patch I could run game in 40-50 in raids on med-high settings. As well in towns and cities.
    Now I run it on 30 fps in raids and in towns same. Much poor performances.
    Here is video of me playing ACValhalla before patch on Medium high Settings, AA low. Bear in mind that i dont have stutters. In video stutters are due to handbrake software



  • PatrykGrzech
    6 posts

    I can confirm. frame drop after latest update is significant... 😞

  • rj2396
    3 posts

    Same here, Im running on an RTX 2080Ti and i7 8700... Installed the game on an SSD also... my fps was around 70 to 90 @1440p Ultra at patch 1.0.4 but lately it goes down into 40 to 55... undefinedundefined

  • Peterfogaren
    4 posts

    Yeah what a joke this is. Same issus for me after the patch. [censored] Ubisoft! Fix it!!

    i5 6600k
    geforce gtx 1070
    16 gig ram
    SSD disk

  • Peterfogaren
    4 posts

    UPDATE

    Might have found a fix to the problem; in Ubisoft launcher select Assassins Creed Vallhalla in "games", then select "properties". After that look for "local files" and select "open folder", click it and look for "ACVallhalla_plus", right click and select "run as administer" . My game runs much smoother now. Hope it helps. 🙂

  • guvenerturk
    13 posts

    @peterfogaren it does not work

  • peterlaub
    Original poster 66 posts


    I tried it too. Unfortunately, it did not work for me either.

  • ryankwaker
    38 posts

    Please fix this fps drop 😔
    And next patch, just don't touch anything about graphical improvement matter for this game unless there will be a ps6 coming out or something so you are making that version of the game. It is already beautiful enough!!!

  • Nebula_XIII
    1 posts

    Same exact problem. The game is very difficult to play now and my gpu and cpu aren't even trying.

  • CrimsonWolf-YT
    40 posts

    @peterfogaren tried, didn't get fps boost.
    In fornburg had min 42 fps now drops to 30

  • Hunterr12
    30 posts

    Happening to me as well. Used to be very stable but now getting drops by 20fps or more.
    i7 7700k
    2080 ti
    32gb ram
    All drivers up to date

  • MeowNuts
    9 posts
    Knowing they have holidays it probably will stay like this until after the first timed seasonal event ends.


    Thank you Ubisoft. Hope you enjoy the holiday and sleep well at night after ruining the game for everyone right before Christmas. We paid for the game, waited for 2 patches and still cant play the game properly. I dont know what to say. Feels like a hard slap to my face as a customer. This the last time i buy your games [censored].

  • Zarael1721
    96 posts

    @meownuts Disgusting is that they did even let patch like that going out untested because thats not whats happenning only to few people but to big part of comunity using Intel CPU... its already more than two days out like that game is unplayable and any hot fix ... thats just sad and very disapointing

  • Cub1008
    5 posts

    Same for me, Was playing at around 88 fps before in non crowded areas and now hardly get 55 fps or in more crowded areas i was running 60 fps now i get a measly 30 undefined

Suggested Topics

Community Details

51
Online
192.8k
Users
32.5k
Topics
162.6k
Posts