Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • diegogamer97
    9 posts

    Guys, I finally solved the problem. The game is fully playable in 60 fps again! Basically, I just needed to make a clean installation of my driver from Nvidia, then I needed to execute cmd.exe with the function "sfc /scannow". https://support.microsoft.com/pt-br/help/929833/use-the-system-file-checker-tool-to-repair-missing-or-corrupted-system. Thank you guys for the help, have good games! o/

  • RedIndianRobin
    186 posts

    @diegogamer97 I literally said downgrade the drivers, if only you read them earlier.

  • DeltaSnipezor
    6 posts

    @redindianrobin tried that my man.

    Still having the same fps drops 30-40minutes into the game.

  • DeltaSnipezor
    6 posts

    Be good to have it at least acknowledged by support...

  • RedIndianRobin
    186 posts

    @deltasnipezor Nope nothing gets acknowledged here in Ubisoft lol

  • Arabianhorse69
    1 posts

    Same issue here I have a 2070 Super and 10th gen i7 and can't achieve a consistent 30fps on high settings.....

  • jandraelune
    117 posts

    Ryzen 5 3600 and GTX 980 with 32gb ram. Not a single slow down from 1080p/30 with everything set low, really no need for all the eye candy. The CPU is only 26% used at most and the GPU gets 40% when playing, it does slow down ONLY when hitting > esc < and going to the menu where the GPU spikes to 85% use for no reason at all.

  • TemoshGangPower
    5 posts

    Hello.
    When you will fix this terrible fps drops after ~1 hour playing? Helping only game restart! Its looks like a classic memory leak issue, check your own forum or reddit for similliar threads. This problem going from the release and make the game unplayable! How many we must wait until devs do something? Or we must suffer for our money?

  • v01d_inc
    1 posts

    @temoshgangpower

    Same here. Playing on Geforcenow. This is disgusting. I could play Odyssey Ultra settings 1080p with breathtaking graphics but can’t even play valhalla in 720p medium.

    The game as potential but it’s so broken. Don’t you guys have testers? How could it not get flagged by QA?

    #BrokenGame #TakeYourTimeToFix

  • omniaaa
    1 posts

    Same thing for me. After one hour the game is unplayable on GeforceNow. Saving and reloading from the main menu fixes it temporarily, but does not always work.

  • Rectdageimar
    4 posts

    Same here, it starts stuttering after like 30 mins, and after 1 hour is unplayable.

  • TemoshGangPower
    5 posts

    Ubisoft, maybe you try to cooperate with Nvidia to resolve this problem? Many users are experiencing issue what ruin all pleasure of the game! 

    Don't you give a damn about us?
    😠 😠 😠

  • UbiKobold
    Ubisoft Support Staff 415 posts

    Hey there fellow gamers, and thank you for your patience! I am very sorry that all of you have been experiencing FPS drops after about an hour of gameplay! I have a few questions and some steps to try, if you all wouldn't mind taking a look!

    1. Are you using GeForce Now?
    2. Have you tried verifying your game files?
    3. If not tried yet, please try our steps here.
    4. Can you provide a video of this occurring from your gameplay? If so, post to YouTube as unlisted and then send the link here.


    Official Response
  • TemoshGangPower
    5 posts

    @ubikobold
    Yes, we using Geforce Now. Therefore we can't verify our game files.

    Here's a link on my gameplay with fps drops proof -

  • se7enX89X
    5 posts

    @diegogamer97 I have a 3080 and the game ran fine up until today. Now I get 33 fps. Its laughable but sadly its typical Ubisoft.

  • TemoshGangPower
    5 posts

    So, whats next? Are you confirm this problem? Can we expect a fix soon?

  • dgeynisman
    1 posts

    @ubikobold Hi, thank you for your reply. Apart from the gameplay recording, is there anything else you might need to troubleshoot the issue? I can spare an hour collecting whatever you need for troubleshooting. I play the PC version, and the game used to work fine before the patch 1.0.4, but now I get constant frame drops, I tried:

    • Verifying game files
    • Installing the game to another SSD disk
    • Re-installing the latest GeForce driver 457.50
    • Updating Windows 10 to 20H2, installing all updates
    • Setting the graphics card settings to default
    • Setting the graphics settings to default
    • Doing a "clean" Windows boot
    • Playing with keyboard/mouse instead of a controller (Xbox One controller via Bluetooth sometimes causes some imput lags).


    I also checked other games, including Ubisoft's Far Cry 5, they all run flawlessly, but not Valhalla 😞 Tonight, I will install the new graphics driver 457.50 and record a video. However, I am totally sure that the problem is not in my PC, and please let me know what information might help your team to investigate this issue. Thank you in advance.

  • YazX_
    139 posts
    @diegogamer97 I have a 3080 and the game ran fine up until today. Now I get 33 fps. Its laughable but sadly its typical Ubisoft.


    i believe your GPU is not working on the frequency that it should, check GPU usage and frequency in game, sometimes GPU frequency gets stuck on low especially if you have power mode set to adaptive in NCP, i had this problem on my old build where whenever i wake my PC from sleep, GPU starts with low frequency and sometimes gets stuck on that frequency until i restart.

  • Amothan1800
    1 posts

    @ubikobold

    Hi have the same issue like the other guys....

  • QuaWua232
    2 posts

    Hello,
    I have some three solutions that might help:

    1. Disable fullscreen optimalization (in compatibility tab)
    2. Disable Windows Game bar
    3. Launch ACValhalla_Plus.exe (instead of the normal one)


    Good luck with that and I hope some of these will work for you.

Suggested topics

Community details

9
Online
124.0k
Users
21.3k
Topics
110.0k
Posts