Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Yesin069
    460 posts

    @strelats

    Short answer...NO! Performance is exactly the same as before...

  • SoberStone999
    52 posts

    @yesin069 For me it's even worse, I was at 50 fps to 30 before patch, now it's 20 fps right from the start. I guess I won't touch the game for another month then!

  • Yesin069
    460 posts

    @soberstone999

    I have between 40 and 80 fps in Valhalla, which isnt good at all when compared to RDR2 which i played with at least 60 fps at all times and which looks better than Valhalla and more detailed.

    I cant understand why Valhalla sometimes falls under 50 fps and i am also not at max settings and play in 1080p. This game is no visual masterpiece and lacks pretty much details (like proper cloth physics with proper fps for everything).

    Even with G-Sync i notice dips when the fps fall under 60 and this is why i always want at least 60 fps. I think about capping Valhalla to 60 fps but i got used to around 70 fps which feels so smooth. Even 60 fps feel a bit jarring now to me...
    This was possible with all modern games i played before, so i cant understand why Valhalla is so demanding. There are no complex physics or NPC routines running in the background like in RDR2 which has the best AI i seen since MGS5.

  • SoberStone999
    52 posts

    @yesin069 agree, game sucks even at being average.

  • mueenahmad786
    13 posts

    Can someone please benchmark game with new update 1.2 and check if CPU Utilization is still stuck to 50% Usage or not? Can someone please confirm this please?

  • mueenahmad786
    13 posts
    This post is deleted!
  • T1GFX
    29 posts

    @mueenahmad786 Still the same. Nothing will change because the support team doesn't want to do anything even after us providing all the information to solving the problem. Only solution is to have somehow backed up the 1.0.4 files on a disk drive and using those files to play the game, as it's the only version where the CPU% is properly distributed and utilized.

  • Kormac67
    497 posts

    Still the same, random after each fasttravel.
    River raids work fine so far (like before).

  • ruanseth
    23 posts

    @mueenahmad786
    It's the same as before, so stuck at around 50%.

    Everyone needs to accept this now WILL NOT change. Those of us on weaker CPU's and who were getting very good performance prior to 1.1.0, wth decent CPU utilization will not be catered for. The only way to get good FPS is to brute force via upgrading... or buy a next gen console, if you can find one.

    Low CPU utilization may be fine with a decent GPU in areas with little AI, but as soon as you enter big battles, or just populated areas, your frame rates will tank.

    Accept it and carry on playing, or give up.... There are no other options.

  • stoyandanov
    11 posts

    Just raised a ticket #14307565 with the following content:

    Hello,

    I'm one of many customers experiencing huge FPS drops for no reason. Start benchmark for the first time - ok with 60 fps, then restart benchmark and it runs with 15 fps with 20% CPU load. This happens all the time during game play as well.

    Please do a refund of my purchase,even that I'm out of refund period, because this game is unplayable for me and a lot of other people:
    https://discussions.ubisoft.com/topic/88876/pc-after-tu-1-1-0-i-am-experiencing-fps-drops-low-cpu-and-gpu-utilisation

    Now when I see no solution to my issue after 1.2.0, I no longer want to wait any further. I believe you have all needed information and stats to see that I have waited 3 months to be able to play, spending my hours in the game mostly for benchmarks and waiting, playing meanwhile origins and odyssey with no issues.

    I really don't have the spare time to give more details about the issue, as I see a forum topic with 873 Replies / 24777 Views, providing screenshots, msinfo, dxdiag.,etc. and ignored for three months.




  • stoyandanov
    11 posts

    For the record I have played (running benchmarks and changing settings) for 2 hours and 39 minutes, which is slightly more than the 2 hours refund policy.
    Meanwhile having 137h in Origins and 76 in Odyssey.

  • Kormac67
    497 posts
    It is not a topic we are ignoring, and I'd like to reassure you that everyone involved is doing what they can to identify the cause of these issues and improve performance on PC.

    @UbiUseless - so, what are the devs doing? Designing a new exciting feature nobody asked for like downgrading items? Populating England with more cats?

  • peterlaub
    Original poster 61 posts

    @kormac67 Bunch of Scammers! I've had enough, I am done.

  • stoyandanov
    11 posts

    They just hit me with a template answer by an anonymous Ubi-OneX employee in the ticket. Asking me to record video of the problem, screenshots, etc. - all that is already here in the forum by a lot of people.
    It is just my bad, waiting and hoping they will fix something that was not broken initially. So if you buy Ubi games, do it on Steam, and refund as soon, as there is an issue, do not hope, do not ask, just refund. If they fix the problem, you can purchase again.

  • Snt.Grem
    23 posts

    Stop humiliating yourself guys. These scammers just pulled money from you and that's it. 4 months have passed, 3 large patches of 15 GB each, can't you see that these clowns are not capable of anything? Nobody reads your messages. They come in every 2 months and pretend that they are aware of the problem. Just forget that bad experience, and never pay more to these idiots.

  • dodokjv
    21 posts

    This is the top unresolved thread in the player support and they still dont give a flying [censored] about this issue. I expect the mods to come back in a few days again and asking to create tickets, give them screenshots, videos, dxdiag and other [censored]. They will never fix this, that's for sure. They should just admit that and delete this thread. Everyone will pretend this is not an issue.

    I WILL NEVER BUY ANOTHER [censored] FROM UBISOFT, I HATE THEM!!!

  • Zarael1721
    95 posts

    I cant believe these scammers really ignoring us for such a long time guys... Took my money, did let me play 100 hours of awesome experience then messed up all performance and any response to that already 4 months? Sorry for saying that and i dont care if they bann me but i have to tell it... UBISOFT YOU ARE BOUNCH OF CU.NTS

  • RitzPaul94
    13 posts
    This post is deleted!
  • Yesin069
    460 posts

    I figured out some places where the performance mostly drops 100% to at least 40fps for me (I play mostly with between 60 and 75fps):

    • Every settlement in Norway (specifically Fornburg) - maybe the snow particles are too badly optimized and tank performance!
    • Eivor's settlement in England (specifically during events like Yule or Ostara)
    • Camps that look like caves and are surrounded by much water - those areas shouldn't be hard to run and drop always when looking at places where there also is water - maybe SSR is too heavy in this game but it isn't a problem in every other area, so it feels like those specific camps are just poorly optimized and need some more handwork


    I can't understand the drops under 60fps. Valhalla looks good but it shouldn't be that difficult to run it properly when settings are tweaked. It also would be great if Ubisoft brings back the settings they taken away from us since Origins and that are in the INI-files (like Globalk Illumination, Fog, Bloom, Tessellation, SSAO). Tessellation and SSAO should give us back some performance if they let us change those settings properly.

  • ruanseth
    23 posts

    @Yesin069 "Valhalla looks good but it shouldn't be that difficult to run it properly when settings are tweaked. It also would be great if Ubisoft brings back the settings they taken away from us since Origins and that are in the INI-files (like Globalk Illumination, Fog, Bloom, Tessellation, SSAO). Tessellation and SSAO should give us back some performance if they let us change those settings properly."


    These entries are all still there in the cfg, apart from GI and tweaking the values seems to make little, if any, difference on performance overall. The areas you mention, where the worst drops occur are all due, in the most part, to heavy AI load, rather than rendering load. Yes, the GPU is pushed more in these areas, often to 99%, but the CPU remains half dormant, and this seems to be the real reason performance is now so much worse than it was prior to 1.1.0....... Even dropping the all the settings to low does not recover the performance in heavy AI areas, as the CPU is just sitting there doing very little.

    No ammount of tweaking (I think I've tried everything) will solve it, so we either play as it is, or give up and move on the other games.

    Sadly, whatever they did in 1.1.0 will not be fixed... There is no true support here, just 'call center' bot type operatives, drafted in, who give the same response over and over, and if I'm wrong Ubi, prove it!

Suggested topics

Community details

20
Online
124.0k
Users
21.3k
Topics
110.0k
Posts