Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Yesin069
    460 posts

    @ruanseth

    I know that these can be tweaked but they seem to be broken and because of that not in the in-game menu. Tesselation seems to be bound to the world detail setting and changes with it. SSAO maybe with Shadows but I didn't test that one.

    I don't know why the AI is so taxing in this game. The AI is dumb as hell and has no complex patterns in it. No comparison to the AI from RDR2 or MGS5. The drops I mentioned above also happen when I killed everybody and look at specific places. This seems like optimisation issues in specific areas and not overall in the game.

    I don't seem to have lower than expected CPU usage so I don't know if I also have the same problem that most people here have. I also started playing with update 1.1.0 installed, so I can't compare it to before.

    For me I just see some specific areas that tank perfomance harder than everything else, without any reason. there is no complex AI or complex architecture. Just a whole in a mountain and some water...

  • dodokjv
    21 posts

    The game runs even worse for me after 1.2.0 update. Before I could maintain stable 30 fps without stutter, now it stutters all the [censored] time. I play on 1060 3gb so I really don't expect high fps and super stable performance, but before 1.2 I could enjoy the game and now it runs like [censored]. Thank you, [censored]!
    FIX YOUR [censored] GAME ALREADY!!!

  • mueenahmad786
    13 posts

    So CPU Utilization issue hasn't been fixed yet even after 4 updates?

    I'm truly Empressed, bravo Ubisoft. Very Empressive.

  • longjohn119
    421 posts

    @mueenahmad786 And this game is listed as 1 of 8 that are supposed to support Resizable Bar for Nvidia 3000 series graphics cards

    Yeah rightttt .......

  • dignite_
    5 posts

    So how do you do rollback? 4 [censored] months and still unplayable.

  • mueenahmad786
    13 posts

    @dignite_ Empressive Question. But unfortunately I will be banned again if I tell. So can't do. One thing I'm going to tell is that I'm really enjoying Valhalla at 70~90 FPS with Full CPU Utilization 90~100% on all cores with all settings maxed out except World Details which are @Medium. All other settings Clutter etc are at MAX. I'm truly in love with this game, I'm glad I got to see such beautiful game in my lifetime. It gives you Ezio Auditore Vibes if you play with male Eivor. Music by a legend Jesper Kyd, and yes SHAWN and REBECCA are BACK!! I'm in love with this game and it runs butter smooth on my intel processor core i5 2500K and GTX 1070 @1080p All Maxed Out Except World Details which need better processor. I'm s
    feeling sorry for all those suffering with COU Utilization issue, Sorry Ubisoft you created a masterpiece but you ruined its experience by your own hands but please fix it asap, some players are still waiting to play because they will get only one opportunity in their lifetime to finish the game for the first time!

  • STRELATS
    9 posts
    This post is deleted!
  • Yesin069
    460 posts

    I got fo Vinland and performance there is just horrible. This area really doesn't look that taxing and the NPC's are dumb as hell and always stay at their positions or walk the same routes even at night. Why this game runs so bad in specific areas, when it runs fine in others?

  • stoyandanov
    11 posts

    So are you guys telling us again that all FPS drops and performance issues are because of the DRM protection and those who paid for the game will not get support. But those who didn't will play without issues?
    Let's hope that as the DRM is not effective now, we will get this burden out of our hardware with the next patch.

  • Snt.Grem
    23 posts

    @stoyandanov, denuvo protection has nothing to do with it. The game from the moment of release until version 1.0.4 worked perfectly. The point is fraud and incompetent employees who could generally admit that such a crooked update would come out in a forced mode and without the possibility of rolling back to the working version. Of course, now they simply ignore their worthlessness, because this is just a megatred on their forum, which does not generate any publicity and does not underestimate the sales of the game. Just think 800+ messages and these are only those who believed and hoped. Only these scammers know how many people have actually suffered and for what amount.

  • dignite_
    5 posts

    @mueenahmad786 PM me if you don't want to reply here.

  • nnMaxnn
    1 posts

    I thought I would post this for future reference. I know this is not a fix for everyone. My FPS drops on my system were due to using Xbox One controller through Bluetooth wireless adapter. Once I plugged my controller in all my FPS issues went away. I went ahead a took it a step further and purchased Xbox wireless adapter for Windows 10. Updated the firmware. The game runs great now! No more massive FPS drops, stuttering and sound issues. I tested it out for good solid hour. Seems to be working perfectly fine now.

  • Mahluk.
    7 posts

    Has anyone tried Empress 1.1.2. Does the problem continue ?

  • ruanseth
    23 posts

    @mahluk
    I'm absolutley seeing quite an improvement with 1.2.1... CPU is still at around 50 - 60% but, the spread is even across my four cores, rather than two working hard and two almost idle. GPU seems pegged higher as well, staying at 99% almost all of the time.

    I am currently running at max settings @1080p on a very old i5-2500k (@4.4ghz) and a GTX1060 6GB with 16GB of RAM with perfectly playable frame rates (for me).... I still get drops in heavy AI areas, but as lowering visual settings makes little differance I may as well enjoy the game looking as best as it can.

    I did not see this consistency before this patch... it's almost a straight line ... I doubt it's the driver, but I'm also trying these nV dev drivers: Gameready 470.14's

    Hopefully we are getting somewhere.
    [img]https://imgur.com/lJXjPLP[/img]

    Sorry image links don't seem to work anymore.






  • ruanseth
    23 posts

    @mahluk

    BTW I deleted the two cache files, and the ACvalhalla cfg in 'C:\Users\*******\Documents\Assassin's Creed Valhalla'. Letting the cache rebuild, and resetting my graphics settings on first run.

  • longjohn119
    421 posts

    @nnmaxnn Window's Bluetooth implementation has always been sh---- ..... I'm always fighting to keep my Bluetooth controllers for my VR headset enabled and if I have my Xbox controller's wireless adapter plugged in they won't work at all ..... But I've had no problems with the Xbox controller wireless adapter in 3 years on two different systems nor can I sense any difference in lag between wireless and wired .... Even with my Windows Tablet and Panasonic Tough Pad I've always went with a keyboard with it's own dongle rather than use a bluetooth keyboard even though my Bluetooth keyboards work just fine on my Nexus 7 Android tablets ,,,,,

  • Smiley_ie
    5 posts

    Still getting same results

    undefined

  • KitK4t1987
    7 posts

    @ubi-orion any look on the last missions of the game in humtascire ones still can't complete the game as still not fixed 😞

  • BoladinhoDaZL
    10 posts
    This post is deleted!
  • BoladinhoDaZL
    10 posts

    Hello, I've been playing valhalla for over 40h - and I realized that every time I enter the game I have unstable and low fps, so when I go back to the home screen and enter the same save again my fps improves and stays stable, I also realized that if I teleport to norway and return to england the fps improves sharply too. but sometimes when teleporting over long distances my fps gets horrible again, someone suffering from the same problems? would it be some kind of memory leak? sorry for my English.

Suggested topics

Community details

16
Online
124.0k
Users
21.3k
Topics
110.0k
Posts