Welcome to discussions

Quick Suggestions

  • Badmotrfinger
    2 posts

    Can anyone try this and see if it works for them, too? It seems too simple, but, while in-game, change window mode to borderless, apply, save. Then change back to full screen, apply, save. I don't know why but it seems to fix the issue for me consistently. Is it just me?

  • Radi3nt
    16 posts

    @badmotrfinger Nope, doesn't work unfortunately.

  • peterlaub
    Original poster 61 posts

    @radi3nt
    Yup, tried it too. Dosen't work 😞

  • EasyTarget2kill
    8 posts

    I'm having the same issue. I get around average of 22 fps. What I did notice is as soon as I launch the game my cpu core speed drops to 3.7 Ghz. Then once I get in the menus it drops to 800Mhz. The core speeds stay this way even after exiting the game. The only way to get my cpu to operate right again is to restart my pc. This only happens with AC Valhalla. The game is messing with the CPU somehow.

    I7 8700k Stock
    RTX 3080
    Mem 16gig

  • Badmotrfinger
    2 posts

    @radi3nt Damn, that's why I was hesitant to post it, but it worked for me multiple times so I figured maybe I was onto something.

  • ShockB0lt
    13 posts

    @Ubi-Raziel

    Hi there

    Dx Diag https://easyupload.io/uax4wp

    Settings:
    undefined

    undefined

    For translation : Muito alto = Very High
    Alto = High
    Ligado = On
    Desligado = Off

    Usage:
    undefined
    I forgot to put Minimum and maximum usages, but it just stays within the 55% - 65% range.

    i also used to have steady 50-55 fps on this settings, and very rarely it would go below that, but after this patch i can't get more than 30 fps in big cities. Thanks

  • EasyTarget2kill
    8 posts

    undefinedundefined

    This is how bad its playing. Core speed goes to 800Mhz. I know my drivers are not up to the latest. I rolled them back to see if it helped but didn't make any difference. Guess I cut off the FPS but its setting at 26 fps.


  • longjohn119
    546 posts

    @easytarget2kill

    800 MHZ ..... wasn't that the clock speed for the Pentium 4 circa 2001?

    I'm tellin' ya all that is wrong here is someone missed setting a compiler switch when the recompiled the EXE ...... All they need to do is go back and double check their compiler settings, find the setting(s) they missed or set wrong and recompile the EXE ...... FFS I'm a hardware engineer and I know how this stuff works ......

    And I'm not buying they can't reproduce this problem because as far as I can tell it affects ALL Intel CPUs

  • TyranusVader
    106 posts

    @longjohn119 It seems the common hardware involved are PCs with Intel CPUs and Geforce GPUs.

  • BIG_BOSS_S.
    10 posts

    performance and graphics get worse every update. when this game first released it looked and ran beautfully on 4k. now it runs like crap with erractic dips in fps also looks like they added film grain or made the textures and lod blurrier. looks like crap.
    just walking through the countryside was drop dead gorgeous now the colors looked washed and blurry/grainy and performance is just straight trash.



    and the yule festival just makes it even worse. holy crap fps dropped to 1fps. wth!

    i9-7920x oc 4.4ghz
    2080rtx
    32gb ram @3200mhz
    nvme ssd

  • askikatasky
    1 posts

    Same problem here, ryzen 7 3700x and rtx 2070. All troubles after 1.1.0 patch (yule festival bonfire is an fps tank).

  • yaceek
    1 posts

    This is getting ridiculous guys.
    You probably had multiple instances of this happening to people but I have all the updates, all drivers up to date and it still, even after these months since release, stutters after 30min of playing.

    How does it happen?
    You fire up Valhalla, get into the game and everything is peachy - mostly stable 60 fps and nothing bothers me.
    After a while (20-30-1h) it starts dropping FPS into 300ms frametime territory. And the only thing I can do is to restart the game to have stable 60 fps. In the same place that stutters occured!
    I'm getting sick of it. Any ideas? GUYS!

  • EasyTarget2kill
    8 posts

    Found out on my issue that my cpu is being power limit throttled. Every Ubisoft game causes this. Other games don't. My TDP will only go to 11w and no higher. I have a i7 8700k at stock settings at the moment.
    Does Ubisoft want us all to upgrade to AMD?

  • AllianceStuck
    156 posts

    @askikatasky the new patch killed my fps and I'm using an rtx 3070

  • Snt.Grem
    27 posts

    Well, it's funny, don't you think? How could such a serious team like UBISOFT release such a patch without being able to rollback?

    I bought the Ultimate Edition for a lot of money for my region. I enjoyed the game for 90 hours and now I just can't play it, I can't get the money back and the development team that spoiled the game for me is unable to reproduce this problem.

    The frame rate even at "high" settings drops to incredible values, even in the open field I can not get smooth gameplay.


    spoiler

    https://drive.google.com/file/d/1piaVmBGbxJyA5ZjMkrnxwQLlQBFAmsPi/view?usp=sharing - DxDiag.txt


    But before the patch, I played at the highest possible settings under vertical sync, and even in the most difficult scenes, my FPS was stable at 60.

    Good job!

  • ryankwaker
    38 posts

    @Ubi-Raziel okay, so here I go

    diag: https://drive.google.com/file/d/1fak_ziHQmrReGCBj1X2th-9zG6mXj-I1/view?usp=sharing

    settings and fps: FHD and MID HIGH OPTION
    undefinedundefinedundefined

  • ryankwaker
    38 posts

    @ubi-raziel so that means it will be done before Christmas comes? Anyway, thank you for the response and support!!!

  • MitouZ
    2 posts

    Hi
    Im playing on Series X and i can definitely feels the game is not smooth since 1.1 and Yule's Festival update.

    I got constant stuttering in villages, Before the patch the game was smooth 90% of the time.

    I got more popin and VRR seems useless now.

    I can say thats not only related to PC version of the game...

    And i got one more issues now : when i load a game or when i revive, Eivor is drunked. I've to talk to a NPC to get Eivor back to normal...

    Broken update. Fix it Ubisoft !

  • TChris96
    14 posts

    @snt-grem They actually have everything neccessary to do a rollback since they presumably use some version-control system. The main pont is that they do not want to and that is what the problem is.

  • PHLFANJAN
    2 posts

    I can't provide a Dxdiag or settings because I am already away for Christmas, but I can confirm that I am having the same issue. I have a fairly low end rig for today's standards (GTX 1060 6GB, i5-4670k, 8GB of really slow DDR3 RAM, and a SATA SSD) but until the new patch came out the games was still running at a decent 60FPS most of the time, with pretty high settings in 1080p.

    As everyone already said, issue is simply that the CPU is not utilized properly anymore. My CPU doesn't go above 50% usage anymore and FPS are awful. I am REALLY disappointed in Ubi. This better be fixed before the Christmas holidays start.

Suggested Topics

Community Details

26
Online
138.8k
Users
24.3k
Topics
125.8k
Posts