Welcome to discussions

Quick Suggestions

  • 64 Likes/1108 Replies/34000 Views
    1 posts

    @ubikobold Hi, thank you for your reply. Apart from the gameplay recording, is there anything else you might need to troubleshoot the issue? I can spare an hour collecting whatever you need for troubleshooting. I play the PC version, and the game used to work fine before the patch 1.0.4, but now I get constant frame drops, I tried:

    • Verifying game files
    • Installing the game to another SSD disk
    • Re-installing the latest GeForce driver 457.50
    • Updating Windows 10 to 20H2, installing all updates
    • Setting the graphics card settings to default
    • Setting the graphics settings to default
    • Doing a "clean" Windows boot
    • Playing with keyboard/mouse instead of a controller (Xbox One controller via Bluetooth sometimes causes some imput lags).

    I also checked other games, including Ubisoft's Far Cry 5, they all run flawlessly, but not Valhalla 😞 Tonight, I will install the new graphics driver 457.50 and record a video. However, I am totally sure that the problem is not in my PC, and please let me know what information might help your team to investigate this issue. Thank you in advance.

  • YazX_
    143 posts
    @diegogamer97 I have a 3080 and the game ran fine up until today. Now I get 33 fps. Its laughable but sadly its typical Ubisoft.

    i believe your GPU is not working on the frequency that it should, check GPU usage and frequency in game, sometimes GPU frequency gets stuck on low especially if you have power mode set to adaptive in NCP, i had this problem on my old build where whenever i wake my PC from sleep, GPU starts with low frequency and sometimes gets stuck on that frequency until i restart.

  • Amothan1800
    1 posts


    Hi have the same issue like the other guys....

  • QuaWua232
    2 posts

    I have some three solutions that might help:

    1. Disable fullscreen optimalization (in compatibility tab)
    2. Disable Windows Game bar
    3. Launch ACValhalla_Plus.exe (instead of the normal one)

    Good luck with that and I hope some of these will work for you.

  • UbiKobold
    Ubisoft Support Staff 533 posts

    Hello again everyone! Thank you for your continued patience. The Game team is currently investigating these FPS drops in the game. If you are using GeForce Now, please contact GeForce Now Support for some additional troubleshooting. However, if not, please create a ticket and attach your MSinfo and DxDiag files. Then provide your ticket number here and I can review the files.

    Official Response
  • WarlordSpinal
    5 posts
    This post is deleted!
  • MeowNuts
    9 posts

    1.10 broke my framerate. Cpu utilization drop from 100% to 50%. Thats for sure. GPU not too sure.

    My fps dropped by 30-50%. Thank you Ubisoft for the wonderful christmas gift by making the game unplayable. I hope you guys enjoy yr christmas.

  • XPS74
    5 posts

    I have exactly the same problem. I didn't change anything, no drivers etc. and played yesterday just fine. Today after Patch 1.1.0 i instantly noticed FPS drops and pressed F1 to ckeck. CPU utilization sits around 50% (before 80-99%) Where only Core 0 and 1 used most and core 2 and 3 only around 15-25%. This update broke the good performance i had. Luckily i am not the only one.

  • AllianceStuck
    156 posts
    This post is deleted!
  • stormPD
    3 posts

    Same here, FPS visually dropped 😕

    GPU: GTX1070
    CPU: i5-4690
    Ram: 16GB DDR3

  • ripkit
    4 posts

    How can I roll back to 1.0.4? It was good performance on GTX1060 and 3570k and 16GB DDR3. Since 1.1.0 the performance is disgusting.
    Got 30fps in the same setting. Is that mainstream to decrease performance like CDPR do?

  • TChris96
    14 posts

    Same for me. I just updated my game on PC to 1.10. The patch log is great, lot of things fixed but also I have 30 fps less then before the patch came out. I'm palying on high-mid setting and I so far I got easily 55-75 fps in the game, with a little stuttering here and there and when I did a benchmark the CPU and GPU usage was close to 100% (as it should be). Now these numbers reduced to 50% CPU usage on all of the cores and only 60% GPU usage therefore I get a lot less frames per second.

    I tried reinstalling the game, verifying the game files, restarting my computer multiple times, updating to the newest nVidia driver (came out for Cyberpunk) with no luck so far. I tried to mess with the config file, deleting the config file, resetting the game settings and setting it up again with no considerable change. The usage percentages are the same. I also tried setting everything to low and trying a lower resolution but my FPS was still way pooerer than it should've been and the game wasn't using my hardware as much as it could.

    I really don't have any more ideas about what I can do to solve this matter. Maybe I have to wait for the next patch which is kind of a bummer because I just took out my holiday leave days from work and I have lots of free time for gaming.

    @ripkit Unfortunately you can not rollback for 1.0.4, we have to wait for the next update or until the Ubisoft team fixis the issue.

    Intel Core i5 4670k, overclocked to 4.0Ghz
    Nvidia GeForce GTX 1060 6GB OC
    16 GB DDR3 RAM
    Latest nvidia and Windows 10 drivers

  • UbiKoreanBBQ
    Ubisoft Support Staff 201 posts

    @peterlaub Hey, I am so sorry to hear you're experiencing this after the patch! Can you let me know if when you start a session, it is at 60 FPS and then drops to 35 FPS at a different time? Or is it consistently 35 FPS now? I'd like to see a screenshot of your benchmark please! Thank you.

    Official Response
  • UbiKoreanBBQ
    Ubisoft Support Staff 201 posts

    @meownuts I'm very sorry to hear this is happening! Please share a screenshot of your benchmark if you can. Can you let me know what graphic setting you're using? And what your normal FPS was at prior?

    Official Response
  • UbiKoreanBBQ
    Ubisoft Support Staff 201 posts

    @xps74 Hello! My deepest apologies to see this is happening after the patch. Can you share a screenshot of your benchmark numbers please? Also, for starters, please let me know your system specs:



    Official Response
  • UbiKoreanBBQ
    Ubisoft Support Staff 201 posts

    @stormpd I'm so sorry to hear about this. What was your FPS before the patch and afterwards? Can you send me a screenshot of your benchmark results? Also, are you seeing the drop immediately upon playing, or does it start at it's original value and then drop over time?

    Official Response
  • UbiKoreanBBQ
    Ubisoft Support Staff 201 posts

    @tchris96 Hey there, I really appreciate your detailed comment on this issue. The team is currently investigating these severe FPS drops. Would you kindly share a screenshot of your benchmark results with me?

    Official Response
  • UbiKoreanBBQ
    Ubisoft Support Staff 201 posts

    @ripkit Hey there, it's not possible to rollback patches, however the team is looking into this issue. Can you let me know what your FPS was at before the patch?

    Official Response
  • Radi3nt
    16 posts

    Confirm framerate is tanked from 70 FPS to 30-40 FPS.

    RTX 2070S

    The game was fine for the first 20 minutes that I played today (roughly 3 hours after patch drop), but then suddenly the FPS tanked and hasn't recovered since. Now, the game is consistently at below 30 FPS in town and cities, around 40-50 outside no matter what I do. Before this, I had consistent 60-80 FPS everywhere. Highly suspect it's server related. I've tried:

    1. Installing latest Nvidia Driver.
    2. Restart PC.
    3. Fast Traveling to different towns and cities. FPS drops confirmed in places where the FPS used to be upper 60 FPS.

    Here is the performance report in Ravensthrope:


  • XPS74
    5 posts

    Hi and thank you for responding. My specs are in the screenshot.


Suggested Topics

Community Details