Welcome to discussions

Quick Suggestions

  • UNSOLVED [PC] After TU 1.1.0, I am experiencing FPS drops / low CPU and GPU utilisation | POST HERE

    64 Likes/1284 Replies/41448 Views
    TemoshGangPower
    5 posts

    Ubisoft, maybe you try to cooperate with Nvidia to resolve this problem? Many users are experiencing issue what ruin all pleasure of the game! 

    Don't you give a damn about us?
    😠 😠 😠

  • UbiKobold
    Ubisoft Support Staff 673 posts

    Hey there fellow gamers, and thank you for your patience! I am very sorry that all of you have been experiencing FPS drops after about an hour of gameplay! I have a few questions and some steps to try, if you all wouldn't mind taking a look!

    1. Are you using GeForce Now?
    2. Have you tried verifying your game files?
    3. If not tried yet, please try our steps here.
    4. Can you provide a video of this occurring from your gameplay? If so, post to YouTube as unlisted and then send the link here.


    Official Response
  • Plan3tCrackr
    46 posts

    @icewolf75 My 2700X runs at maybe 40% max in benchmark. However, I'm not sure how trusting the benchmark is as it shows certain selected parameters as OFF even if they are enabled. If the benchmark is meant to run with these parameters only OFF then that defeats the purpose of even listing the parameter in the benchmark. It is probably fine for baseline testing if always using the same parameters. Nice choice in CPU.

  • TemoshGangPower
    5 posts

    @ubikobold
    Yes, we using Geforce Now. Therefore we can't verify our game files.

    Here's a link on my gameplay with fps drops proof -

  • IceWolf75
    4 posts

    @plan3tcrackr
    But... isn't the main purpose of a benchmark to push the system to its limits? I can't complain about the performance of the game, it runs good enough but why keeping the CPU underutilized even in benchmark which suppose to measure the raw performance to assess what's keeping up and what's not or to compare?
    Thank you for appreciation of my choice, it's my first AMD after 14 years of Intel. My old 7700K was old enough and it dragged the RTX 3080 down quite a bit.

  • Plan3tCrackr
    46 posts

    @icewolf75 16 threads 5800X vs 8 threads 7700k. What resolution are you playing and with what GPU?

  • se7enX89X
    5 posts

    @diegogamer97 I have a 3080 and the game ran fine up until today. Now I get 33 fps. Its laughable but sadly its typical Ubisoft.

  • IceWolf75
    4 posts

    @plan3tcrackr 2560x1080 Ultra settings

  • TemoshGangPower
    5 posts

    So, whats next? Are you confirm this problem? Can we expect a fix soon?

  • dgeynisman
    1 posts

    @ubikobold Hi, thank you for your reply. Apart from the gameplay recording, is there anything else you might need to troubleshoot the issue? I can spare an hour collecting whatever you need for troubleshooting. I play the PC version, and the game used to work fine before the patch 1.0.4, but now I get constant frame drops, I tried:

    • Verifying game files
    • Installing the game to another SSD disk
    • Re-installing the latest GeForce driver 457.50
    • Updating Windows 10 to 20H2, installing all updates
    • Setting the graphics card settings to default
    • Setting the graphics settings to default
    • Doing a "clean" Windows boot
    • Playing with keyboard/mouse instead of a controller (Xbox One controller via Bluetooth sometimes causes some imput lags).


    I also checked other games, including Ubisoft's Far Cry 5, they all run flawlessly, but not Valhalla 😞 Tonight, I will install the new graphics driver 457.50 and record a video. However, I am totally sure that the problem is not in my PC, and please let me know what information might help your team to investigate this issue. Thank you in advance.

  • YazX_
    172 posts
    @diegogamer97 I have a 3080 and the game ran fine up until today. Now I get 33 fps. Its laughable but sadly its typical Ubisoft.


    i believe your GPU is not working on the frequency that it should, check GPU usage and frequency in game, sometimes GPU frequency gets stuck on low especially if you have power mode set to adaptive in NCP, i had this problem on my old build where whenever i wake my PC from sleep, GPU starts with low frequency and sometimes gets stuck on that frequency until i restart.

  • Amothan1800
    1 posts

    @ubikobold

    Hi have the same issue like the other guys....

  • QuaWua232
    2 posts

    Hello,
    I have some three solutions that might help:

    1. Disable fullscreen optimalization (in compatibility tab)
    2. Disable Windows Game bar
    3. Launch ACValhalla_Plus.exe (instead of the normal one)


    Good luck with that and I hope some of these will work for you.

  • AllianceStuck
    156 posts

    Can't even get 60fps at 1440p with an rtx 3070 but meanwhile an RX 5700 is matching the performance of the rtx 3070. Lol

    How can an RX 5700 match the performance of the rtx 3070 in valhalla but in other games the 3070 is 35-40% faster than the RX 5700.

  • Quor321
    232 posts

    I'm running a 2070 in 4k with no problem. Only issue is my monitor, have to run at 30 fps along with a few other adjustment to make it run smooth and beautiful. More often then not it's an user error or hardware not the game. Takes more then a GPU to make a game run smoothly.

  • AllianceStuck
    156 posts

    @quor321 I'm running on ultra settings brah

  • DaelosTheCat
    167 posts

    I couldn't disagree with you more. I started playing at 3440x1440p with a GTX 1080 Ti. All settings maxed out with only Resolution Scaling at 80% and I was getting stable 50-60 FPS. Was actually surprised with how well it ran. And then I upgraded to a RTX 3090 🙂

  • Quor321
    232 posts

    @alliancestuck Maybe that's your problem dude. I can run at max too, runs good most of the time but I do run into issues now and then. So I turned it down some and all smooth now and still looks amazing.

  • AllianceStuck
    156 posts

    @quor321 I didn't spend $500 on a gpu to play on anything but ultra settings

  • Akira1364
    118 posts

    @daelosthecat I mean, you were just playing at 2752 x 1152 then...

Suggested Topics