Continue your odyssey

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • Guttzor
    5 posts

    @ubikoreanbbq Can confirm same issue. I played the game for the first time yesterday and configured to the below settings to get FPS I was happy with - AVG 70 or so. Now getting AVG 46 on benchmark. CPU dropping below 40% usage at times. Never above 50%. Just to note I installed latest Nvidia driver today - 460.89. Screens belowundefinedundefinedundefined

  • UbiKoreanBBQ
    Ubisoft Support Staff 184 posts

    @xps74 Thank you for providing this! I'm passing it on to the team for their investigation.

    Official Response
  • UbiKoreanBBQ
    Ubisoft Support Staff 184 posts

    @radi3nt Hey there, I super appreciate you bringing forward the screenshots and detailed description of your experience, but I am truly sorry that it is happening in the first place. The team is currently investigating this, and I'll be passing your information to them!

    Official Response
  • Janiya1013
    27 posts

    This has done nothing for me.12/15. I have two quest that appear to be glitching to the point it doesn't allow yu to complete them.in dreams and of blood and bonds.leaving me unable to progress farer in the main story.i love this game but would yu please fix this.

  • UbiKoreanBBQ
    Ubisoft Support Staff 184 posts

    @guttzor Hey! Thank you for these screenshots and explanation! Does the game start at 70 fps upon launch, and then drop to 46 or so shortly after? Or is it stating at the lower number to start with?

    Official Response
  • UbiKoreanBBQ
    Ubisoft Support Staff 184 posts

    @janiya1013 Hey there, I believe you might be posting in the wrong thread. Are you experiencing FPS drops right now in addition to your progression issue?

    Official Response
  • Guttzor
    5 posts

    @ubikoreanbbq It hit 35 in the loading screen with the character then creeps up in benchmark but doesn't get above 50 fps .

  • ripkit
    4 posts

    @ubikoreanbbq I have medium settings + high textures and low volumetric clouds. I had 55-60 fps on my hardware in 1.0.4 verison (i5 3570k and GTX1060). Now it's 30 fps.

  • ripkit
    4 posts

    CPU AVG load is about 70%. It was 55-65fps in 1.0.4
    undefined

  • larrykop1967
    65 posts

    I went back to the Nvidia release driver for Valhalla 457.30 and my fps issues that i was having with the new drivers stopped, i was getting stuttering when loading area's in and fps drops here and there as well with both newer drivers from Nvidia,

  • KAZU9G
    1 posts

    Having the same problem here very noticeable. Before the patch my average fps is about 60-70 at high setting and it drop to 45-50 after

  • peterlaub
    Original poster 61 posts

    @ubikoreanbbq
    Thanks for replying.
    The session starts with low FPS, and ends with low FPS.
    My settings are custom, but I put everthing at high, except anti-aliasing

    undefined

  • longjohn119
    431 posts

    Could a couple of you (preferably one Intel and one AMD CPU) run a benchmark and include the CPU graph? Just judging by the CPU numbers it looks like it's hitching like a MFer ..... While the GPU numbers are fairly consistent ..... Others are also reporting that it's not using all the cores but you'd have to log it in Afterburner or similar to check for that ......

    These simple charts don't really provide enough information but it looks to me like a CPU not a GPU problem

  • Divados1990
    1 posts

    I can confirm this. GPU % is all over the place jumping from 0-100% constantly. CPU % is more stable but about 20% lower than before the update.

  • TChris96
    14 posts

    @ubikoreanbbq Yes, here is the screenshot of the official game benchmark. Before the update I was averaging arount 65 fps, now 45. CPU usage during the benchmark is 50% on all cores and the GPU usage is around 60% percent while with the previous version both were close to and equal to 100% percent hence the better performance then.
    undefined

  • peterlaub
    Original poster 61 posts

    @longjohn119
    I also think is with the CPU
    undefined

    undefined

  • TChris96
    14 posts

    @peterlaub Yeah actually if the CPU is not running on 100% the video card also can't. These percentages are same as mine. Game is literally unplayable from 1.10.

  • BlainKaramel
    1 posts

    only my fourth core is at 100% the rest are are barely being used
    i5 3570k gtx 1060undefined

  • TChris96
    14 posts

    More detailed picture CPU cores only running arount 60%, core1 only at 39%, GPU only at 60% whereas before the patch everyting ran on 100%, fps avarage is 39, significantly lower than before the patch released. Memory usage only 5 GB, before the patch this was much more too. Hotfix needed quick, game is unplayable.
    undefined
    Specs:
    GTX 1060 6GB OC
    Intel Core i5 4670k 4.0Ghz
    16 GB DDR3 RAM

  • longjohn119
    431 posts

    @tchris96
    My bad I forgot they changed the benchmark and no longer show the separate GPU and CPU charts nor do they let you compare with your last benchmark so you can see the difference after an update like they did with Odyssey ..... No sense keeping anything that was actually useful in benchmark

    However I downloaded the game again and and then played through a quick side quest or whatever they call them now including a little bit of a boat trip and riding my horse and I couldn't reproduce the problem on my 3700X/RTX 2080 Super .... I don't know if a fresh install made any difference but I did notice anytime I put the cursor over a photo I took I'd get an "online service error" so that damned Connect app is still buggy and who knows how much problems it's causing still

    I did notice that the Aim Assist sort of works but only on animals not humans .... It will snap right to a snake or a deer or even one of the camp dogs (no I didn't shoot the dog) but the little quest or event or whatever they call it took me to a small bandit? camp and I couldn't get a lock on the enemy or get it to snap to them if they were in front of me like it does with animals .....

    I really want to like this game but I just don't , it's just so frustrating after all the hours I sunk into Odyssey that I can't play it the way I'd like to

Suggested topics

Community details

20
Online
125.5k
Users
21.7k
Topics
111.8k
Posts