Continue your odyssey

Welcome to discussion

Welcome to discussion

Quick Suggestions

Hello! These new forums are an open beta and we welcome your feedback in this section.
  • ShockB0lt
    13 posts

    At least now we have a good shot on what the problem is (CPUs that do not support Hyperthreading), those of us who still have a little patience left must try once again to make this information get to the developers.

  • AnolinMcGinnis
    17 posts

    So Hyperthreading, eh?

    Here's a benchmark with my 9900k with HT on:

    undefined

    Here's with HT off:

    undefined


    While HT was on, like I said, only core [1] would hit 50%, while the rest sat there at 23%'ish. With HT OFF, all cores were at 50%'ish, but as you can see, the benchmark results are within the margin of error. So I think something else is going on.

  • Radi3nt
    16 posts

    @anolinmcginnis Lmao with today update, even with HT my game has once again dropped back to the 30-40 FPS range from 60-70 FPS just a few days ago. What a joke.
    Should've figured out the HT issue and finish this game before this patch hit.

  • Radi3nt
    16 posts

    @radi3nt Edit: I restarted my PC and the FPS was gone. I suspect the game just has stability issue in general.

  • longjohn119
    494 posts
    So Hyperthreading, eh?

    Here's a benchmark with my 9900k with HT on:

    undefined

    Here's with HT off:

    undefined


    While HT was on, like I said, only core [1] would hit 50%, while the rest sat there at 23%'ish. With HT OFF, all cores were at 50%'ish, but as you can see, the benchmark results are within the margin of error. So I think something else is going on.


    You can likely cut those spikes by 50% by turning down Volumetric Clouds a notch .... For some reason the highest setting causes hitching

    Here is what mine looks like, everything cranked except Volumetric clouds down a notch and Depth of Field off

    undefined

  • longjohn119
    494 posts

    @longjohn119 Here is a video of the benchmark in progress .... All settings at highest except Volumetric clouds down a notch and Depth of Field off .... It's only rendered to 1080p and will probably take a day before it's a full 1440p (YouTube is slooww these days) but it should be clear enough to see the core/thread usage

  • ruanseth
    32 posts

    I'm seeing even worse performance with 1.1.2. Before I updated I selected an area and noted the frame rates and then saved, and then did the same post patch... With 1.1.1 I was getting an average of 49fps based on the last 30 seconds of play, and now I'm getting an average of 43fps. Benchmark result shows much the same. Even CPU utilisation seems a few % lower, regularly dropping well below 50% across four, non hyperthreaded cores. GPU utilisation is 93-99%.

    So I give up. I will not support Ubisoft from this point on. They damaged performance badly with patch 1.1.0 and seem unable or unwilling to investigate properly and set this right. Just looking at the vast amount of persistent bugs being reported here I would say this game is almost as big a mess as Cyberpunk... the difference is I bet eventually CP with end up being fixed, and this will not. Plus, you could get a refund.

    I'm not going to start shouting, swearing and calling the staff names as some do, as it does no good whatsoever, but I am fed up that one of the best game I've played in years has been ruined and the company response has been so poor.

  • longjohn119
    494 posts

    @longjohn119 Just for comparison this is Odyssey using the same basic settings, everything cranked to max except Volumetric Clouds turned down a notch and Depth of Field off. You can see it's a lot less spiky and the first CPU spike and the two smaller ones don't have a corresponding spike in the GPU graph which indicates a hitching problem with the CPU although in the case of Odyssey it's less prevalent and not really noticeable in gameplay ..... Odyssey does have about 10% better framerates

    I'm not so sure it's actually a CPU utilization or SMT/Hyperthreading problem but perhaps an asset streaming problem but I'm not really seeing it on my system so I can't analyze it but you can see the CPU usage in Valhalla seldom goes over 50% except in small bursts and only one or two threads/cores on a system that is working properly .... Of course your results will vary if you have fewer cores/threads




  • dodokjv
    21 posts

    Well i just found out something that improved stability for me. I didnt want to update the game so i played offline and fps was better. I locked the game at 30 because i have [censored] 1060 3gb, and now in raids i get between 27-30 fps instead of low 20s. Thats pretty playable for me so i hope i can finally play and finish the game.

    Maybe some of you can also try going offline. CPU utilization is still at about 50% but maybe youll experience less drops.

  • peterlaub
    Original poster 61 posts

    @dodokjv
    I triede going offline, I didn't work for me 😞

  • TheHumanSpectre
    4 posts

    After update I came back to check the situation and seems like it doesn't seem playable yet. I've bought and refunded the game almost 2 months ago but still checking this topic every week to hear some good news. It's really shame that they couldn't fix it yet. Meanwhile I've played few games including Metal Gear Solid 5 and Red Dead Redemption 2. Thanks Ubisoft(and CDPR) for letting me play this games. MGS had great stealth gameplay and RDR 2 is a masterpiece I recommend both of them. Both of them caused me no trouble and had decent perfomance. Anyway I'll still buy this game again but doesn't seem anytime soon. I hope they'll fix this game because I want to play it.

  • UbiKobold
    Ubisoft Support Staff 531 posts

    Hey there everyone. Thank you all for your continued updates on this issue! We have been continuing to forward up the information you all have been providing to further assist the Game team with their investigation. I have provided below two workarounds that others in the community have suggested recently, that have helped to improve their gameplay for the time being.

    • test your game in offline mode
    • test your game with and without hyperthreading


    Thank you again for your patience as the investigation continues. Please keep an eye out for further updates and information.

    Official Response
  • Smiley_ie
    5 posts

    Hyperthreading on / off and offline get the same low CPU usage
    undefined

  • longjohn119
    494 posts

    @smiley_ie Yeah I'd say that is a pretty disappointing result given your hardware ..... You have more cores and threads than I do plus a 900 Mhz higher boost frequency compared to my 3700X plus a 3090 compared to my 2080 Super and you are only getting a whole 4 more FPS than I am ...... I know this game engine never scaled up very well but that is ridiculous You likely have 20-25% more power but are only getting about a 5-6% increase in FPS ..... That is some pretty poor scaling

    @thehumanspectre I'm with you brother although I kept my copy since I got it when I bought a 3700X last July ..... I'm not playing the game other than coming in a running some tests after an update ..... I hate playing buggy games with a passion so I'll just play other games until this and Cyberpunk are fixed and relatively bug free ..... Maybe by June or July lolol

  • longjohn119
    494 posts
    This post is deleted!
  • Snt.Grem
    24 posts

    @ubikobold, you are not competent! You are useless! Nobody believes your empty comments.

    Look at this! The comment we deserve for 3 months of waiting...

  • Ubi-Woofer
    Ubisoft Support Staff 713 posts

    Hello everyone,

    I fully appreciate that this thread concerning FPS drops on PC after TU 1.1.0 has been open for some time, and we are doing all we can here on the support team to pass forward the relevant information and keep you updated with the latest news from the developers' investigations. It is not a topic we are ignoring, and I'd like to reassure you that everyone involved is doing what they can to identify the cause of these issues and improve performance on PC.

    The information the developers still would like to gather from affected players is as follows -

    • MSINFO and DXDIAG files for analysis (exported in a .txt format)
    • Screenshots of your preferred graphical settings
    • Screenshots of your CPU and GPU usage while running the benchmark (this can be through any supported software for your hardware, or programs such as Rivatuner Statistics Server)


    These documents and images should be submitted via a support case or Live Chat, so that we can both track reports and also easily pass information between the relevant teams involved in the ongoing investigations into the game's performance on PC. Once your case is open, please write the reference number here in the thread so that we can gather the relevant documents and images and forward them. 🙂

    I am truly sorry that we do not have more information to share for the moment, but rest assured we'll be back with news as soon as we have any to share.

    @Snt-Grem - I appreciate that this issue has been ongoing for some time, and my colleagues (such as @UbiKobold and @Ubi-Raziel) and myself are doing our best to keep everyone here updated. We are doing what we can to ensure the swift passage of information between players such as yourself and the developers working on this issue. Thank you for your patience, and rest assured this isn't an issue we are ignoring.

    Official Response
  • peterlaub
    Original poster 61 posts

    Here ya go. Again.. again.. once more 🙂

  • T1GFX
    33 posts

    @ubi-woofer https://support.ubisoft.com/en-US/Cases/13807427

    I hope the team doesn't mind a zippyshare link since the archive of attached evidence does not want to upload to your servers.

  • AnolinMcGinnis
    17 posts

    @ubi-woofer @UbiKobold

    Nope, not doing to bother with opening a ticket, and submitting all that info you requested when there are plenty of screenshots and dxdiag/msinfo32 here to prove it.

    And besides, please don't tell me the developers of the game don't have access to similar hardware that both myself and others are reportedly using. If you can't reproduce this in house by simply turning off/on Hyperthreading in the BIOS, then something is pretty wrong with your development team.

    Finally - what's the point? Look how long it takes for them to push out updates! Remember the Yule event and how EVERYONE'S Evior loaded in drunk?! We had to wait until the next patch to fix something simple like that. And now there are NEW bugs with River Raids, downgraded weapons, quests that are STILL broken, so I think that I'll just uninstall AC Valhalla and come back to it February 2022 when it's finally ready to be played.

Suggested Topics

Community Details

59
Online
130.5k
Users
22.6k
Topics
117.2k
Posts